Bug 1161732 - Network monitoring is broken with KSysGuard
Network monitoring is broken with KSysGuard
Status: RESOLVED DUPLICATE of bug 1151190
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: KDE Workspace (Plasma)
Current
All openSUSE Factory
: P5 - None : Normal (vote)
: ---
Assigned To: E-Mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-01-23 21:50 UTC by Artem Labazov
Modified: 2020-01-24 14:05 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Artem Labazov 2020-01-23 21:50:00 UTC
On Tumbleweed with KDE Plasma 5.17.90 from openSUSE Factory columns "Download" and "Upload" in KSysGuard are empty.

Launching it from terminal shows the following output:
> org.kde.ksysguard.plugin.network: Helper process terminated abnormally!
> org.kde.ksysguard.plugin.network: "The process doesn't have permission to open the capture source\n"

Running "setcap cap_net_raw+ep /usr/lib64/libexec/ksysguard/ksgrd_network_helper" under root solves the mentioned issue
Comment 1 Fabian Vogt 2020-01-24 14:05:27 UTC
The whitelisting of the binary in the permissions package is broken, there is a typo.

Let's continue this in the original audit bug.

*** This bug has been marked as a duplicate of bug 1151190 ***