Bug 1161687 - [Build 20200121] openQA test fails in yast2_nfs_client: YaST breaks rpcbind.socket
[Build 20200121] openQA test fails in yast2_nfs_client: YaST breaks rpcbind.s...
Status: RESOLVED FIXED
: 1161804 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: YaST Team
Jiri Srain
https://openqa.opensuse.org/tests/115...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-01-23 12:11 UTC by Fabian Vogt
Modified: 2021-12-14 10:35 UTC (History)
6 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
YaST logs (from the assets page) (6.61 MB, application/x-bzip)
2020-01-23 12:11 UTC, Fabian Vogt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian Vogt 2020-01-23 12:11:39 UTC
Created attachment 828155 [details]
YaST logs (from the assets page)

From journal.txt:

Jan 23 05:56:58 susetest systemd[2559]: rpcbind.socket: Failed to create listening socket (0.0.0.0:111): Address already in use
Jan 23 05:56:58 susetest systemd[1]: rpcbind.socket: Failed to receive listening socket (0.0.0.0:111): Input/output error
Jan 23 05:56:58 susetest systemd[1]: rpcbind.socket: Failed to listen on sockets: Input/output error
Jan 23 05:56:58 susetest systemd[1]: rpcbind.socket: Failed with result 'resources'.
Jan 23 05:56:58 susetest systemd[1]: Failed to listen on RPCbind Server Activation Socket.
Jan 23 05:56:58 susetest systemd[1]: Dependency failed for RPC Bind.
Jan 23 05:56:58 susetest systemd[1]: rpcbind.service: Job rpcbind.service/start failed with result 'dependency'.

This is apparently caused by YaST starting /sbin/rpcbind itself, circumventing systemd:

2020-01-23 05:56:57 <1> susetest(2393) [libstorage] SystemCmd.cc:69 constructor SystemCmd("/sbin/rpcbind")
2020-01-23 05:56:57 <1> susetest(2393) [libstorage] SystemCmd.cc:188 SystemCmd Executing:"/sbin/rpcbind"

This binds to the port and is not killed before attempting to start rpcbind.socket.

## Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-yast2_nfs_v3_client@64bit fails in
[yast2_nfs_client](https://openqa.opensuse.org/tests/1152736/modules/yast2_nfs_client/steps/46)

## Test suite description
NFS multi-machine test suite. Maintainer jrivrain@suse.com


## Reproducible

Fails since (at least) Build [20200120](https://openqa.opensuse.org/tests/1151100)


## Expected result

Last good: [20200119](https://openqa.opensuse.org/tests/1150542) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?arch=x86_64&distri=opensuse&flavor=DVD&machine=64bit&test=yast2_nfs_v3_client&version=Tumbleweed)
Comment 1 Ancor Gonzalez Sosa 2020-01-24 11:36:49 UTC
Also reported by Jozef by reopening bug#1151426.

Let's track everything here. For that, I'm copying Jozef observations here:

> With yast2-nfs-client-4.1.7 https://smelt.suse.de/request/209869/ is Y2DEBUG=1 > ZYPP_MEDIA_CURL_DEBUG=1 yast2 nfs-client module failing with pop-up Cannot > start 'rpcbind' service
> 
> ● rpcbind.socket - RPCbind Server Activation Socket
>    Loaded: loaded (/usr/lib/systemd/system/rpcbind.socket; enabled; vendor 
> preset: disabled)
>    Active: failed (Result: resources)
>    Listen: /run/rpcbind.sock (Stream)
>            0.0.0.0:111 (Stream)
>            0.0.0.0:111 (Datagram)
>            [::]:111 (Stream)
>            [::]:111 (Datagram)
> 
> Jan 24 03:24:41 susetest systemd[1]: rpcbind.socket: Failed to listen on
> sockets: Address already in use
> Jan 24 03:24:41 susetest systemd[1]: Failed to listen on RPCbind Server
> Activation Socket.
> Jan 24 03:24:41 susetest systemd[1]: rpcbind.socket: Unit entered failed state.

And also:

> Could not upload 13MB y2logs, uploaded it on my export.
(see the comment in the other bug for the link).
Comment 3 Ancor Gonzalez Sosa 2020-01-27 09:57:18 UTC
*** Bug 1161804 has been marked as a duplicate of this bug. ***
Comment 4 Rodion Iafarov 2020-02-04 13:45:05 UTC
Visible in SLES 15 SP2 too.
Comment 5 José Iván López González 2020-02-06 16:19:33 UTC
The problem was caused because *libstorage-ng* runs rpcbind binary without using systemd. So, from systemd point of view, rpcbind service is not active (even though there is a rpcbind process already running). Then, nfs-client tries to start rpcbind service, and it fails.

This was fixed by yast2-nfs-client 4.2.7. Now, the rpcbind process is killed before activating the systemd service.

* Maintenance Update Request: https://build.opensuse.org/request/show/770652
* Pull Request: https://github.com/yast/yast-nfs-client/pull/93
Comment 8 Swamp Workflow Management 2020-02-28 14:23:18 UTC
SUSE-RU-2020:0530-1: An update that has 6 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1006815,1060159,1149754,1151426,1156446,1161687
CVE References: 
Sources used:
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1 (src):    libstorage-ng-4.1.107-4.11.8
SUSE Linux Enterprise Module for Development Tools 15-SP1 (src):    libstorage-ng-4.1.107-4.11.8
SUSE Linux Enterprise Module for Basesystem 15-SP1 (src):    libstorage-ng-4.1.107-4.11.8, yast2-nfs-client-4.1.8-3.7.7, yast2-storage-ng-4.1.91-3.19.15
SUSE Linux Enterprise Installer 15-SP1 (src):    libstorage-ng-4.1.107-4.11.8, yast2-storage-ng-4.1.91-3.19.15

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 9 Swamp Workflow Management 2020-03-05 23:11:46 UTC
openSUSE-RU-2020:0306-1: An update that has 6 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1006815,1060159,1149754,1151426,1156446,1161687
CVE References: 
Sources used:
openSUSE Leap 15.1 (src):    libstorage-ng-4.1.107-lp151.3.9.1, yast2-nfs-client-4.1.8-lp151.2.3.1, yast2-storage-ng-4.1.91-lp151.2.12.1