Bug 1161439 - [Build 20200119] Chromium crashes on kde/wayland
[Build 20200119] Chromium crashes on kde/wayland
Status: RESOLVED WORKSFORME
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: X.Org
Current
Other Other
: P3 - Medium : Normal (vote)
: ---
Assigned To: Stefan Dirsch
E-mail List
https://openqa.opensuse.org/tests/115...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-01-21 15:11 UTC by Dominique Leuenberger
Modified: 2020-02-26 15:02 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Leuenberger 2020-01-21 15:11:30 UTC
## Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-kde-wayland@64bit_virtio fails in
[chromium](https://openqa.opensuse.org/tests/1150453/modules/chromium/steps/20)

## Test suite description
Basic KDE installation, but switches to a Wayland session on login. Needs Virtio (or similiar) GPU.


## Reproducible

Fails since (at least) Build [20200119](https://openqa.opensuse.org/tests/1149642)


## Expected result

Last good: [20200118](https://openqa.opensuse.org/tests/1148863) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?arch=x86_64&distri=opensuse&flavor=DVD&machine=64bit_virtio&test=kde-wayland&version=Tumbleweed)
Comment 1 Dominique Leuenberger 2020-01-21 15:14:27 UTC
Snapshot 0119 contained major upgrades for:

* Qt to version 5.14
* libva to version 2.6.0 (from 2.5.0)

those seem the most likely candidates to be involved in the crash
Comment 2 Fabian Vogt 2020-01-21 16:16:52 UTC
Installing libva 2.6.0 from X11:XOrg causes the crash on the latest TW snapshot as well, so the libva upgrade is most likely the culprit.

libva 2.6.1 (from home:dimstar:Factory) didn't help either.

For reference, the printed error message:

libva error: vaGetDriverNameByIndex() failed with unknown libva error, driver_name = (null)
[5464:5464:0121/171445.600117:ERROR:vaapi_wrapper.cc(422)] vaInitialize failed (ignore if using Wayland desktop environment, refer:(Github)akarshanbiswas/chromium-vaapi/issues/7): unknown libva error
Received signal 11 SEGV_MAPERR 000000000000
#0 0x565095924b66 base::debug::StackTrace::StackTrace()
#1 0x5650958d77b6 base::debug::(anonymous namespace)::StackDumpSignalHandler()
#2 0x5650958d7dbe base::debug::(anonymous namespace)::StackDumpSignalHandler()
#3 0x7ffb9b8c42d0 <unknown>
#4 0x7ffb98b8a961 __strlen_avx2
#5 0x565097a7784b media::(anonymous namespace)::VADisplayState::InitializeOnce()
#6 0x565097a77cd5 _ZN5media12_GLOBAL__N_114VADisplayState10InitializeEv.lto_priv.0
...
(repeats 9 times)
[5440:5450:0121/171447.677309:FATAL:gpu_data_manager_impl_private.cc(990)] The display compositor is frequently crashing. Goodbye.
Comment 3 Dominique Leuenberger 2020-01-21 16:22:23 UTC
libva in openSUSE:Factory was reverted to version 2.5.0 (update to 2.6.1 submitted from home:dimstar:Factory to X11:XOrg; even if it does not fix the issue, it's good to have this present and not lose the work already done)

assigning to the libva maintainer for further investigation/fixing
CC SLE maintainers of libva as well
Comment 4 Stefan Dirsch 2020-02-26 14:41:07 UTC
Just had a try with current TW/KDE using still libva 2.5.0. No crashes with chromium. As expected libva cannot work with virtio driver. So you see error messages during startup of chromium, but it starts!

XOrg Session
---------------
# chromium
libva error: va_getDriverName() failed with unknown libva error,driver_name=(null)
[2992:2992:0226/150457.010027:ERROR:vaapi_wrapper.cc(417)] vaInitialize failed: unknown libva error
[2992:2992:0226/150457.112318:ERROR:viz_main_impl.cc(161)] Exiting GPU process due to errors during initialization
libva error: va_getDriverName() failed with unknown libva error,driver_name=(null)
[3013:3013:0226/150457.240237:ERROR:vaapi_wrapper.cc(417)] vaInitialize failed: unknown libva error

# vainfo
libva info: VA-API version 1.5.0
libva info: va_getDriverName() returns -1
libva error: va_getDriverName() failed with unknown libva error,driver_name=(null)
vaInitialize failed with error code -1 (unknown libva error),exit

Wayland session
-------------------
# chromium
libva error: va_getDriverName() failed with unknown libva error,driver_name=(null)
[4212:4212:0226/153601.808107:ERROR:vaapi_wrapper.cc(417)] vaInitialize failed: unknown libva error
[4212:4212:0226/153602.060344:ERROR:viz_main_impl.cc(161)] Exiting GPU process due to errors during initialization
libva error: va_getDriverName() failed with unknown libva error,driver_name=(null)
[4404:4404:0226/154008.323373:ERROR:vaapi_wrapper.cc(417)] vaInitialize failed: unknown libva error

# vainfo
libva info: VA-API version 1.5.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib64/dri/emgd_drv_video.so
libva info: va_openDriver() returns -1
vaInitialize failed with error code -1 (unknown libva error),exit

No idea why libva tries to open the emgd driver on Wayland with vainfo ...
Comment 5 Stefan Dirsch 2020-02-26 14:49:06 UTC
Exactly the same results after updating to libva 2.6.1. I see no regressions here.

Xorg Ssession
---------------
# chromium
libva error: vaGetDriverNameByIndex() failed with unknown libva error, driver_name = (null)
[5728:5728:0226/154631.635080:ERROR:vaapi_wrapper.cc(417)] vaInitialize failed: unknown libva error
[5728:5728:0226/154631.893196:ERROR:viz_main_impl.cc(161)] Exiting GPU process due to errors during initialization
libva error: vaGetDriverNameByIndex() failed with unknown libva error, driver_name = (null)
[5808:5808:0226/154631.980472:ERROR:vaapi_wrapper.cc(417)] vaInitialize failed: unknown libva error

# vainfo
libva info: VA-API version 1.6.0
libva error: vaGetDriverNameByIndex() failed with unknown libva error, driver_name = (null)
vaInitialize failed with error code -1 (unknown libva error),exit

Wayland Session
--------------------
# chromium
libva error: vaGetDriverNameByIndex() failed with unknown libva error, driver_name = (null)
[4890:4890:0226/154433.311917:ERROR:vaapi_wrapper.cc(417)] vaInitialize failed: unknown libva error
[4890:4890:0226/154433.541304:ERROR:viz_main_impl.cc(161)] Exiting GPU process due to errors during initialization
libva error: vaGetDriverNameByIndex() failed with unknown libva error, driver_name = (null)
[4954:4954:0226/154433.643151:ERROR:vaapi_wrapper.cc(417)] vaInitialize failed: unknown libva error

# vainfo
libva info: VA-API version 1.6.0
libva info: Trying to open /usr/lib64/dri/emgd_drv_video.so
libva info: va_openDriver() returns -1
vaInitialize failed with error code -1 (unknown libva error),exit
Comment 6 Stefan Dirsch 2020-02-26 15:02:58 UTC
Closing as worksforme.