Bug 1161435 - Panda does not boot any more
Panda does not boot any more
Status: NEW
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Bootloader
Current
armv7 Other
: P5 - None : Normal (vote)
: ---
Assigned To: Bootloader Maintainers
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-01-21 14:15 UTC by Andreas Schwab
Modified: 2022-07-28 12:29 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Schwab 2020-01-21 14:15:13 UTC
Loading Linux 5.4.10-1-default ...
Loading initial ramdisk ...
EFI stub: Booting Linux Kernel...
EFI stub: Using DTB from configuration table
EFI stub: Exiting boot services and installing virtual address map...
data abort
pc : [<bff6545a>]          lr : [<bff65491>]
reloc pc : [<8080045a>]    lr : [<80800491>]
sp : bdf43ed4  ip : 00000000     fp : 00000000
r10: bff65000  r9 : bdf44ed0     r8 : 20071040
r7 : bff656e0  r6 : bff65694     r5 : 000000ad  r4 : 200856e0
r3 : 00000000  r2 : 00000050     r1 : bff65690  r0 : abb1aaad
Flags: NzCv  IRQs off  FIQs off  Mode SVC_32
Code: ea83428a d1f52010 f856bdf0 40685b04 (f854b2c5) 
UEFI image [0xbcf20000:0xbcf3bfff] '/VenHw(e61d73b9-a384-4acc-aeab-82e828f3628b)/USB(0x6,0x0)/HD(1,GPT,216dc377-761b-4afe-a951-fe9dc892afb6,0x800000000000,0xbcf2943000000000)/\efi\boot\bootarm.efi'
UEFI image [0xaca8a000:0xad2e7fff]
Resetting CPU ...

resetting ...

U-Boot SPL 2019.01 (Mar 18 2019 - 11:17:54 +0000)
OMAP4430-GP ES2.2
Trying to boot from MMC1
SPL: Please implement spl_start_uboot() for your board
SPL: Direct Linux boot not active!


U-Boot 2019.01 (Mar 18 2019 - 11:17:54 +0000)

CPU  : OMAP4430-GP ES2.2
Board: OMAP4 Panda
I2C:   ready
DRAM:  1 GiB
MMC:   OMAP SD/MMC: 0
Loading Environment from FAT... *** Warning - bad CRC, using default environment

Net:   No ethernet found.
Hit any key to stop autoboot:  0
Comment 1 Andreas Schwab 2020-01-21 14:23:51 UTC
The previous kernels no longer boot either, with the same symptoms.  Since grub was also updated, my guess would be a bug in grub.
Comment 2 Andreas Schwab 2020-01-23 15:41:23 UTC
I can successfully boot a new JeOS-panda image, I have no idea what has gone wrong after the last update.  I have tried copying /boot and /lib/modules from the new image to the old one, but that doesn't boot either with the same error.
Comment 3 Andreas Schwab 2020-01-27 14:12:23 UTC
I was able to recover the system by writing the MLO and u-boot.img images to the boot device, as done during installation.  That really needs to be redone whenever u-boot is updated.
Comment 4 Benjamin Brunner 2022-07-28 12:29:15 UTC
Bulk-re-assigning to the new bootloader-maintainers@suse.de group.