Bug 1161432 - update zstd to 1.4.4
update zstd to 1.4.4
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Development
Leap 15.1
x86-64 openSUSE 42.1
: P5 - None : Normal (vote)
: ---
Assigned To: Bernhard Wiedemann
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-01-21 13:55 UTC by Bernhard Wiedemann
Modified: 2020-01-29 23:39 UTC (History)
1 user (show)

See Also:
Found By: Development
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bernhard Wiedemann 2020-01-21 13:55:15 UTC
Version 1.4.4 brings several fixes over 1.4.2

  * bug: Fix Dictionary Compression Ratio Regression (#1709)
  * bug: Fix Buffer Overflow in v0.3 Decompression (#1722)
  * misc: Add NULL pointer check in util.c (#1706)

  * perf: Improved decompression speed, by > 10%
  * perf: Better compression speed when re-using a context
  * perf: Fix compression ratio when compressing large files with
    small dictionary
  * api: fixed decoding of magic-less frames
  * api: fixed ZSTD_initCStream_advanced() performance with fast modes
  * cli: command --output-dir-flat=DIE , generates target files into
    requested directory
  * cli: fix rare deadlock condition within dictionary builder
  * misc: Improved documentation : ZSTD_CLEVEL, DYNAMIC_BMI2,
    ZSTD_CDict, function deprecation, zstd format
Comment 1 Swamp Workflow Management 2020-01-21 14:30:11 UTC
This is an autogenerated message for OBS integration:
This bug (1161432) was mentioned in
https://build.opensuse.org/request/show/766083 15.1 / zstd
Comment 2 Swamp Workflow Management 2020-01-26 23:11:39 UTC
openSUSE-RU-2020:0108-1: An update that has one recommended fix can now be installed.

Category: recommended (moderate)
Bug References: 1161432
CVE References: 
Sources used:
openSUSE Leap 15.1 (src):    zstd-1.4.4-lp151.3.6.1
Comment 3 Andreas Stieger 2020-01-27 09:26:58 UTC
done
Comment 4 Swamp Workflow Management 2020-01-29 20:38:19 UTC
openSUSE-RU-2020:0144-1: An update that has one recommended fix can now be installed.

Category: recommended (moderate)
Bug References: 1161432
CVE References: 
Sources used:
openSUSE Backports SLE-15-SP1 (src):    zstd-1.4.4-bp151.4.6.1