Bug 1161399 - [Build 20200119] openQA test fails in gdal: failed to build
[Build 20200119] openQA test fails in gdal: failed to build
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Bruno Friedmann
E-mail List
https://openqa.opensuse.org/tests/114...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-01-21 08:47 UTC by Dominique Leuenberger
Modified: 2020-01-23 07:12 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Leuenberger 2020-01-21 08:47:09 UTC
## Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-extra_tests_in_textmode@64bit fails in
[gdal](https://openqa.opensuse.org/tests/1149774/modules/gdal/steps/35)

openSUSE:Factory / gdal failed to build - and with the old deps is now no longer installable


## Test suite description
Maintainer: okurz@suse.de

Mainly console extratest.


## Reproducible

Fails since (at least) Build [20190716](https://openqa.opensuse.org/tests/984307)


## Expected result

Last good: [20190713](https://openqa.opensuse.org/tests/983791) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?arch=x86_64&distri=opensuse&flavor=DVD&machine=64bit&test=extra_tests_in_textmode&version=Tumbleweed)
Comment 1 Bruno Friedmann 2020-01-21 09:58:49 UTC
gdal is still building on Devel Repo, would you mind to try a rebuild of it.
Seems it could suffer again the problem to not build under obscur concurrency.


Trying to access to openqa links give 504 error, so pretty hard to debug
Comment 2 Dominique Leuenberger 2020-01-21 10:47:57 UTC
Triggered a rebuild - no change

openQA won't tell you much: except gdal is not installable
The underlying issue is the build failure in openSUSE:Factory; is your devel prj building against Factory or Tumbleweed? if TW (/snapshot)
Comment 3 Dominique Leuenberger 2020-01-21 10:49:07 UTC
nothing provides libpoppler.so.91()(64bit) needed by libgdal26-3.0.2-1.6.x86_64
is the error reported by zypp in openQA (which is correct, poppler was updated)
Comment 4 Stefan Brüns 2020-01-21 11:07:39 UTC
The x86_64 build in Application:Geo has not yet picked up the latest poppler, it "ignores" a Rebuild trigger, possibly due to the high load on OBS.

gdal uses popplers private API and has not been adapted to the latest changes.
Comment 5 Bruno Friedmann 2020-01-21 17:18:01 UTC
@Stefan didn't your build pick up pure factory here
https://build.opensuse.org/package/live_build_log/home:StefanBruens:branches:Application:Geo/gdal/pure_factory/x86_64

where it build correctly ?
Comment 6 Stefan Brüns 2020-01-21 17:34:27 UTC
Have a look at the timestamps, the build is from 2 days ago.
Comment 7 Bruno Friedmann 2020-01-22 10:56:40 UTC
Ok version 3.0.3 seems to have a bugfix for poppler 0.83

It's actually building here
https://build.opensuse.org/package/show/home:bruno_friedmann:branches:Application:Geo/gdal

So in a few hours we will know if it works as expected. Then devel submission and factory submission.
Comment 8 Bruno Friedmann 2020-01-22 12:39:23 UTC
SR to devel projet in progress (gdal build with poppler 0.94)
https://build.opensuse.org/request/show/766301
Comment 9 Bruno Friedmann 2020-01-23 07:12:45 UTC
New version builded correctly.
So closing