Bug 1161214 - KMail - wrong GMail labels when moving message from unified inbox
KMail - wrong GMail labels when moving message from unified inbox
Status: NEW
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: KDE Applications
Current
x86-64 Other
: P5 - None : Minor (vote)
: ---
Assigned To: E-Mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-01-17 15:31 UTC by Nicholas Harvey
Modified: 2020-01-17 15:31 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicholas Harvey 2020-01-17 15:31:13 UTC
I am using Kontact 19.12.1 and have 2 GMail accounts configured. I have also set-up the Unified Inbox and have that set to show both inboxes from my GMail accounts.

When reading my email I often wish to file messages by dragging them from the inbox onto a GMail folder in the left-hand list. However I have found a problem when filing messages from the Unified Inbox specifically.

To test this, I log-n to my GMail account via the browser so I can verify the result directly on the server vs Kontact's view. Here are the steps to duplicate the problem:

1. Correct behaviour:
In Kontact, go to the Inbox of the GMail account (not the unified inbox) and drag a message into a folder called 'test'.
When viewed on the GMail web site, the message loses the 'inbox' label and gains the 'test' label. This is correct in my view.

2. Incorrect (buggy) behaviour:
In KMail, go to the Unified Inbox and drag a message into a folder called 'test'.
When viewed on the GMail web site, the message gains the 'test' label but also maintains the 'inbox' label. This is incorrect in my view.

This can be duplicated every time.