Bug 1161212 - ceph-fuse does not find libceph-common.so.0
ceph-fuse does not find libceph-common.so.0
Status: RESOLVED DUPLICATE of bug 1140346
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Nathan Cutler
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-01-17 15:24 UTC by Bernhard Wiedemann
Modified: 2021-03-17 13:39 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bernhard Wiedemann 2020-01-17 15:24:10 UTC
Steps To Reproduce:
zypper in ceph-fuse
ceph-fuse 

Actual Results:
ceph-fuse: error while loading shared libraries: libceph-common.so.0: cannot open shared object file: No such file or directory
Comment 1 Bernhard Wiedemann 2020-01-17 16:33:11 UTC
submitted a likely fix to
https://build.opensuse.org/request/show/765319
Comment 2 Nathan Cutler 2020-01-20 09:56:50 UTC
Is this really happening in SES6 (Ceph 14)? Because the spec file change you submitted is for Ceph 15 (SES7).

Also, the spec file is maintained upstream.
Comment 3 Nathan Cutler 2020-01-20 10:03:53 UTC
Please also provide details on how you deployed SES here. Which operating system, which repos.
Comment 4 Bernhard Wiedemann 2020-01-20 10:29:08 UTC
I installed SES6 on SLES-15-SP1 with deepsea.
I also installed ceph-fuse on Leap-15.1 with zypper install ceph-fuse

Both of them are affected by this bug.
Maybe I did not actually test SES7
Comment 5 Nathan Cutler 2020-01-20 12:31:36 UTC
(In reply to Bernhard Wiedemann from comment #4)
> I installed SES6 on SLES-15-SP1 with deepsea.
> Both of them are affected by this bug.

I cannot reproduce this (yet) on either SES6 or SES7. Can you please provide the output of "rpm -q ceph-common".
Comment 6 Nathan Cutler 2020-01-20 12:32:32 UTC
Also "zypper lr -u" please.
Comment 7 Nathan Cutler 2020-01-20 12:35:21 UTC
Also, ceph-fuse is unsupported on SES, so I'm moving the bug to openSUSE Tumbleweed.
Comment 8 Nathan Cutler 2020-01-20 12:44:51 UTC
This looks like a duplicate of Bug 1140346.

I suspect you are using an out-of-date version. This was a problem < 14.2.5
Comment 9 Bernhard Wiedemann 2020-01-21 14:26:52 UTC
Ah, so it was because of the patch with empty rpath that is still in Leap 15.1.
It needs a maintenance update then.
Comment 10 Nathan Cutler 2020-01-29 13:37:20 UTC
(In reply to Bernhard Wiedemann from comment #9)
> Ah, so it was because of the patch with empty rpath that is still in Leap
> 15.1.
> It needs a maintenance update then.

It does not need a maintenance update: the issue was fixed in 14.2.4-1295-g7bb6db3bbc

*** This bug has been marked as a duplicate of bug 1140346 ***