Bug 1161197 - Upgrade failure
Upgrade failure
Status: RESOLVED DUPLICATE of bug 1136641
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Installation
Leap 15.1
x86-64 Other
: P5 - None : Major (vote)
: ---
Assigned To: E-mail List
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-01-17 14:21 UTC by Alberto Zacchetti
Modified: 2020-01-20 16:19 UTC (History)
2 users (show)

See Also:
Found By: Customer
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alberto Zacchetti 2020-01-17 14:21:30 UTC
The system cannot be upgraded from Leap 15.0 to 15.1 because some physical volumes are not found. But in Leap 15.0 everything works perfectly. This is the real message:
"The volume group /dev/system is incomplete because some physical volumes are missing. If you continue, the volume group will be deleted later as part of the installation process. Moreover, incomplete volume groups are ignored by the partitioning proposal and are not visible in the Expert Partitioner."

My system uses 4 hard drives, each divided into two partitions, to compose a raid 5 array (md0). md0 is used as a physical unit for an LVM (system) divided into 3 logical volumes (root, swap and home). Here is the output of lsblk:

NAME              MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
sdb                 8:16   0 931,5G  0 disk  
├─sdb1              8:17   0   250M  0 part  /boot
└─sdb2              8:18   0 931,3G  0 part  
  └─md0             9:0    0   2,7T  0 raid5 
    ├─system-root 254:0    0    50G  0 lvm   /
    ├─system-swap 254:1    0     4G  0 lvm   [SWAP]
    └─system-home 254:2    0   2,7T  0 lvm   /home
sdc                 8:32   0 931,5G  0 disk  
├─sdc1              8:33   0   250M  0 part  
└─sdc2              8:34   0 931,3G  0 part  
  └─md0             9:0    0   2,7T  0 raid5 
    ├─system-root 254:0    0    50G  0 lvm   /
    ├─system-swap 254:1    0     4G  0 lvm   [SWAP]
    └─system-home 254:2    0   2,7T  0 lvm   /home
sdd                 8:48   0 931,5G  0 disk  
├─sdd1              8:49   0   250M  0 part  
└─sdd2              8:50   0 931,3G  0 part  
  └─md0             9:0    0   2,7T  0 raid5 
    ├─system-root 254:0    0    50G  0 lvm   /
    ├─system-swap 254:1    0     4G  0 lvm   [SWAP]
    └─system-home 254:2    0   2,7T  0 lvm   /home
sde                 8:64   1 931,5G  0 disk  
├─sde1              8:65   1   250M  0 part  
└─sde2              8:66   1 931,3G  0 part  
  └─md0             9:0    0   2,7T  0 raid5 
    ├─system-root 254:0    0    50G  0 lvm   /
    ├─system-swap 254:1    0     4G  0 lvm   [SWAP]
    └─system-home 254:2    0   2,7T  0 lvm   /home

How can I proceed with the update?
Comment 1 Alberto Zacchetti 2020-01-17 16:50:49 UTC
I also tried to perform a fresh installation, but even in this way it is not possible, due to problems with the visibility of the volumes.
Comment 2 Alynx Zhou 2020-01-19 00:40:00 UTC
You said Expert Partitioner so I guess you are using installer, right? it seems your hard drives are all fine, so I guess it's a installer problem.
Comment 3 Alberto Zacchetti 2020-01-19 09:39:21 UTC
Exact. The disks are fine, but running the boot with Leap 15.1 from the ISO image on USB to perform the update or installation, it is not possible because there are problems with LVM that the system believes is installed on the various physical HD, while instead it is placed on top of raids. The list I posted is the result of the lsblk command. So I don't know how to proceed with the update.
Comment 4 Alberto Zacchetti 2020-01-19 09:43:58 UTC
The error that I reported in the first post appears after the license screen and the language selection, when the upgrade system is still checking the existing configuration and the hard disks. I don't get to use the partitioner.
Comment 5 Ancor Gonzalez Sosa 2020-01-20 16:19:20 UTC
The problem is not in the installer, but in a buggy release of the LVM tools that, unfortunately, slipped into 15.1. It was reported as bug#1136641 (and then several more times).

So this is just another duplicate of that. Marking it as so.

*** This bug has been marked as a duplicate of bug 1136641 ***