Bug 1161077 - pstore: Unknown compression: deflate
pstore: Unknown compression: deflate
Status: RESOLVED WONTFIX
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-01-16 11:22 UTC by Tomáš Chvátal
Modified: 2020-01-16 15:25 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
dmesg.txt (85.93 KB, text/plain)
2020-01-16 11:22 UTC, Tomáš Chvátal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomáš Chvátal 2020-01-16 11:22:56 UTC
Created attachment 827648 [details]
dmesg.txt

As the $SUMMARY says the message gets printed on dmesg but nothing else seems to come out of it.

I guess it is cosmetic but maybe we should not print it at all?

Attaching full dmesg, but nothing else seems fishy in there.
Comment 1 Michal Suchanek 2020-01-16 12:52:20 UTC
See bug 1159986

*** This bug has been marked as a duplicate of bug 1159986 ***
Comment 2 Takashi Iwai 2020-01-16 13:33:55 UTC
This is about TW kernel, so it's a different story although the cause is same.

The deflate pstore default has been there since 4.17 on TW, so it's nothing new.
It's known to be incompatible with SLE kernel setup, hence the error is expected.
For accessing the pstore files that were created by SLE kernel, you'd need to change the pstore backend by passing the proper pstore.compress module option.
In that sense, the kernel error shouldn't be ignored.

That being said, this is rather a WONTFIX bug.  We shouldn't change the kconfig default for TW, and the incompatibility is expected.
Comment 3 Michal Suchanek 2020-01-16 14:43:32 UTC
In compatibility with SLES is one thing, broken config another.
Comment 4 Takashi Iwai 2020-01-16 15:14:56 UTC
(In reply to Michal Suchanek from comment #3)
> In compatibility with SLES is one thing, broken config another.

OK, the missing kconfig change has to be adjusted, but let's keep it in mind that the default shouldn't be changed to lzo for TW.
Comment 5 Michal Suchanek 2020-01-16 15:20:22 UTC
Why?

The previous default was broken since 4.17 and nobody cared.
Comment 6 Takashi Iwai 2020-01-16 15:25:35 UTC
Hrm, it's a good point :)

BTW, can't the pstore start working after loading deflate module?