Bug 1160994 - Firefox very slow after update to version 72
Firefox very slow after update to version 72
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Firefox
Current
x86-64 All
: P5 - None : Normal (vote)
: ---
Assigned To: Mozilla Bugs
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-01-15 14:46 UTC by Christoph Karrasch
Modified: 2022-03-26 19:44 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
wolfgang: needinfo? (boogle33)


Attachments
about:support (43.89 KB, text/plain)
2020-01-15 14:46 UTC, Christoph Karrasch
Details
buildconfig, upstream (2.87 KB, text/plain)
2020-01-16 09:09 UTC, Christoph Karrasch
Details
buildconfig, diff tw - upstream (4.26 KB, text/plain)
2020-01-16 09:10 UTC, Christoph Karrasch
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Karrasch 2020-01-15 14:46:44 UTC
Created attachment 827577 [details]
about:support

After update to version 72 on tumbleweed, firefox has become painfully slow. The problem did not occur with version 71.

example 1: google maps is almost unusable.
example 2: the graphics tests 4,5,6,7 on https://web.basemark.com/

Most importantly: If I download binaries for Firefox 72 directly from https://www.mozilla.org, the problem does *not* occur, Firefox is as speedy as usual.

The problem occurs even when starting with a new, clean profile (deleting .mozilla in home directory).

The problem occurs on two different laptops.

about:support is attached (both for the version from the tumbleweed repo and for the version directly from mozilla).
Comment 1 Wolfgang Rosenauer 2020-01-16 07:34:04 UTC
I do not see this affect neither with TW nor with Leap.

Can you please also share your desktop environment?
GFX hardware seems to be Whiskey Lake 3x8 GT2?

And because I'm wondering about basemark. I have no comparison because I haven't used it before. What is your total score there?
Comment 2 Christoph Karrasch 2020-01-16 08:30:08 UTC
I am on KDE (tumbleweed snapshot 20200113). Correct, Whiskey Lake 3x8 GT2 (Intel UHD graphics 620).

The second laptop on which the same problem occurs is also running KDE (tumbleweed) and also has Intel graphics (Iris Plus 640).

Basemark score for Firefox 72 (clean profile) from Tumbleweed repo: 270
Basemark score for Firefox 72 (clean profile) from Mozilla: 390

However, these scores might be misleading since not all tests seems similarly affected - it seems that only the graphics-intensive tests are affected. Example:

Test 7 (draw-call-test) runs 30 seconds on Mozilla's build and about 8 minutes on Tumbleweed's build. I could share a screen capture if needed.

As a test, I just installed firefox-esr 68.4.1 from the tumbleweed repo - esr is *not* affected!
Comment 3 Christoph Karrasch 2020-01-16 08:52:41 UTC
PS: I just ran a diff on about:support, comparing Mozilla's and TW's build. Config seems exactly the same:

diff mozillabuild.txt twbuild.txt 

7d6
< Update Channel: release
167c166
< dom.push.userAgentID: 0cb13890125c405ebfc0b752dd3fdf9c
---
> dom.push.userAgentID: 1a53a2af73374dfea303607f17ab448a
172,173c171,172
< security.sandbox.content.tempDirSuffix: b302fa80-775c-4ee1-8343-2a28d5c6f794
< security.sandbox.plugin.tempDirSuffix: e0120e53-f70b-484a-8d73-d1c0fd06a217
---
> security.sandbox.content.tempDirSuffix: 269201ae-9c87-46c2-a716-afb815eb7e1b
> security.sandbox.plugin.tempDirSuffix: 3e842a6a-a45d-494e-b431-51059e5cbd35
238,240c237,239
< App Locales: ["en-US"]
< Regional Preferences: ["en-US"]
< Default Locale: "en-US"
---
> App Locales: ["en-US","und"]
> Regional Preferences: ["en-US","und"]
> Default Locale: "und"
Comment 4 Wolfgang Rosenauer 2020-01-16 08:57:19 UTC
I can confirm a performance degradation related to (likely) graphics.
Compared 72.0.1 and 68.4.1 on my Leap 15.1 system:
- graphics from basemark moving faster
  72.0.1: 270
  68.4.1: 314

Just a very quick thought does not reveal larger differences in build and patches between both.
Obviously some typical fluctuation in patches being obsolete or rebased.

So the difference between openSUSE versions of ESR and regular are VERY small. Compared with upstream we use gcc instead of clang but as ESR is not (as much?) affected as regular it somehow think that it's a combination of Firefox core changes and probably toolchain.

As a first step I can switch from gcc to clang to see if that is related.
Comment 5 Wolfgang Rosenauer 2020-01-16 08:58:26 UTC
(In reply to Christoph Karrasch from comment #3)
> PS: I just ran a diff on about:support, comparing Mozilla's and TW's build.
> Config seems exactly the same:

since you have upstream available right now. Can you please compare about:buildconfig?
Comment 6 Christoph Karrasch 2020-01-16 09:09:40 UTC
Created attachment 827630 [details]
buildconfig, upstream
Comment 7 Christoph Karrasch 2020-01-16 09:10:05 UTC
Created attachment 827631 [details]
buildconfig, diff tw - upstream
Comment 8 Wolfgang Rosenauer 2020-01-17 11:39:19 UTC
Got a clang build of FF72.0.1 on my machine now.

I could not guarantee lab conditions in my benchmarks but what I had with web.basemark.com:

gcc build: 270
clang build: 301

Some anymations were visibly faster but 68.4.1 still had a higher score (built with gcc).

Also Christoph's findings:
> Basemark score for Firefox 72 (clean profile) from Tumbleweed repo: 270
> Basemark score for Firefox 72 (clean profile) from Mozilla: 390
are not close. I had 270 but I only reached 301 compared to 390 with clang.

I try to build and publish the clang build from here:
https://build.opensuse.org/project/show/mozilla:experimental
but OBS seems to have worker issues so huge packages like Firefox are waiting currently for ages to be built.
Once some build is available. I would need feedback from comparison on other people's machines.
Comment 9 Christoph Karrasch 2020-01-20 12:19:30 UTC
> I try to build and publish the clang build from here:
> https://build.opensuse.org/project/show/mozilla:experimental
> but OBS seems to have worker issues so huge packages like Firefox are
> waiting currently for ages to be built.
> Once some build is available. I would need feedback from comparison on other
> people's machines.

I just checked this repo, it seems that the x86_64 build for tumbleweed failed?
Comment 10 Andreas Stieger 2022-03-26 19:44:04 UTC
We are a couple of major versions ahead. Assuming his is fixed now. Reopen if needed with current data.