Bug 1160661 - installer does not accept existing LVM VG over RAID1
installer does not accept existing LVM VG over RAID1
Status: RESOLVED DUPLICATE of bug 1136641
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Installation
Leap 15.1
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-01-10 10:40 UTC by Patrick Schaaf
Modified: 2020-01-10 11:24 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
installer screenshot with the relevant error message, which we did not see in any pre-15.1 scenario (820.40 KB, image/jpeg)
2020-01-10 10:40 UTC, Patrick Schaaf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Schaaf 2020-01-10 10:40:49 UTC
Created attachment 827314 [details]
installer screenshot with the relevant error message, which we did not see in any pre-15.1 scenario

Testing the openSUSE 15.1 installer first time today. I have an existing setup with a RAID1 over sda1+sdb1 drives, then an LVM volume group on top, and root, home, etc volumes out of that volume group that I partially want to keep.

Expected result, and known behaviour from 15.0, 42.3, 42.2, 42.1, and 13.1 installers, was that I can enter Expert Partitioner, say "Rescan Devices", and then work with the stuff I already got.

That is no longer possible, with an error screen that I'll attach. While the RAID1 is accepted the volume group is not.

Funny thing is, on the F9 bash the actually running system, using vgdisplay, lvdisplay commands, has no problems knowing the volumes

Also, a few crypto volumes inside that LVM were somehow recognized by the isntaller  and it asked about their passwords. (unrelated to main install which is completely uncrypted!)

Here's the actual shape of the system, from inside the running one (some irrelevant lvs not shown):

myhost:~ # lsblk
NAME                    MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
sda                       8:0    0 232.9G  0 disk  
└─sda1                    8:1    0 232.9G  0 part  
  └─md0                   9:0    0 232.9G  0 raid1 
    ├─system-swap       254:0    0     2G  0 lvm   [SWAP]
    ├─system-root       254:1    0    24G  0 lvm   /
    ├─system-home       254:2    0    64G  0 lvm   /home  
sdb                       8:16   0 232.9G  0 disk  
└─sdb1                    8:17   0 232.9G  0 part  
  └─md0                   9:0    0 232.9G  0 raid1 
    ├─system-swap       254:0    0     2G  0 lvm   [SWAP]
    ├─system-root       254:1    0    24G  0 lvm   /
    ├─system-home       254:2    0    64G  0 lvm   /home
Comment 1 Ancor Gonzalez Sosa 2020-01-10 11:24:42 UTC
The problem is not in the installer, but in a buggy release of the LVM tools that, unfortunately, slipped into 15.1. It was reported as bug#1136641 (and then several more times).

So this is just another duplicate of that. Marking it as so.

*** This bug has been marked as a duplicate of bug 1136641 ***