Bug 1153174 - Yasts's "%posttrans" progress display gets stuck in online_update
Yasts's "%posttrans" progress display gets stuck in online_update
Status: RESOLVED WORKSFORME
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: YaST2
Leap 15.1
All Other
: P3 - Medium : Normal (vote)
: ---
Assigned To: YaST Team
Jiri Srain
https://trello.com/c/V0SBh4k7
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-10-07 08:10 UTC by Ulrich Windl
Modified: 2022-09-22 23:34 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
Relevant Yast logs (104.49 KB, application/gzip)
2019-10-08 07:38 UTC, Ulrich Windl
Details
Posttrans popup (179.67 KB, image/png)
2019-10-09 15:05 UTC, Ladislav Slezák
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ulrich Windl 2019-10-07 08:10:17 UTC
When updating many packages (e.g. libreoffice, kernel, etc.), I noticed that the "posttrans" display displayed progress for libreoffice icons up to 60%, then got stuck, and it was the last posttrans indicator seen. However from the noises of my disks I noticed that the kernel also had triggered rebuilding the initrd and reinstalling GRUB2.

From that I conclude that the posttrans progress display is broken.

I also searched y2log fro "posttrans:" messages, confirming my point of view:
2019-10-07 09:39:12 <1> pc(4931) [zypp::posttrans] RpmPostTransCollector.cc(collectScriptFromPackage):77 COLLECT posttrans: /var/adm/update-scripts/posttransl4NIpO/libreoffice-icon-themes-6.2.7.1-lp151.3.6.1.noarch.rpmLnrBBe{- 0700 0/0 size 254}
2019-10-07 09:40:56 <1> pc(4931) [zypp::posttrans] RpmPostTransCollector.cc(collectScriptFromPackage):77 COLLECT posttrans: /var/adm/update-scripts/posttransl4NIpO/ibus-1.5.19-lp151.2.3.1.x86_64.rpmysd9Ev{- 0700 0/0 size 24}
2019-10-07 09:41:22 <1> pc(4931) [zypp::posttrans] RpmPostTransCollector.cc(collectScriptFromPackage):77 COLLECT posttrans: /var/adm/update-scripts/posttransl4NIpO/libreoffice-l10n-en-6.2.7.1-lp151.3.6.1.noarch.rpmlRMsQg{- 0700 0/0 size 238}
2019-10-07 09:42:23 <1> pc(4931) [zypp::posttrans] RpmPostTransCollector.cc(collectScriptFromPackage):77 COLLECT posttrans: /var/adm/update-scripts/posttransl4NIpO/device-mapper-1.02.149-lp151.4.3.1.x86_64.rpm7jPj3s{- 0700 0/0 size 167}
2019-10-07 09:42:39 <1> pcrz00066(4931) [zypp::posttrans] RpmPostTransCollector.cc(collectScriptFromPackage):77 COLLECT posttrans: /var/adm/update-scripts/posttransl4NIpO/lvm2-2.02.180-lp151.4.3.1.x86_64.rpmH4FrlA{- 0700 0/0 size 167}
[...then the scripts are executed...]
device-mapper calls dracut to rebuild the initrd
All the scripts were actually executed, but not displayed

2019-10-07 09:45:53 <2> pc(4931) [PLUGIN] PluginScript.cc(~PluginDumpStderr):75 ! INFO:root:COMMITEND
Comment 1 Ladislav Slezák 2019-10-07 18:34:26 UTC
Please attach complete y2log, we need to check the details (e.g. which callbacks were received from libzypp).
Comment 2 Ulrich Windl 2019-10-08 07:38:53 UTC
Created attachment 820751 [details]
Relevant Yast logs
Comment 3 Ladislav Slezák 2019-10-09 15:05:47 UTC
Created attachment 820929 [details]
Posttrans popup

Unfortunately the logs do not tell much details, but when I tried running the online update locally it displayed a progress popup while the initrd was being built. See the screenshot.

Maybe the popup was displayed below some other windows, could check it again? (Manually downgrade some package which is in the initrd then run the online update again.)

I'd say it works fine for me.
Comment 4 Ulrich Windl 2019-10-10 06:53:40 UTC
The good news is the bad news for you: Before reporting the issue, I had observed it at least five times, alltogether on at least three different installations on really different hardware. Last seen yesterday while upgrading SLES 15 to SP1.
Comment 5 Ladislav Slezák 2019-10-15 14:05:46 UTC
OK, I do not know whether the problem is in YaST wrongly displaying the details or in libzypp not reporting the feedback properly...

Anyway, YaST should write the details into the progress log, opening a popup is annoying.
Comment 6 Ulrich Windl 2019-10-16 07:02:59 UTC
(In reply to Ladislav Slezák from comment #5)
> Anyway, YaST should write the details into the progress log, opening a popup
> is annoying.

Meaning the progress of %posttrans continues in the "normal log"? Would be fine, but still it has to work, whatever the output media will be.
Comment 7 Stefan Hundhammer 2022-09-22 14:33:34 UTC
This whole package installation progress area was completely reworked some months ago. See also

  https://github.com/yast/yast-packager/pull/612
Comment 8 Ulrich Windl 2022-09-22 23:34:39 UTC
(In reply to Stefan Hundhammer from comment #7)
>   https://github.com/yast/yast-packager/pull/612

It does not mention the progress window on final script execution ("posttrans").
Also the report was before Yast got messed up for 15.4 (the report was for 15.1).
I can confirm that the problem still exists in 15.3 as of today.