Bug 1150675 - Is Intel 945 GME still supported?
Is Intel 945 GME still supported?
Status: RESOLVED FIXED
: 1150478 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: X.Org
Current
i586 openSUSE Factory
: P3 - Medium : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-09-13 09:38 UTC by Tamás Németh
Modified: 2020-04-10 09:57 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
The elements (polygons?) of the folding envelope of Gmail are distorted and flickering on Intel 945 GME (40.69 KB, image/png)
2019-09-13 09:38 UTC, Tamás Németh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tamás Németh 2019-09-13 09:38:39 UTC
Created attachment 818117 [details]
The elements (polygons?) of the folding envelope of Gmail are distorted and flickering on Intel 945 GME

Since a few weeks ago I experience some glitches on my notebooks with Intel graphics chipsets. I will attach a screenshot.

One of my machines is an old 32 bit computer with an Intel 945 GME graphic chip, running an up-to-date 32 bit OpenSUSE Tumbleweed with XFCE. When I installed it in the beginning of this summer, it ran compiz very smoothly, but since an update, 3D acceleration has clearly visible and very disturbing quirks. These quirks become even more annoying when memory usage increases.

The elements (polygons?) of OpenGL 3D objects are often misplaced, distorted or even flickering. I tried to revert to older kernel versions (5.0 and 5.1) from http://download.opensuse.org/repositories/home:/tiwai:/kernel:/5.*/standard/ , and it PROBABLY moderated the problems, but definitely didn't eliminate them completely.
Comment 1 Tamás Németh 2019-09-13 09:41:49 UTC
*** Bug 1150478 has been marked as a duplicate of this bug. ***
Comment 2 Stefan Dirsch 2019-09-14 11:57:37 UTC
Oh. Well, this sounds like a 32bit netbook from 2012? Maybe you can try to disable "Display compositing" in XFCE?
Comment 3 Tamás Németh 2019-09-16 08:08:38 UTC
(In reply to Stefan Dirsch from comment #2)
> Oh. Well, this sounds like a 32bit netbook from 2012? Maybe you can try to
> disable "Display compositing" in XFCE?

No, it's an even older machine from 2009. I'm a bit into retro computing. I currently use a non compositing window manager which works fine, but there are glitches in OpenGL accelerated components of the applications.
Comment 4 Stefan Dirsch 2019-09-16 17:37:25 UTC
Ok. Since you were mentioning XFCE and Display compositing"  is its default that was my first idea. Unfortunately driver regressions are always possible and the older the hardware the more unlikely it is, that these get fixed again. :-( You may want to give Mesa's environment variable
a try

 LIBGL_ALWAYS_SOFTWARE=true
Comment 5 Tamás Németh 2019-09-19 19:43:15 UTC
(In reply to Stefan Dirsch from comment #4)
> Ok. Since you were mentioning XFCE and Display compositing"  is its default
> that was my first idea. Unfortunately driver regressions are always possible
> and the older the hardware the more unlikely it is, that these get fixed
> again. :-( You may want to give Mesa's environment variable
> a try
> 
>  LIBGL_ALWAYS_SOFTWARE=true

Well, I didn't even know that XFCE's window manager does compositing. You're right, it's the default, but I didn't notice it because it doesn't do any Compiz-like trick. However, I enabled some transparency in window handling, and I noticed that xfwm4 uses openGL indeed, but it runs very smoothly and without any gliches. Then I tried glxgears, which also ran with high FPS and without any problem, even when xfwm4 made it transparent.

So 3D rendering is not entirely broken, only some functions of it, and the problem seems not to be in the kernel. The attached gmail glitch for example also occurs with windows compositing disabled.

I'm afraid it's an upstream bug either in the X server or in Mesa. Thank you for the informations.
Comment 6 Stefan Dirsch 2020-02-27 11:30:46 UTC
Any improvements with Leap 15.1, Leap 15.2-Beta or current Tumbleweed?

Otherwise I would say, let's close it as WONTFIX. I believe you can live without XFCE's compositing feature on you more than 10 year old Laptop. ;-)
Comment 7 Tamás Németh 2020-04-10 08:46:27 UTC
Sorry, I didn't notice your message. Anyway, whether you believe or not, Mesa 20 solved the problem. It works perfectly now. FIXED!
Comment 8 Stefan Dirsch 2020-04-10 09:57:52 UTC
Wow! Thanks for your update!