Bug 1150577 - Freescale Layerscape 2088A fails to boot with tumbleweed
Freescale Layerscape 2088A fails to boot with tumbleweed
Status: RESOLVED FIXED
: 1142758 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
aarch64 openSUSE Factory
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-09-12 14:03 UTC by Nicolas Patricio Saenz Julienne
Modified: 2022-12-23 11:33 UTC (History)
8 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
Boot Failure kernel v5.2.0 (26.78 KB, text/plain)
2019-09-12 14:03 UTC, Nicolas Patricio Saenz Julienne
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nicolas Patricio Saenz Julienne 2019-09-12 14:03:35 UTC
Created attachment 818026 [details]
Boot Failure kernel v5.2.0

There seems to be some problem with the IOMMU. The issue first appeared in v5.2 and it's still there in linux-next. I attached some logs.
Comment 2 Nicolas Patricio Saenz Julienne 2019-09-17 15:15:10 UTC
Relevant discussion https://community.nxp.com/thread/512247
Comment 3 Joerg Roedel 2019-09-18 08:38:59 UTC
I pushed a config change to set

CONFIG_ARM_SMMU_DISABLE_BYPASS_BY_DEFAULT=n

to master, which should show up in tumbleweed soon and fix this issue.
Comment 4 Yousaf Kaukab 2019-09-25 12:50:20 UTC
*** Bug 1151943 has been marked as a duplicate of this bug. ***
Comment 5 Andreas Schwab 2019-11-11 13:48:32 UTC
*** Bug 1142758 has been marked as a duplicate of this bug. ***
Comment 6 Matthias Brugger 2019-11-15 20:37:45 UTC
merged into the branches some month ago. should long be fixed.