Bug 1150488 - flatpak app can not be installed by "2-click" in web browswer when "gnome-software --gapplication-service" is launched in advance.
flatpak app can not be installed by "2-click" in web browswer when "gnome-so...
Status: RESOLVED WORKSFORME
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: GNOME
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Jonathan Kang
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-09-12 09:22 UTC by Yifan Jiang
Modified: 2019-09-18 06:28 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
failure message from gnome-software UI (130.70 KB, image/png)
2019-09-12 09:22 UTC, Yifan Jiang
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yifan Jiang 2019-09-12 09:22:15 UTC
Created attachment 817947 [details]
failure message from gnome-software UI

The issue seems strange to me, so I am just opening the bug to see if someone else has met this as well:

1. Install flatpak and enable the flathub remote repo following:

https://flatpak.org/setup/openSUSE/

2. Launch gnome-software by clicking it's GNOME icon (which launches "gnome-software --gapplication-service"), or launch the command directly

3. Use firefox to visit:

https://flathub.org/apps/details/org.gnome.Games

4. Click the "Install" button, then choose to open it with "Software Install" as firefox suggested by default.

Then gnome-software UI will be brought up and the loader animation spinning for a long time, finally it ends up with a gnome-software in-house popup "Failed to install file: not supported" (as attached picture shown)

The typical journal message for this issue tells:

> Sep 12 15:23:52 wfc14.cy gnome-software[5219]: failed to convert file to GsApp: no application was created for running file-to-app with dedupe-flags=7 with refine-flags=require-license,require-url,require-size,require-version,require-history,require-setup-action,require-origin,require-related,require-menu-path,require-provenance,require-icon,require-permissions,require-origin-hostname,require-runtime,require-screenshots,require-categories,require-project-group,require-developer-name,require-kudos,content-rating with timeout=60 with file=/tmp/gnome-software-RUL27Z/org.gnome.Games-2.flatpakref on plugin=flatpak took 34948ms
Comment 1 Yifan Jiang 2019-09-12 09:26:44 UTC
Skip the step 2. in the description (namely, keep no gnome-software process running before install the app), the page of the target flatpak app (gnome-games in this description) can be shown in gnome-software successfully.

In the successful case like this, when installing the app from the browswer, the bare gnome-software process will be launched, using --local-file to open the temporary file downloaded by the browser directly.
Comment 2 Jonathan Kang 2019-09-18 06:28:50 UTC
As we discussed offline earlier today, this might be due to network issues and
cannot be reproduced anymore.

Closing this at the moment. Feel free to reopen this if you can reproduce this
again.

Thanks.