Bug 1150473 - Compiz cannot be installed, because it depends on a nonexistent package
Compiz cannot be installed, because it depends on a nonexistent package
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Compiz
Current
All openSUSE Factory
: P3 - Medium : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-09-12 08:05 UTC by Tamás Németh
Modified: 2019-11-18 19:44 UTC (History)
0 users

See Also:
Found By: Community User
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tamás Németh 2019-09-12 08:05:58 UTC
libprotobuf19 has been removed with a recent update, but at least the following packages still depend on it, so they cannot be installed:

libcompizconfig
python3-compizconfig
compiz
simple-ccsm
python3-ccm
funsion-icon
compiz-plugins-extra
compiz-plugins-experimental
compiz-lang
compiz-gnome
compiz-emerald
compiz-branding-openSUSE
simple-ccsm-lang
compizconfig-settings-manager
compiz-plugins-extra-lang
compiz-plugins-experimental-lang
compiz-emerald-themes
compiz-emerald-theme-manager
compiz-emerald-lang
compizconfig-settings-manager

However, compiz still works fine when I retaint libprotobuf19. Can compiz be built linked with libprotobuf20 instead of libprotobuf20? If yes, please consider doing so. Thank you in advance.
Comment 1 Tamás Németh 2019-11-18 19:44:03 UTC
Thank you for your work, this bug is fixed.