Bug 1149869 - glslang: symbol lookup error
glslang: symbol lookup error
Status: RESOLVED FIXED
: 1149873 1150365 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Maintenance
Current
x86-64 Other
: P5 - None : Normal with 8 votes (vote)
: ---
Assigned To: Jan Engelhardt
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-09-07 09:10 UTC by Adriaan Struys
Modified: 2020-08-17 13:27 UTC (History)
11 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adriaan Struys 2019-09-07 09:10:31 UTC
mpv is unusable due to a library dependency problem.
Version: 0.30.0+git.1567376743.6d90517275-30.1, Tumbleweed 20190905

mpv: symbol lookup error: /usr/lib64/libshaderc_shared.so.1: undefined symbol: _ZN7glslang8TProgram5mapIOEPNS_14TIoMapResolverE
Comment 1 Felix Miata 2019-09-07 20:27:06 UTC
*** Bug 1149873 has been marked as a duplicate of this bug. ***
Comment 2 simon izor 2019-09-08 05:20:37 UTC
I'm having the same issue.  Anything that uses mpv is currently unusable due to this:

symbol lookup error: /usr/lib64/libshaderc_shared.so.1: undefined symbol: _ZN7glslang8TProgram5mapIOEPNS_14TIoMapResolverE
Comment 3 Igor Kuznetsov 2019-09-08 05:43:12 UTC
same problem with mpv
Comment 4 Jan Engelhardt 2019-09-08 05:47:30 UTC
glslang changed ABI without SONAME change. rq 729104
Comment 5 Andrey Karepin 2019-09-12 06:42:45 UTC
*** Bug 1150365 has been marked as a duplicate of this bug. ***
Comment 6 Andrey Karepin 2019-09-12 06:50:53 UTC
workaround https://lists.opensuse.org/opensuse-factory/2019-09/msg00086.html
Comment 7 Adriaan Struys 2019-09-14 16:46:49 UTC
I think this can be closed since the updates are in Tumbleweed now.
Comment 8 Jan Engelhardt 2020-01-12 20:27:26 UTC
marking as resolved.