Bug 1149790 - undefined symbol: fz_identity (python3-PyMuPDF)
undefined symbol: fz_identity (python3-PyMuPDF)
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Dirk Mueller
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-09-06 11:51 UTC by Yunhe Guo
Modified: 2019-09-17 21:47 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yunhe Guo 2019-09-06 11:51:52 UTC
https://build.opensuse.org/package/show/openSUSE:Factory/python-PyMuPDF


Describe the bug (mandatory)

I packaged pymupdf for openSUSE. It compiled very well. But some other packages that optionally require PyMuPDF crashed when PyMuPDF was installed as dependency. Lector (a ebook reader) gives this error:

Traceback (most recent call last):
  File "/usr/bin/lector", line 11, in <module>
    load_entry_point('lector==0.5.1', 'gui_scripts', 'lector')()
  File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 489, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 2852, in load_entry_point
    return ep.load()
  File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 2443, in load
    return self.resolve()
  File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 2449, in resolve
    module = __import__(self.module_name, fromlist=['__name__'], level=0)
  File "/usr/lib/python3.7/site-packages/lector/__main__.py", line 42, in <module>
    from lector import sorter
  File "/usr/lib/python3.7/site-packages/lector/sorter.py", line 58, in <module>
    from lector.parsers.pdf import ParsePDF
  File "/usr/lib/python3.7/site-packages/lector/parsers/pdf.py", line 20, in <module>
    import fitz
  File "/usr/lib64/python3.7/site-packages/fitz/__init__.py", line 3, in <module>
    from fitz.fitz import *
  File "/usr/lib64/python3.7/site-packages/fitz/fitz.py", line 18, in <module>
    from . import _fitz
ImportError: /usr/lib64/python3.7/site-packages/fitz/_fitz.cpython-37m-x86_64-linux-gnu.so: undefined symbol: fz_identity

Steps to reproduce:

1. Install openSUSE Tumbleweed.
2. Install lector and python3-PyMuPDF packages.
3. Run lector in terminal.

If you install it via pip ( sudo pip install pymupdf ), it works fine. So this isn't an upstream issue.

The *.so file is compiled without any errors. So there might be a linking issue. I have talked with upstream developer but no conclusion. https://github.com/pymupdf/PyMuPDF/issues/355

Hope experienced python package maintainers can help me out. Thanks!
Comment 1 Yunhe Guo 2019-09-17 21:47:12 UTC
The problem is in mupdf and it has been fixed.