Bug 1149619 - gdb libipt update v2.0 -> v2.0.1
gdb libipt update v2.0 -> v2.0.1
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Development
Current
Other Other
: P5 - None : Enhancement (vote)
: ---
Assigned To: Tom de Vries
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-09-05 14:00 UTC by Tom de Vries
Modified: 2019-10-03 08:45 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom de Vries 2019-09-05 14:00:11 UTC
libipt v2.0.1 has been released: https://github.com/intel/libipt/tree/v2.0.1
Comment 1 Tom de Vries 2019-09-24 15:10:01 UTC
Hmm, there's just one test in the gdb testsuite that tests this feature: gdb.btrace/tsx.exp.

I've looked at the testresults from $(osc getbinaries openSUSE_Factory x86_64) and found that this test is unsupported:
...
$ grep tsx.exp *.sum
gdb-x86_64-suse-linux-m32.-fno-PIE.-no-pie.sum:Running /home/abuild/rpmbuild/BUILD/gdb-8.3/gdb/testsuite/gdb.btrace/tsx.exp ...
gdb-x86_64-suse-linux-m32.-fno-PIE.-no-pie.sum:UNSUPPORTED: gdb.btrace/tsx.exp: target does not support PT
gdb-x86_64-suse-linux-m32.sum:Running /home/abuild/rpmbuild/BUILD/gdb-8.3/gdb/testsuite/gdb.btrace/tsx.exp ...
gdb-x86_64-suse-linux-m32.sum:UNSUPPORTED: gdb.btrace/tsx.exp: target does not support PT
gdb-x86_64-suse-linux-m64.-fno-PIE.-no-pie.sum:Running /home/abuild/rpmbuild/BUILD/gdb-8.3/gdb/testsuite/gdb.btrace/tsx.exp ...
gdb-x86_64-suse-linux-m64.-fno-PIE.-no-pie.sum:UNSUPPORTED: gdb.btrace/tsx.exp: target does not support PT
gdb-x86_64-suse-linux-m64.sum:Running /home/abuild/rpmbuild/BUILD/gdb-8.3/gdb/testsuite/gdb.btrace/tsx.exp ...
gdb-x86_64-suse-linux-m64.sum:UNSUPPORTED: gdb.btrace/tsx.exp: target does not support PT
...

It's unsupported because:
...
(gdb) record btrace pt^M
Could not enable branch tracing for process 17815: Failed to open /sys/bus/event_source/devices/intel_pt/type: No such file or directory.^M
...

I do have this device available on my laptop:
...
$ ls -al /sys/bus/event_source/devices/intel_pt/type
-r--r--r-- 1 root root 4096 24 sep 16:00 /sys/bus/event_source/devices/intel_pt/type
...

I'll try to do an osc local build for openSUSE_Leap_15.1 x86_64 and see it the test will still show as unsupported.
Comment 2 Michael Matz 2019-09-24 15:17:56 UTC
Note that this feature depends on hardware and virtualization: if either the build host doesn't have the right CPU, or our VM kernel we use for building
doesn't pass-through the capabilities (I don't know if that's even supported, or OTOH necessary) this test will always be unsupported.

Hence it's expected that depending on build-host/vm-kernel this test might
oscillate between unsupported and whatever-else (fail or ok).
Comment 3 Tom de Vries 2019-09-25 14:45:15 UTC
(In reply to Tom de Vries from comment #1)
> I'll try to do an osc local build for openSUSE_Leap_15.1 x86_64 and see it
> the test will still show as unsupported.

That also failed, but in the end using rpmbuild directly yielded a functional test. No regression after update to v2.0.1.
Comment 4 Tom de Vries 2019-10-03 08:45:10 UTC
Request https://build.opensuse.org/request/show/733347 was accepted for devel:gcc/gdb.