Bug 1149068 - pipenv fails to install any dependencies
pipenv fails to install any dependencies
Status: RESOLVED WONTFIX
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Development
Current
x86-64 SUSE Other
: P5 - None : Normal (vote)
: ---
Assigned To: Tomáš Chvátal
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-09-01 11:31 UTC by Johannes Marbach
Modified: 2020-03-25 07:59 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
Shell log demonstrating the problem (3.76 KB, text/plain)
2019-09-01 11:33 UTC, Johannes Marbach
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Marbach 2019-09-01 11:31:29 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0
Build Identifier: 

On openSUSE Tumbleweed with all updates installed the pipenv command can successfully initialize an environment. However, any time I try to install a dependency into it, it crashes.

Reproducible: Always

Steps to Reproduce:
$ mkdir test
$ cd test
$ pipenv install
Creating a virtualenv for this project…
Pipfile: /home/jm/test/Pipfile
Using /usr/bin/python3 (3.7.3) to create virtualenv…
⠏ Creating virtual environment...Already using interpreter /usr/bin/python3
Using base prefix '/usr'
New python executable in /home/jm/.local/share/virtualenvs/test-2t7aXW0E/bin/python3
Also creating executable in /home/jm/.local/share/virtualenvs/test-2t7aXW0E/bin/python
Installing setuptools, pip, wheel...
done.

✔ Successfully created virtual environment! 
Virtualenv location: /home/jm/.local/share/virtualenvs/test-2t7aXW0E
Creating a Pipfile for this project…
Pipfile.lock not found, creating…
Locking [dev-packages] dependencies…
Locking [packages] dependencies…
Updated Pipfile.lock (a65489)!
Installing dependencies from Pipfile.lock (a65489)…
  
Comment 1 Johannes Marbach 2019-09-01 11:33:59 UTC
Created attachment 816513 [details]
Shell log demonstrating the problem
Comment 2 Tomáš Chvátal 2020-03-25 07:59:40 UTC
pipenv was removed from the repo because it was utterly broken.