Bug 1148955 - regression: wicked obtains incorrect ipv4 address for bridge
regression: wicked obtains incorrect ipv4 address for bridge
Status: RESOLVED DUPLICATE of bug 1136600
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
x86-64 Other
: P5 - None : Normal (vote)
: ---
Assigned To: wicked maintainers
E-mail List
:
Depends on: 1136600
Blocks:
  Show dependency treegraph
 
Reported: 2019-08-30 10:00 UTC by Olaf Hering
Modified: 2020-03-20 14:43 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Olaf Hering 2019-08-30 10:00:52 UTC
With these files, wicked does not get the correct ipv4 address in Tumbleweed, but it does so in Leap, SLE15, SLE12:

stein-schneider:/etc/sysconfig/network # head ifcfg-*
==> ifcfg-br0 <==
BOOTPROTO='dhcp'
BRIDGE='yes'
BRIDGE_FORWARDDELAY='0'
BRIDGE_PORTS='eth0'
BRIDGE_STP='off'
STARTMODE='auto'

==> ifcfg-eth0 <==
BOOTPROTO='none'
STARTMODE='auto'

It gets some random address from the pool, instead of the assigned address for this specific MAC.

With just this file it gets the expected address:
==> /etc/sysconfig/network/ifcfg-eth0 <==
BOOTPROTO='dhcp'
STARTMODE='auto'
DHCLIENT_CLIENT_ID='01:00:26:55:23:e5:46'


Appending the clientid to ifcfg-br0 makes zero difference. It just gets another random address from the pool.
Comment 1 Dead Mozay 2019-09-02 03:51:13 UTC
I confirm, that the bridges stopped working with IPv4
Comment 2 Dead Mozay 2019-09-09 05:16:37 UTC
Checked with NetworkManager, same problem
Comment 4 Olaf Hering 2020-03-20 14:41:00 UTC
Unlikely.

dup of some systemd bug. Still unfixed after one year...
Comment 5 Olaf Hering 2020-03-20 14:43:09 UTC
systemd bug.

*** This bug has been marked as a duplicate of bug 1136600 ***