Bug 1148780 - system ansible throws a callback exception while the pypi does not
system ansible throws a callback exception while the pypi does not
Status: RESOLVED NORESPONSE
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
x86-64 All
: P5 - None : Normal (vote)
: ---
Assigned To: Lars Vogdt
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-08-29 11:49 UTC by Kyrylo Shatskyy
Modified: 2022-10-10 08:45 UTC (History)
6 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
lars.vogdt: needinfo? (kyrylo.shatskyy)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kyrylo Shatskyy 2019-08-29 11:49:00 UTC
Callback Exception: 
  File "/usr/lib/python3.7/site-packages/ansible/executor/task_queue_manager.py", line 333, in send_callback
    method(*new_args, **kwargs)
   File "/usr/lib/python3.7/site-packages/ansible/plugins/callback/default.py", line 135, in v2_runner_on_ok
    msg += " => %s" % (self._dump_results(result._result),)
   File "/usr/lib/python3.7/site-packages/ansible/plugins/callback/yaml.py", line 123, in _dump_results
    dumped += to_text(yaml.dump(abridged_result, allow_unicode=True, width=1000, Dumper=AnsibleDumper, default_flow_style=False))
   File "/usr/lib64/python3.7/site-packages/yaml/__init__.py", line 290, in dump
    return dump_all([data], stream, Dumper=Dumper, **kwds)
   File "/usr/lib64/python3.7/site-packages/yaml/__init__.py", line 278, in dump_all
    dumper.represent(data)
   File "/usr/lib64/python3.7/site-packages/yaml/representer.py", line 28, in represent
    self.serialize(node)
   File "ext/_yaml.pyx", line 1348, in _yaml.CEmitter.serialize
   File "ext/_yaml.pyx", line 1510, in _yaml.CEmitter._serialize_node
   File "ext/_yaml.pyx", line 1433, in _yaml.CEmitter._serialize_node
Comment 1 Kyrylo Shatskyy 2019-08-29 11:49:28 UTC
ansible --version
ansible 2.8.3
  config file = /etc/ansible/ansible.cfg
  configured module search path = ['/home/kyr/.ansible/plugins/modules', '/usr/share/ansible/plugins/modules']
  ansible python module location = /usr/lib/python3.7/site-packages/ansible
  executable location = /usr/bin/ansible
  python version = 3.7.3 (default, Apr 09 2019, 05:18:21) [GCC]
Comment 2 Kyrylo Shatskyy 2019-08-29 11:51:08 UTC
rpm -qf /usr/lib64/python3.7/site-packages/yaml/__init__.py
python3-PyYAML-5.1.2-1.1.x86_64
Comment 3 Kyrylo Shatskyy 2019-08-29 11:52:26 UTC
pip show PyYAML
Name: PyYAML
Version: 5.1.2
Summary: YAML parser and emitter for Python
Home-page: https://github.com/yaml/pyyaml
Author: Kirill Simonov
Author-email: xi@resolvent.net
License: MIT
Location: /home/kyr/kshtsk/teuthology-deploy/v/lib/python3.7/site-packages
Requires: 
Required-by: oslo.serialization, oslo.config, openstacksdk, cliff, ansible
Comment 4 Johannes Kastl 2019-09-08 18:56:34 UTC
I am not the bugowner of the ansible package, I only proposed two updates for this package some time ago.
Adding Lars Vogdt as he is the maintainer.
Comment 5 Lars Vogdt 2020-05-11 15:05:23 UTC
Sorry for the late reply - and I am even more sorry, as I can not reproduce your report here on a Leap 15.1 system. Before I start to verify this on Tumbleweed, can I ask you to give a bit more details?

Which ansible command are you trying to execute? 
If you try to run a playbook, can you provide this playbook (as attachment)?

Does the bug still persist with the latest ansible 2.9.7 at all?
Comment 6 Matej Cepl 2020-05-26 12:45:04 UTC
(In reply to Kyrylo Shatskyy from comment #0)
> Callback Exception: 
>   File
> "/usr/lib/python3.7/site-packages/ansible/executor/task_queue_manager.py",
> line 333, in send_callback
>     method(*new_args, **kwargs)
>    File
> "/usr/lib/python3.7/site-packages/ansible/plugins/callback/default.py", line
> 135, in v2_runner_on_ok
>     msg += " => %s" % (self._dump_results(result._result),)
>    File "/usr/lib/python3.7/site-packages/ansible/plugins/callback/yaml.py",
> line 123, in _dump_results
>     dumped += to_text(yaml.dump(abridged_result, allow_unicode=True,
> width=1000, Dumper=AnsibleDumper, default_flow_style=False))
>    File "/usr/lib64/python3.7/site-packages/yaml/__init__.py", line 290, in
> dump
>     return dump_all([data], stream, Dumper=Dumper, **kwds)
>    File "/usr/lib64/python3.7/site-packages/yaml/__init__.py", line 278, in
> dump_all
>     dumper.represent(data)
>    File "/usr/lib64/python3.7/site-packages/yaml/representer.py", line 28,
> in represent
>     self.serialize(node)
>    File "ext/_yaml.pyx", line 1348, in _yaml.CEmitter.serialize
>    File "ext/_yaml.pyx", line 1510, in _yaml.CEmitter._serialize_node
>    File "ext/_yaml.pyx", line 1433, in _yaml.CEmitter._serialize_node

Can you reproduce reliably? It seems to me that there is something missing from this traceback (namely, its end with the specific exception being thrown), or is it just some C error? Anyway, from the partial traceback we have, I would try to blame PyYAML module.
Comment 7 Lars Vogdt 2020-08-13 13:52:01 UTC
Closing here, as there is no feedback since 2020-05-11.

Feel free to re-open the bug and provide the requested information at any time.