Bug 1148638 - Thumbleweed Application:geo PDAL dependency problem
Thumbleweed Application:geo PDAL dependency problem
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
x86-64 SUSE Other
: P5 - None : Normal (vote)
: ---
Assigned To: Bruno Friedmann
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-08-28 20:11 UTC by Daniel Rohrer
Modified: 2019-10-25 12:07 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
alynx.zhou: needinfo? (drohrer.corgemont)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Rohrer 2019-08-28 20:11:24 UTC
Hello,

I'm trying to install PDAL library on Thumbleweed

+++++++++++++++++++++
Résolution des dépendances des paquets...
Problème : rien ne fournit libjsoncpp.so.19, qui est requis par PDAL-1.8.0-1.3.i586
 Solution 1 : ne pas demander d'installer un élément résoluble fournissant pdal
 Solution 2 : casser PDAL-1.8.0-1.3.i586 en ignorant certaines de ses dépendances
+++++++++++++++++++++++++

Yast indicates that the library libjsoncpp.so.21 is available

Version of tumbleweed:
NAME="openSUSE Tumbleweed"
# VERSION="20190824"
ID="opensuse-tumbleweed"
ID_LIKE="opensuse suse"
VERSION_ID="20190824"
PRETTY_NAME="openSUSE Tumbleweed"
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:opensuse:tumbleweed:20190824"
BUG_REPORT_URL="https://bugs.opensuse.org"
HOME_URL="https://www.opensuse.org/"
LOGO="distributor-logo"

Is it possible to arrange the PDAL package ?

Bests regards

Daniel
Comment 1 Alynx Zhou 2019-08-29 03:24:59 UTC
Where did you get PDAL package? I cannot find it with zypper...
Comment 2 Bruno Friedmann 2019-10-25 12:07:00 UTC
Hi Alynx, it seems to be a very old bug, which should be already fixed for TW

PDAL is build and develop in Application:Geo on obs
https://build.opensuse.org/package/show/Application:Geo/PDAL
A new build has just finished yesterday

I'm closing this bug as everything work as expected.

The following 2 NEW packages are going to be installed:
  PDAL       2.0.1-2.10
  libPDAL10  2.0.1-2.10

2 new packages to install.
Overall download size: 1.5 MiB. Already cached: 0 B. After the operation, additional 5.3 MiB will be used.
Continue? [y/n/v/...? shows all options] (y): y
committing
Retrieving package libPDAL10-2.0.1-2.10.x86_64                                                                                                (1/2),   1.4 MiB (  5.1 MiB unpacked
Retrieving: libPDAL10-2.0.1-2.10.x86_64.rpm ...................................................................................................................[done (753.1 KiB/s)
Retrieving package PDAL-2.0.1-2.10.x86_64                                                                                                     (2/2),  77.9 KiB (176.5 KiB unpacked
Retrieving: PDAL-2.0.1-2.10.x86_64.rpm ......................................................................................................................................[done

Checking for file conflicts: ................................................................................................................................................[done
(1/2) Installing: libPDAL10-2.0.1-2.10.x86_64 ...............................................................................................................................[done
(2/2) Installing: PDAL-2.0.1-2.10.x86_64 ....................................................................................................................................[done
CommitResult  (total 2, done 2, error 0, skipped 0, updateMessages 0)

Funky that I was thinking about Daniel today, at this happen :-)