Bug 1148509 - Problem: telegram-desktop-1.8.2-1.1.x86_64 conflicts with libqt5-qtstyleplugins-platformtheme-gtk2 provided by libqt5-qtstyleplugins-platformtheme-gtk2-5.0.0+git20170311-6.11.x86_64
Problem: telegram-desktop-1.8.2-1.1.x86_64 conflicts with libqt5-qtstyleplugi...
Status: RESOLVED FIXED
: 1149130 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
Other Other
: P5 - None : Normal with 14 votes (vote)
: ---
Assigned To: Peter Nixon
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-08-28 09:39 UTC by Ave Milia
Modified: 2019-09-13 13:55 UTC (History)
6 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ave Milia 2019-08-28 09:39:15 UTC
Upgrading to 20190824 is stalled due to:

Problem: telegram-desktop-1.8.2-1.1.x86_64 conflicts with libqt5-qtstyleplugins-platformtheme-gtk2 provided by libqt5-qtstyleplugins-platformtheme-gtk2-5.0.0+git20170311-6.11.x86_64
 Solution 1: deinstallation of libqt5-qtstyleplugins-platformtheme-gtk2-5.0.0+git20170311-6.11.x86_64
 Solution 2: deinstallation of telegram-desktop-1.8.1-1.1.x86_64
 Solution 3: keep obsolete telegram-desktop-1.8.1-1.1.x86_64
Comment 1 Ave Milia 2019-08-28 09:44:54 UTC
Upgrading from 20190823, that is.
Comment 2 Bogdan Ivanyuk 2019-08-31 17:27:17 UTC
Problem: telegram-desktop-1.8.2-1.1.x86_64 conflicts with libqt5-qtstyleplugins-platformtheme-gtk2 provided by libqt5-qtstyleplugins-platformtheme-gtk2-5.0.0+git20170311-6.11.x86_64
 Solution 1: Following actions will be done:
  deinstallation of telegram-desktop-1.8.1-1.1.x86_64
  deinstallation of telegram-theme-plata-0.8.9-1.1.noarch
  deinstallation of telegram-theme-adapta-3.95.0.11-2.1.x86_64
 Solution 2: deinstallation of libqt5-qtstyleplugins-platformtheme-gtk2-5.0.0+git20170311-6.11.x86_64
 Solution 3: keep obsolete telegram-desktop-1.8.1-1.1.x86_64
 
The problem is the same
Comment 3 Ave Milia 2019-09-06 08:32:22 UTC
I see that the bug has been assigned to telegram-desktop bugowner, but it's been a week without response. Any clue on what's wrong?
Comment 4 Ave Milia 2019-09-06 08:38:12 UTC
Since the bugowner is inherited, I've added telegram-desktop maintainers to CC, maybe they can help.
Comment 5 Marcel Kuehlhorn 2019-09-06 08:43:32 UTC
(In reply to Ave Milia from comment #4)
> Since the bugowner is inherited, I've added telegram-desktop maintainers to
> CC, maybe they can help.

Thanks, up until now I was not notified of this.

As for the Bug: the Conflict was introduced intentionally to be able to use Telegrams GTK integration for native notifications.
After enabling this, Telegram would refuse to start as long as libqt5-qtstyleplugins-platformtheme-gtk2 is present on the system.
Comment 6 Ave Milia 2019-09-06 09:34:10 UTC
(In reply to Marcel Kuehlhorn from comment #5)
> As for the Bug: the Conflict was introduced intentionally to be able to use
> Telegrams GTK integration for native notifications.
> After enabling this, Telegram would refuse to start as long as
> libqt5-qtstyleplugins-platformtheme-gtk2 is present on the system.

Thank you for the information. So the resolution is to uninstall libqt5-qtstyleplugins-platformtheme-gtk2?

I remember there was some problem with GTK themes when moving to Qt 5.7[0], is this package related to that? The issue I refer to has caused weird problems like

> GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion
> 'G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

as a runtime error on already compiled applications.

[0]: <https://bbs.archlinux.org/viewtopic.php?id=214147>
Comment 7 Marcel Kuehlhorn 2019-09-06 09:39:31 UTC
(In reply to Ave Milia from comment #6)
> Thank you for the information. So the resolution is to uninstall
> libqt5-qtstyleplugins-platformtheme-gtk2?
> 
For now, yes.

> I remember there was some problem with GTK themes when moving to Qt 5.7[0],
> is this package related to that? The issue I refer to has caused weird
> problems like
> 
> > GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion
> > 'G_TYPE_IS_INSTANTIATABLE (instance_type)' failed
> 
> as a runtime error on already compiled applications.
> 
> [0]: <https://bbs.archlinux.org/viewtopic.php?id=214147>

That looks indeed similar to the errors Telegram gives:
> ~>telegram-desktop 
> (telegram-desktop:4205): GLib-GObject-WARNING **: 17:15:44.346: cannot register existing type 'GdkDisplayManager'
> (telegram-desktop:4205): GLib-CRITICAL **: 17:15:44.346: g_once_init_leave: assertion 'result != 0' failed
> (telegram-desktop:4205): GLib-GObject-CRITICAL **: 17:15:44.346: g_object_new_with_properties: assertion 'G_TYPE_IS_OBJECT (object_type)' failed
Comment 8 Ave Milia 2019-09-06 10:09:43 UTC
(In reply to Marcel Kuehlhorn from comment #7)
> (In reply to Ave Milia from comment #6)
> > Thank you for the information. So the resolution is to uninstall
> > libqt5-qtstyleplugins-platformtheme-gtk2?
> > 
> For now, yes.
> 
> > I remember there was some problem with GTK themes when moving to Qt 5.7[0],
> > is this package related to that? The issue I refer to has caused weird
> > problems like
> > 
> > > GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion
> > > 'G_TYPE_IS_INSTANTIATABLE (instance_type)' failed
> > 
> > as a runtime error on already compiled applications.
> > 
> > [0]: <https://bbs.archlinux.org/viewtopic.php?id=214147>
> 
> That looks indeed similar to the errors Telegram gives:
> > ~>telegram-desktop 
> > (telegram-desktop:4205): GLib-GObject-WARNING **: 17:15:44.346: cannot register existing type 'GdkDisplayManager'
> > (telegram-desktop:4205): GLib-CRITICAL **: 17:15:44.346: g_once_init_leave: assertion 'result != 0' failed
> > (telegram-desktop:4205): GLib-GObject-CRITICAL **: 17:15:44.346: g_object_new_with_properties: assertion 'G_TYPE_IS_OBJECT (object_type)' failed

Is there a tracking bug for this particular issue of tg? For example, ckb-next was haunted by it[0] (if that's the same cause) seemingly due to appindicator, and it only happened for KDE users, or something like that. But for some people installing qt5ct resolved the issues. That was a mess that I never figured out.

[0]: <https://github.com/ckb-next/ckb-next/issues/139>
Comment 9 Marcel Kuehlhorn 2019-09-06 10:23:32 UTC
(In reply to Ave Milia from comment #8)
> Is there a tracking bug for this particular issue of tg? For example,
> ckb-next was haunted by it[0] (if that's the same cause) seemingly due to
> appindicator, and it only happened for KDE users, or something like that.
> But for some people installing qt5ct resolved the issues. That was a mess
> that I never figured out.
> 
> [0]: <https://github.com/ckb-next/ckb-next/issues/139>

Not an open one at least, the one I could find [1] was closed with (paraphrasing): "Use our binary blob, we don't care about errors with distro packages"

[1] https://github.com/telegramdesktop/tdesktop/issues/4301
Comment 10 Ave Milia 2019-09-06 10:36:39 UTC
(In reply to Marcel Kuehlhorn from comment #9)
> (In reply to Ave Milia from comment #8)
> > Is there a tracking bug for this particular issue of tg? For example,
> > ckb-next was haunted by it[0] (if that's the same cause) seemingly due to
> > appindicator, and it only happened for KDE users, or something like that.
> > But for some people installing qt5ct resolved the issues. That was a mess
> > that I never figured out.
> > 
> > [0]: <https://github.com/ckb-next/ckb-next/issues/139>
> 
> Not an open one at least, the one I could find [1] was closed with
> (paraphrasing): "Use our binary blob, we don't care about errors with distro
> packages"

Fair enough :) As a developer, I 100% understand their decision.

> 
> [1] https://github.com/telegramdesktop/tdesktop/issues/4301

So, do you have any documented issues on your side? Or where did you pull the #7 error messages from? If you have any recorded information and can reproduce it, it's probably a good idea to create a new bug for it. I feel like this issue is triggered by some edge case in a mishmash of Qt versions, now-additional Qt packages (like platform themes), desktop environments and tray icon libraries.

Regarding current issue, if you (or any other knowledgeable people) think that current resolution of package removal is a correct one and is not a temporary workaround, feel free to close.
Comment 11 Marcel Kuehlhorn 2019-09-09 09:58:40 UTC
*** Bug 1149130 has been marked as a duplicate of this bug. ***
Comment 12 Marcel Kuehlhorn 2019-09-09 10:20:15 UTC
(In reply to Ave Milia from comment #10)
> 
> So, do you have any documented issues on your side? Or where did you pull
> the #7 error messages from? If you have any recorded information and can
> reproduce it, it's probably a good idea to create a new bug for it. I feel
> like this issue is triggered by some edge case in a mishmash of Qt versions,
> now-additional Qt packages (like platform themes), desktop environments and
> tray icon libraries.
> 
I did not have one yet, created bug 1149986 now.
The error messages are from building telegram-desktop without the Conflicts and installing it together with libqt5-qtstyleplugins-platformtheme-gtk2

> Regarding current issue, if you (or any other knowledgeable people) think
> that current resolution of package removal is a correct one and is not a
> temporary workaround, feel free to close.
>
I'll keep this Issue open to discussion seeing as you're not the first one to bring it up and I get the feeling quite a few people would prefer disabled GTK integration / no native notifications as it was before.
Comment 13 andy great 2019-09-09 21:47:16 UTC
cinnamon-session required libqt5-qtstyleplugins-platformtheme-gtk2 as hard dependency, therefore user with cinnamon desktop cannot install telegram from the repo.
Comment 14 Marcel Kuehlhorn 2019-09-10 08:53:11 UTC
(In reply to andy great from comment #13)
> cinnamon-session required libqt5-qtstyleplugins-platformtheme-gtk2 as hard
> dependency, therefore user with cinnamon desktop cannot install telegram
> from the repo.

I guess I'll have to disable GTK integration on the main package again with the next version update...

A branch with it enabled will be kept at
https://build.opensuse.org/project/show/home:tux93:tdesktop
Comment 15 Marcel Kuehlhorn 2019-09-13 13:55:21 UTC
SR#730197 with the update to 1.8.8 was just accepted to Factory, it removes GTK integration and the Conflict again.