Bug 1148444 - wicked&wpa_supplicant: ni_wpa_interface_bind(wlp0s20f0u9): Operation not permitted
wicked&wpa_supplicant: ni_wpa_interface_bind(wlp0s20f0u9): Operation not perm...
Status: RESOLVED DUPLICATE of bug 1166933
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
Other Other
: P5 - None : Normal with 5 votes (vote)
: ---
Assigned To: wicked maintainers
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-08-28 04:57 UTC by Marguerite Su
Modified: 2020-03-30 12:10 UTC (History)
5 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marguerite Su 2019-08-28 04:57:12 UTC
Hi,

In TW 20190814+, wicked can't connect to Wi-Fi at boot time.

I found these messages:

8月 28 12:36:59 linux-fpbk wickedd[1260]: __ni_dbus_object_message(path=/org/opensuse/Network/Interface/3, interface=org.opensuse.Network.Wireless, method=changeDevice) ca>
8月 28 12:36:59 linux-fpbk wickedd[1260]: ni_dbus_client_open(bus_type=system, bus_name=fi.epitest.hostap.WPASupplicant)
8月 28 12:36:59 linux-fpbk wickedd[1260]: ni_dbus_connection_open(bus=system, name=)
8月 28 12:36:59 linux-fpbk dbus-daemon[1033]: [system] Activating via systemd: service name='fi.epitest.hostap.WPASupplicant' unit='wpa_supplicant.service' requested by ':>
8月 28 12:37:01 linux-fpbk ModemManager[1043]: <info>  Couldn't check support for device '/sys/devices/pci0000:00/0000:00:14.0/usb1/1-9': not supported by any plugin
8月 28 12:37:01 linux-fpbk ModemManager[1043]: <info>  Couldn't check support for device '/sys/devices/pci0000:00/0000:00:1c.7/0000:03:00.0': not supported by any plugin
8月 28 12:37:24 linux-fpbk dbus-daemon[1033]: [system] Failed to activate service 'fi.epitest.hostap.WPASupplicant': timed out (service_start_timeout=25000ms)
8月 28 12:37:24 linux-fpbk wickedd[1260]: dbus error reply = org.freedesktop.DBus.Error.TimedOut (Failed to activate service 'fi.epitest.hostap.WPASupplicant': timed out (>
8月 28 12:37:24 linux-fpbk wickedd[1260]: ni_dbus_translate_error(org.freedesktop.DBus.Error.TimedOut, msg=Failed to activate service 'fi.epitest.hostap.WPASupplicant': ti>
8月 28 12:37:24 linux-fpbk wickedd[1260]: unable to map DBus error org.freedesktop.DBus.Error.TimedOut, return GENERAL_FAILURE
8月 28 12:37:24 linux-fpbk wickedd[1260]: ni_wpa_interface_bind(wlp0s20f0u9): Operation not permitted
8月 28 12:37:24 linux-fpbk wickedd[1260]: wpa_supplicant doesn't know interface wlp0s20f0u9
8月 28 12:37:24 linux-fpbk wickedd-nanny[1264]: dbus error reply = org.freedesktop.DBus.Error.Failed (could not associate)
8月 28 12:37:24 linux-fpbk wickedd-nanny[1264]: ni_ifworker_error_handler(org.freedesktop.DBus.Error.Failed, could not associate)
8月 28 12:37:24 linux-fpbk wickedd-nanny[1264]: unable to map DBus error org.freedesktop.DBus.Error.Failed, return GENERAL_FAILURE
8月 28 12:37:24 linux-fpbk wickedd-nanny[1264]: device wlp0s20f0u9: call to org.opensuse.Network.Wireless.changeDevice() failed: General failure
8月 28 12:37:24 linux-fpbk wickedd-nanny[1264]: ni_managed_device_progress(wlp0s20f0u9) target(network-up [network-up..max]), transition(none => none)
8月 28 12:37:24 linux-fpbk wickedd-nanny[1264]: sending event "progressInfo"
8月 28 12:37:24 linux-fpbk wickedd-nanny[1264]: wlp0s20f0u9: failed to bring up device, still continuing

It seems wicked can't talk to wpa_supplicant via DBus.

I built a verbose dbus and found these two important messages:

skipping rule because dest fi.epitest.hostap.WPASupplicant doesn’t exist 
....
skipping rule because dest fi.epitest.hostap.WPASupplicant isn’t owned by receiver.

It looks like:

1. wicked.service (beforce network.target) started before wpa_supplicant.service (after network.target), so actually wicked brought up wpa_supplicant.

2. wicked didn't find the DBus interface of wpa_supplicant, so it started/created it.

3. wicked sent messages to wpa_supplicant via DBus, but due to some reasons (isn't owned by receiver), DBus can't send the reply back.

I did some monkey patching around, but didn't find out any clue.

I'm ready to help debugging this/testing patches.

Marguerite
Comment 1 Marguerite Su 2019-08-28 04:58:09 UTC
assigned to MT.
Comment 2 Ignat Awwit 2019-08-29 08:07:43 UTC
I have the same problem, I have to manually start the network every time. 

Hope to fix it soon.
Comment 3 simon becherer 2019-10-07 09:49:24 UTC
Same here
a automated work around would be good
simoN
Comment 4 Luca Billi 2019-11-14 13:20:11 UTC
Looks similar to bug 1144670.
Comment 5 Marius Tomaschewski 2020-03-30 12:10:11 UTC
This is a result of some systemd-networkd workaround tweaks in:

https://bugzilla.suse.com/show_bug.cgi?id=1165266

The wpa_supplicant has been changed to start after the network setup,
fix reverting the change is in bug 1166933.

*** This bug has been marked as a duplicate of bug 1166933 ***