Bug 1148397 - Meta bug: Qt4 removal
Meta bug: Qt4 removal
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: KDE Applications
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-Mail List
E-mail List
:
Depends on: 1148398 1148401 1148406 1148408
Blocks:
  Show dependency treegraph
 
Reported: 2019-08-27 16:10 UTC by Christophe Marin
Modified: 2019-10-14 11:32 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christophe Marin 2019-08-27 16:10:31 UTC
The following packages have a direct dependency on Qt4 and shall be dropped if a Qt5 version is not available or functional:

- gwenhywfar
- keepassx
- mumble
- qgo


* gwenhywfar: The previous attempt to use a beta version was reverted without notifying the SR author... See https://bugzilla.opensuse.org/1139415

The last beta snapshot is 4.99.11beta from march. Not much activity since then.

* keepassx: The previous messages on the factory list indicate that keepassxc has more features. No action was taken to replace keepassx.

* mumble: mumble 1.3.0-rc2 was released on june.

* qgo: Dead upstream. There are 2 possible solution:
 - Replace it with https://senseis.xmp.net/?QGo
 - Use a git snapshot from the original repo https://github.com/pzorin/qgo
Comment 1 Christophe Marin 2019-08-27 16:15:50 UTC
About Scribus which we maintain, 2 options:
- Use the official Qt5 development version, see https://www.scribus.net/scribus-1-5-5-released/ 
Package available here: https://build.opensuse.org/package/show/home:cgiboudeaux:branches:KDE:Extra/scribus

- Use a snapshot tracking the SVN repo
Comment 2 Dr. Werner Fink 2019-08-28 06:20:29 UTC
(In reply to Christophe Giboudeaux from comment #0)
> The following packages have a direct dependency on Qt4 and shall be dropped
> if a Qt5 version is not available or functional:
> 
> - gwenhywfar
> - keepassx

Bad idea to drop keepassx ... https://en.wikipedia.org/wiki/KeePassX
that is there are many users (including me)
Comment 3 Dr. Werner Fink 2019-08-28 06:23:13 UTC
(In reply to Dr. Werner Fink from comment #2)
> (In reply to Christophe Giboudeaux from comment #0)
> > The following packages have a direct dependency on Qt4 and shall be dropped
> > if a Qt5 version is not available or functional:
> > 
> > - gwenhywfar
> > - keepassx
> 
> Bad idea to drop keepassx ... https://en.wikipedia.org/wiki/KeePassX
> that is there are many users (including me)

https://github.com/keepassx/keepassx ... looks like there is a Qt 5.11 with latest master ... adding maintainer/bugowner of keepassx to carbon copy list
Comment 4 Christophe Marin 2019-08-28 06:44:29 UTC
(In reply to Dr. Werner Fink from comment #2)
> (In reply to Christophe Giboudeaux from comment #0)
> > The following packages have a direct dependency on Qt4 and shall be dropped
> > if a Qt5 version is not available or functional:
> > 
> > - gwenhywfar
> > - keepassx
> 
> Bad idea to drop keepassx ... https://en.wikipedia.org/wiki/KeePassX
> that is there are many users (including me)

https://bugzilla.opensuse.org/1148401 for the keepassx report.
Comment 5 Christophe Marin 2019-10-14 11:32:01 UTC
Say goodbye to KDE4 & Qt4