Bug 1148353 - raspberry pi 1 (armv6l) latest image halts instead of reboot
raspberry pi 1 (armv6l) latest image halts instead of reboot
Status: RESOLVED NORESPONSE
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
Other openSUSE Factory
: P5 - None : Major (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-08-27 12:19 UTC by redstorm psydiver
Modified: 2019-11-01 11:08 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
tiwai: needinfo? (redstorm2000)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description redstorm psydiver 2019-08-27 12:19:52 UTC
Recently i decided to do a full upgrade on one of my raspberry pi's which have opensuse tumbleweed and was rebooting fine. First thing i noticed that after update & reboot it didn't booted by itself, so i have to power cycle it. Later i noticed that either "shutdown -r now", or "reboot" .. and even 'echo "b" > /proc/sysrq-trigger' is not working on newer distribution! it's simply halted and needs to be power cycled manually to reboot! i even attached a serial console and the system is looking like this:

[  OK  ] Stopped File System Check on Root Device.
[  OK  ] Stopped Create Static Device Nodes in /dev.
[  OK  ] Reached target Shutdown.
[  OK  ] Reached target Final Step.
[  OK  ] Started Reboot.
[  OK  ] Reached target Reboot.
[  144.054311] reboot: Restarting system

And that's all! No reboot.. forever in that state. Older images on the same hardware rebooting fine, i even tested a bunch of other raspberries (1B and 1B+) and they all hangs on reboot now.

Steps to reproduce:
1. Download latest image from HCL:Raspberry_Pi & save it to sd card.
2. Try to reboot the system...

PS. "downstream kernel" image from HCL:Raspberry_Pi is not working at all, stuck in a booting loop according to serial console.
Comment 1 redstorm psydiver 2019-08-27 22:13:54 UTC
I must add, that i think is't a critical issue as rebooting is very substantial part of a system management process (i.e. upgrade). And it's not that good if a physical access or additional tools is needed to reboot the system... That way now i forced to use my older working tumbleweed images (which is incompatible by packages now if i want to install/update something), or even another OS ...
Comment 2 Takashi Iwai 2019-08-29 08:59:34 UTC
Is this a kernel regression?  Please test the new image but with an older kernel that has worked.
Comment 3 Jiri Slaby 2019-11-01 11:08:51 UTC
Closing due to lack of response.