Bug 1148183 - Calibre is not installable due to missing libicu >= 4.4
Calibre is not installable due to missing libicu >= 4.4
Status: RESOLVED FIXED
: 1167278 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
x86-64 All
: P5 - None : Normal (vote)
: ---
Assigned To: Eric Schirra
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-08-26 14:31 UTC by Vojtech Zeisek
Modified: 2021-07-10 12:12 UTC (History)
8 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vojtech Zeisek 2019-08-26 14:31:17 UTC
Calibre e-book manager https://calibre-ebook.com/ is not installable in the current Tumbleweed due to missing libicu >= 4.4:

sudo zypper se -s calibre
Loading repository data...
Reading installed packages...

S | Name    | Type    | Version    | Arch   | Repository
--+---------+---------+------------+--------+-----------
  | calibre | package | 3.46.0-1.2 | x86_64 | tw-oss
  | calibre | package | 3.46.0-1.2 | i586   | tw-oss

sudo zypper in calibre
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: nothing provides libicu >= 4.4 needed by calibre-3.46.0-1.2.x86_64
 Solution 1: do not install calibre-3.46.0-1.2.x86_64
 Solution 2: break calibre-3.46.0-1.2.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c/d/?] (c):
Comment 1 Jan Engelhardt 2019-08-26 19:23:26 UTC
There is not really a need to runtime-require "libicu >= 4.4", because the version has always been encoded in the SONAME, meaning having a build-require on "libicu >= 4.4" will guarantee it will always be 4.4+ at runtime too.
Comment 2 Bob Vickers 2020-01-20 14:09:33 UTC
This problem has now been introduced into opensuse 15.1 by patch openSUSE-2020-74. The patch would not install until I removed calibre.

Before installing the patch release lp151.2.4 of package libicu60_2 provided libicu, but release lp151.3.3.1 does not.

I presume from Jan's comments it is safe to force the installation of calibre?
Comment 3 Bob Vickers 2020-01-21 10:12:48 UTC
Very short-lived bug in opensuse 15.1! Was fixed today by patch 2020-83-1
Comment 4 Mark Fairbairn 2020-04-06 09:05:52 UTC
This bug is also present in openSUSE Leap 15.2 Beta (Build 617.1)
Comment 5 Andreas Stieger 2021-07-10 11:46:39 UTC
.

*** This bug has been marked as a duplicate of bug 1167278 ***
Comment 6 Jan Engelhardt 2021-07-10 12:12:54 UTC
*** Bug 1167278 has been marked as a duplicate of this bug. ***