Bug 1148085 - x.org display flickering/artifacting when scrolling (basically, when something needs to be refreshed)
x.org display flickering/artifacting when scrolling (basically, when somethin...
Status: RESOLVED UPSTREAM
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
x86-64 Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-08-26 08:03 UTC by bzz bee
Modified: 2019-11-04 12:25 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
tiwai: needinfo? (bezdek)


Attachments
snapper diff between particular updates when the issue arrived (2.64 MB, application/x-xz)
2019-08-26 08:57 UTC, bzz bee
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bzz bee 2019-08-26 08:03:09 UTC
The problem started appear after 1-2 rolling updates on tumbleweed.
Description:
When i scroll (firefox or terminal history) the graphics on places where it needs to "change" start to flickering. when the "scroll/move" is done, it changes to "normal display". (even hovering over icons in xfce panel cause this flickering)

In dmesg quite a lot of warnings like:
[37101.852459] WARNING: CPU: 2 PID: 2102 at drivers/gpu/drm/amd/amdgpu/../display/dc/dcn10/dcn10_hw_sequencer.c:854 dcn10_verify_allow_pstate_change_high.cold+0xc/0x229 [amdgpu]
[37101.852460] Modules linked in: fuse vhost_net vhost tap tun ebtable_filter ebtables ip6table_filter ip6_tables iptable_filter ip_tables x_tables bpfilter scsi_transport_iscsi af_packet br_netfilter bridge stp llc iscsi_ibft iscsi_boot_sysfs msr nls_iso8859_1 nls_cp437 vfat fat edac_mce_amd kvm_amd ccp kvm irqbypass crct10dif_pclmul crc32_pclmul ghash_clmulni_intel aesni_intel snd_hda_codec_realtek snd_hda_codec_generic aes_x86_64 ledtrig_audio crypto_simd cryptd glue_helper snd_hda_codec_hdmi eeepc_wmi asus_wmi sparse_keymap wmi_bmof rfkill snd_hda_intel pcspkr k10temp snd_hda_codec sp5100_tco snd_hda_core i2c_piix4 snd_hwdep snd_pcm r8169 snd_timer snd realtek soundcore joydev libphy gpio_amdpt gpio_generic pcc_cpufreq button acpi_cpufreq uas usb_storage hid_logitech_hidpp btrfs hid_logitech_dj libcrc32c xor raid6_pq hid_generic usbhid amdgpu crc32c_intel amd_iommu_v2 gpu_sched i2c_algo_bit ttm drm_kms_helper syscopyarea sysfillrect sysimgblt fb_sys_fops drm xhci_pci xhci_hcd usbcore wmi
[37101.852471]  video pinctrl_amd sg dm_multipath dm_mod scsi_dh_rdac scsi_dh_emc scsi_dh_alua efivarfs
[37101.852473] CPU: 2 PID: 2102 Comm: X Tainted: G        W         5.2.9-1-default #1 openSUSE Tumbleweed (unreleased)
[37101.852474] Hardware name: System manufacturer System Product Name/PRIME B450M-A, BIOS 1804 07/29/2019
[37101.852514] RIP: 0010:dcn10_verify_allow_pstate_change_high.cold+0xc/0x229 [amdgpu]
[37101.852515] Code: 83 c8 ff e9 a9 ca f9 ff 48 c7 c7 b8 aa 6c c0 e8 7c d5 2c d0 0f 0b 83 c8 ff e9 93 ca f9 ff 48 c7 c7 b8 aa 6c c0 e8 66 d5 2c d0 <0f> 0b 80 bb 93 01 00 00 00 75 05 e9 79 ee f9 ff 48 8b 83 80 02 00
[37101.852515] RSP: 0018:ffffac1083c1b638 EFLAGS: 00010282
[37101.852516] RAX: 0000000000000024 RBX: ffff9257e5060000 RCX: 0000000000000006
[37101.852516] RDX: 0000000000000007 RSI: 0000000000000002 RDI: ffff9257eea99a10
[37101.852517] RBP: ffff9252e0fd0ec0 R08: 000021be72bbc983 R09: ffff9257ee800000
[37101.852517] R10: 000000000000b22e R11: 00000000001d545c R12: ffff9252e0fd0000
[37101.852517] R13: ffff9257e5060000 R14: ffff9257e582e540 R15: 0000000000000003
[37101.852518] FS:  00007fddbce26940(0000) GS:ffff9257eea80000(0000) knlGS:0000000000000000
[37101.852518] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[37101.852519] CR2: 00000008004354c8 CR3: 00000007d22e6000 CR4: 00000000003406e0
[37101.852519] Call Trace:
[37101.852558]  dcn10_program_pipe+0x1a7/0x270 [amdgpu]
[37101.852596]  dcn10_apply_ctx_for_surface+0x4d6/0x5e0 [amdgpu]
[37101.852634]  dc_commit_updates_for_stream+0x7f1/0xbe0 [amdgpu]
[37101.852671]  amdgpu_dm_commit_planes.constprop.0+0x6b4/0x880 [amdgpu]
[37101.852709]  amdgpu_dm_atomic_commit_tail+0x9be/0xd30 [amdgpu]
[37101.852714]  ? commit_tail+0x3c/0x70 [drm_kms_helper]
[37101.852718]  commit_tail+0x3c/0x70 [drm_kms_helper]
[37101.852722]  drm_atomic_helper_commit+0x108/0x110 [drm_kms_helper]
[37101.852726]  restore_fbdev_mode_atomic+0x1b3/0x1c0 [drm_kms_helper]
[37101.852729]  drm_fb_helper_pan_display+0xb6/0x1c0 [drm_kms_helper]
[37101.852731]  fb_pan_display+0x83/0x100
[37101.852732]  bit_update_start+0x1a/0x40
[37101.852733]  fbcon_switch+0x3a3/0x570
[37101.852734]  redraw_screen+0x128/0x210
[37101.852735]  fbcon_blank+0x277/0x2a0
[37101.852737]  do_unblank_screen+0xaa/0x150
[37101.852738]  complete_change_console+0x54/0xd0
[37101.852738]  vt_ioctl+0x1181/0x11c0
[37101.852744]  ? drm_setmaster_ioctl+0xb0/0xb0 [drm]
[37101.852745]  tty_ioctl+0x372/0x8c0
[37101.852746]  ? ktime_get_mono_fast_ns+0x4e/0x90
[37101.852747]  do_vfs_ioctl+0x447/0x640
[37101.852748]  ? do_futex+0x10a/0x1d0
[37101.852749]  ksys_ioctl+0x5e/0x90
[37101.852750]  ? trace_hardirqs_off_thunk+0x1a/0x33
[37101.852751]  __x64_sys_ioctl+0x16/0x20
[37101.852752]  do_syscall_64+0x6e/0x1e0
[37101.852753]  entry_SYSCALL_64_after_hwframe+0x49/0xbe
[37101.852754] RIP: 0033:0x7fddbd20a7c7
[37101.852755] Code: 00 00 90 48 8b 05 d1 86 0c 00 64 c7 00 26 00 00 00 48 c7 c0 ff ff ff ff c3 66 2e 0f 1f 84 00 00 00 00 00 b8 10 00 00 00 0f 05 <48> 3d 01 f0 ff ff 73 01 c3 48 8b 0d a1 86 0c 00 f7 d8 64 89 01 48
[37101.852755] RSP: 002b:00007fff001ac908 EFLAGS: 00003246 ORIG_RAX: 0000000000000010
[37101.852756] RAX: ffffffffffffffda RBX: 0000000000000001 RCX: 00007fddbd20a7c7
[37101.852756] RDX: 0000000000000001 RSI: 0000000000005605 RDI: 000000000000000c
[37101.852756] RBP: 00005617c64392cc R08: 0000000000000000 R09: 00007fff001ac630
[37101.852757] R10: 0000000000000007 R11: 0000000000003246 R12: 00005617c6439390
[37101.852757] R13: 00005617c6439380 R14: 00005617c64392c8 R15: 00007fff001ac984
[37101.852758] ---[ end trace 4bb79af4c980bd53 ]---


Also i can see errors with DRM:
[37030.228971] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:56:crtc-0] flip_done timed out
[37040.459614] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:56:crtc-0] flip_done timed out
[37050.690683] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CONNECTOR:64:HDMI-A-1] flip_done timed out
[37060.922091] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:49:plane-3] flip_done timed out



Now i'm on:
NAME="openSUSE Tumbleweed"
# VERSION="20190823"
ID="opensuse-tumbleweed"
ID_LIKE="opensuse suse"
VERSION_ID="20190823"
PRETTY_NAME="openSUSE Tumbleweed"
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:opensuse:tumbleweed:20190823"
BUG_REPORT_URL="https://bugs.opensuse.org"
HOME_URL="https://www.opensuse.org/"
LOGO="distributor-logo"

HW: 
AMD Ryzen 3 2200G with Radeon Vega Graphics

Also updated BIOS on my MB yesterday to check if it's related, but that didn't helped.

The problem is related with (most probably) graphic card driver. 

Some 2-3 releases all was ok. (not exactly sure, which was the exact release, where it worked fine, but it's 2-3 releases back)

Last installed releases:
2019-08-19 19:46:07|install|openSUSE-release-ftp|20190815-227.1|x86_64||repo-oss|2200bcee2d1dd427af75ff06f6e58368921e99abb1e6ff9b882493d4b7095bae|
2019-08-19 19:46:10|install|openSUSE-release|20190815-227.1|x86_64||repo-oss|4ff54ab75e8c2df5a204f33b4ff3deb0a5e8883ace55c7a799cd89b2694b5157|
2019-08-24 15:04:05|install|openSUSE-release-ftp|20190822-233.1|x86_64||repo-oss|79636bb94a53fe4f682e2bbfa1f1bcddf8ad67320f54951e7b328546e8ed5987|
2019-08-24 15:04:16|install|openSUSE-release|20190822-233.1|x86_64||repo-oss|45006b088c2272a61bbcdb112aae366f1ea0324be2e952d8f724bdc30bcb7730|
2019-08-25 21:17:36|install|openSUSE-release-ftp|20190823-234.1|x86_64||repo-oss|e608cd293c6ee38d8fd3f67b92b23fe929187741162b9c3cfd3bbc84e0384cf0|
2019-08-25 21:17:43|install|openSUSE-release|20190823-234.1|x86_64||repo-oss|7162b84b34a49e584b37326a43d7e3bf78538cb3465a644077cc9163f84d6fa9|
Comment 1 bzz bee 2019-08-26 08:31:08 UTC
no issue, when booted into old kernel:
Linux suse 5.2.5-1-default #1 SMP Wed Jul 31 10:41:36 UTC 2019 (79b6a9c) x86_64 x86_64 x86_64 GNU/Linux
Comment 2 bzz bee 2019-08-26 08:36:17 UTC
no issue, when booted into old kernel:
Linux suse 5.2.8-1-default #1 SMP Fri Aug 9 17:51:51 UTC 2019 (bf37e83) x86_64 x86_64 x86_64 GNU/Linux
Comment 3 Takashi Iwai 2019-08-26 08:40:20 UTC
With 5.2.8 you didn't get the kernel WARNING as well, not only the stall, right?

Just to be sure, please check whether the kernel in OBS Kernel:stable repo still shows the same problem.  It's the built from the latest stable git branch.
If the problem persists, try the latest 5.3-rc kernel in OBS Kernel:HEAD repo, too.  If the problem is present on both, we'd need to report this regression to upstream.

You can uninstall these test kernels once after testing.  Also, it's recommended to increase the number of multi-install packages in /etc/zypp/zypp.conf beforehand.
Comment 4 bzz bee 2019-08-26 08:57:13 UTC
Created attachment 815679 [details]
snapper diff between particular updates when the issue arrived

snapper diff between particular updates when the issue arrived
seems that this issue is maybe connected to xfce/xorg...
Comment 5 bzz bee 2019-08-26 09:39:36 UTC
now testing:
Linux suse 5.3.0-rc5-6.gdf791c5-default #1 SMP Fri Aug 23 07:47:04 UTC 2019 (df791c5) x86_64 x86_64 x86_64 GNU/Linux

nothing so far in dmesg, however no change with flickering graphics. can be realted to x.org/xfce (but dunno)

cd /var/log/lightdm;
cat x-0.log

X.Org X Server 1.20.5
X Protocol Version 11, Revision 0
Build Operating System: openSUSE SUSE LINUX
Current Operating System: Linux suse 5.3.0-rc5-6.gdf791c5-default #1 SMP Fri Aug 23 07:47:04 UTC 2019 (df791c5) x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-5.3.0-rc5-6.gdf791c5-default root=/dev/mapper/system-root splash=silent resume=/dev/system/swap quiet splash=silent resume=/dev/system/swap quiet
Build Date: 30 July 2019  12:00:00PM

Current version of pixman: 0.36.0
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Aug 26 11:31:10 2019
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(II) AMDGPU(0): [KMS] Kernel modesetting enabled.

Mon Aug 26 11:31:10 2019
 vncext:      VNC extension running!
 vncext:      Listening for VNC connections on all interface(s), port 5900
 vncext:      created VNC server for screen 0



 cat  lightdm.log
[+0.00s] DEBUG: Logging to /var/log/lightdm/lightdm.log
[+0.00s] DEBUG: Starting Light Display Manager 1.28.0, UID=0 PID=1961
[+0.00s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-suse-defaults.conf
[+0.00s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
[+0.00s] DEBUG: Registered seat module local
[+0.00s] DEBUG: Registered seat module xremote
[+0.00s] DEBUG: Registered seat module unity
[+0.00s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+0.00s] DEBUG: _g_io_module_get_default: Found default implementation local (GLocalVfs) for ‘gio-vfs’
[+0.00s] DEBUG: Monitoring logind for seats
[+0.00s] DEBUG: New seat added from logind: seat0
[+0.00s] DEBUG: Seat seat0: Loading properties from config section Seat:*
[+0.00s] DEBUG: Seat seat0: Starting
[+0.00s] DEBUG: Seat seat0: Creating user session
[+0.08s] DEBUG: Loading users from org.freedesktop.Accounts
[+0.08s] DEBUG: User /org/freedesktop/Accounts/User1000 added
[+0.12s] DEBUG: Seat seat0: Creating display server of type x
[+0.12s] DEBUG: posix_spawn avoided (fd close requested)
[+0.13s] DEBUG: Using VT 7
[+0.13s] DEBUG: Seat seat0: Starting local X display on VT 7
[+0.13s] DEBUG: XServer 0: Logging to /var/log/lightdm/x-0.log
[+0.13s] DEBUG: XServer 0: Writing X server authority to /run/lightdm/root/:0
[+0.13s] DEBUG: XServer 0: Launching X Server
[+0.13s] DEBUG: Launching process 2013: /usr/bin/X :0 -seat seat0 -auth /run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
[+0.13s] DEBUG: XServer 0: Waiting for ready signal from X server :0
[+0.13s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
[+0.13s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
[+0.13s] DEBUG: posix_spawn avoided (automatic reaping requested) (fd close requested)
[+1.11s] DEBUG: Got signal 10 from process 2013
[+1.11s] DEBUG: XServer 0: Got signal from X server :0
[+1.11s] DEBUG: XServer 0: Connecting to XServer :0
[+1.11s] DEBUG: posix_spawn avoided (fd close requested) (child_setup specified)
[+1.11s] DEBUG: Seat seat0: Display server ready, starting session authentication
[+1.11s] DEBUG: Session pid=2137: Started with service 'lightdm-autologin', username 'bzz'
[+1.15s] DEBUG: Session pid=2137: Authentication complete with return value 0: Success
[+1.15s] DEBUG: Seat seat0: Session authenticated, running command
[+1.16s] DEBUG: Launching process 2140: /etc/X11/xdm/Xstartup
[+1.17s] DEBUG: Process 2140 exited with return value 0
[+1.17s] DEBUG: Seat seat0: Exit status of /etc/X11/xdm/Xstartup: 0
[+1.17s] DEBUG: Registering session with bus path /org/freedesktop/DisplayManager/Session0
[+1.17s] DEBUG: posix_spawn avoided (fd close requested) (child_setup specified)
[+1.17s] DEBUG: Session pid=2137: Running command /etc/X11/xdm/Xsession startxfce4
[+1.17s] DEBUG: Creating shared data directory /var/lib/lightdm-data/bzz
[+1.17s] DEBUG: Session pid=2137: Logging to .xsession-errors
[+1.31s] DEBUG: Activating VT 7
[+1.31s] DEBUG: Activating login1 session 1
[+1.31s] DEBUG: Seat seat0 changes active session to 1
[+1.31s] DEBUG: Session 1 is already active



but i cannot see anything unusual...
Comment 6 bzz bee 2019-08-26 09:42:45 UTC
Ok, now i probably found out how to really test this:

When i booted to the RC kernel (in previous post) all was fine. 
I'm disable all screensavers/sleep modes etc. (it's a desktop) and only thing i turn off is the display (Dell U3014). 
Now when i started it back again, the Warnings appeared in dmesg and i have "solid green screen" (that happened time to time before already, but usually went out after some kernel upgrade.


Linux suse 5.3.0-rc5-6.gdf791c5-default #1 SMP Fri Aug 23 07:47:04 UTC 2019 (df791c5) x86_64 x86_64 x86_64 GNU/Linux

Adding dmesg warning when i started the display up:

[  560.861723] [drm] pstate TEST_DEBUG_DATA: 0x37F6F000
[  560.861725] ------------[ cut here ]------------
[  560.861802] WARNING: CPU: 1 PID: 176 at drivers/gpu/drm/amd/amdgpu/../display/dc/dcn10/dcn10_hw_sequencer.c:932 dcn10_verify_allow_pstate_change_high.cold+0xc/0x229 [amdgpu]
[  560.861803] Modules linked in: fuse vhost_net vhost tap tun ebtable_filter ebtables ip6table_filter ip6_tables iptable_filter ip_tables x_tables bpfilter scsi_transport_iscsi af_packet br_netfilter bridge stp llc iscsi_ibft iscsi_boot_sysfs msr nls_iso8859_1 nls_cp437 vfat fat edac_mce_amd kvm_amd ccp kvm irqbypass crct10dif_pclmul crc32_pclmul ghash_clmulni_intel snd_hda_codec_realtek snd_hda_codec_generic snd_hda_codec_hdmi ledtrig_audio snd_hda_intel snd_hda_codec aesni_intel aes_x86_64 crypto_simd cryptd snd_hda_core eeepc_wmi snd_hwdep glue_helper snd_pcm asus_wmi sparse_keymap pcspkr rfkill wmi_bmof sp5100_tco snd_timer r8169 snd k10temp realtek i2c_piix4 soundcore libphy joydev gpio_amdpt gpio_generic acpi_cpufreq button hid_logitech_hidpp btrfs libcrc32c xor uas usb_storage hid_logitech_dj raid6_pq hid_generic usbhid amdgpu amd_iommu_v2 gpu_sched i2c_algo_bit ttm drm_kms_helper syscopyarea sysfillrect sysimgblt fb_sys_fops drm xhci_pci crc32c_intel xhci_hcd usbcore wmi video
[  560.861822]  pinctrl_amd sg dm_multipath dm_mod scsi_dh_rdac scsi_dh_emc scsi_dh_alua efivarfs
[  560.861826] CPU: 1 PID: 176 Comm: kworker/u64:8 Not tainted 5.3.0-rc5-6.gdf791c5-default #1 openSUSE Tumbleweed (unreleased)
[  560.861827] Hardware name: System manufacturer System Product Name/PRIME B450M-A, BIOS 1804 07/29/2019
[  560.861833] Workqueue: events_unbound commit_work [drm_kms_helper]
[  560.861883] RIP: 0010:dcn10_verify_allow_pstate_change_high.cold+0xc/0x229 [amdgpu]
[  560.861884] Code: 83 c8 ff e9 58 3d f8 ff 48 c7 c7 58 6b 7c c0 e8 99 5a ff c5 0f 0b 83 c8 ff e9 42 3d f8 ff 48 c7 c7 58 6b 7c c0 e8 83 5a ff c5 <0f> 0b 80 bb 9f 01 00 00 00 75 05 e9 d6 63 f8 ff 48 8b 83 f8 02 00
[  560.861885] RSP: 0018:ffffa5698045fa18 EFLAGS: 00010286
[  560.861886] RAX: 0000000000000024 RBX: ffff88c961920000 RCX: 0000000000000006
[  560.861886] RDX: 0000000000000007 RSI: 0000000000000092 RDI: ffff88c96ea59a10
[  560.861887] RBP: ffff88c961920000 R08: 00000000000004c4 R09: 0000000000000001
[  560.861887] R10: 0000000000000000 R11: 0000000000000001 R12: ffff88c6e08901b8
[  560.861888] R13: ffff88c947c4d000 R14: ffff88c6e08913f8 R15: 0000000000000004
[  560.861888] FS:  0000000000000000(0000) GS:ffff88c96ea40000(0000) knlGS:0000000000000000
[  560.861889] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[  560.861889] CR2: 00007fe7d200b000 CR3: 00000006c4ea8000 CR4: 00000000003406e0
[  560.861890] Call Trace:
[  560.861941]  dcn10_pipe_control_lock.part.0+0x69/0x70 [amdgpu]
[  560.861988]  commit_planes_for_stream+0x5a4/0x860 [amdgpu]
[  560.862033]  dc_commit_updates_for_stream+0x942/0xab0 [amdgpu]
[  560.862078]  amdgpu_dm_commit_planes.constprop.0+0x7d7/0x9a0 [amdgpu]
[  560.862123]  amdgpu_dm_atomic_commit_tail+0x94c/0xfb0 [amdgpu]
[  560.862138]  ? __btrfs_drop_extents+0xb11/0xdc0 [btrfs]
[  560.862141]  ? __switch_to_asm+0x40/0x70
[  560.862142]  ? __switch_to_asm+0x34/0x70
[  560.862143]  ? __switch_to_asm+0x40/0x70
[  560.862144]  ? __switch_to_asm+0x34/0x70
[  560.862145]  ? __switch_to_asm+0x40/0x70
[  560.862146]  ? __switch_to_asm+0x34/0x70
[  560.862147]  ? __switch_to_asm+0x40/0x70
[  560.862148]  ? __switch_to_asm+0x34/0x70
[  560.862149]  ? __switch_to_asm+0x40/0x70
[  560.862149]  ? __switch_to_asm+0x34/0x70
[  560.862150]  ? __switch_to_asm+0x40/0x70
[  560.862151]  ? __switch_to_asm+0x34/0x70
[  560.862152]  ? __switch_to_asm+0x40/0x70
[  560.862153]  ? __switch_to_asm+0x34/0x70
[  560.862154]  ? __switch_to_asm+0x40/0x70
[  560.862156]  ? trace_hardirqs_off_thunk+0x1a/0x30
[  560.862157]  ? wait_for_completion_timeout+0xf3/0x110
[  560.862158]  ? finish_task_switch+0x7e/0x280
[  560.862163]  ? commit_tail+0x3c/0x70 [drm_kms_helper]
[  560.862166]  commit_tail+0x3c/0x70 [drm_kms_helper]
[  560.862169]  process_one_work+0x1df/0x380
[  560.862170]  worker_thread+0x4d/0x400
[  560.862171]  kthread+0xf9/0x130
[  560.862173]  ? process_one_work+0x380/0x380
[  560.862173]  ? kthread_park+0x80/0x80
[  560.862175]  ret_from_fork+0x27/0x50
[  560.862176] ---[ end trace 1ec4a5fdfcd96670 ]---
[  560.862779] [drm] pstate TEST_DEBUG_DATA: 0x37F6F000
[  560.862779] ------------[ cut here ]------------
[  560.862843] WARNING: CPU: 1 PID: 176 at drivers/gpu/drm/amd/amdgpu/../display/dc/dcn10/dcn10_hw_sequencer.c:932 dcn10_verify_allow_pstate_change_high.cold+0xc/0x229 [amdgpu]
[  560.862843] Modules linked in: fuse vhost_net vhost tap tun ebtable_filter ebtables ip6table_filter ip6_tables iptable_filter ip_tables x_tables bpfilter scsi_transport_iscsi af_packet br_netfilter bridge stp llc iscsi_ibft iscsi_boot_sysfs msr nls_iso8859_1 nls_cp437 vfat fat edac_mce_amd kvm_amd ccp kvm irqbypass crct10dif_pclmul crc32_pclmul ghash_clmulni_intel snd_hda_codec_realtek snd_hda_codec_generic snd_hda_codec_hdmi ledtrig_audio snd_hda_intel snd_hda_codec aesni_intel aes_x86_64 crypto_simd cryptd snd_hda_core eeepc_wmi snd_hwdep glue_helper snd_pcm asus_wmi sparse_keymap pcspkr rfkill wmi_bmof sp5100_tco snd_timer r8169 snd k10temp realtek i2c_piix4 soundcore libphy joydev gpio_amdpt gpio_generic acpi_cpufreq button hid_logitech_hidpp btrfs libcrc32c xor uas usb_storage hid_logitech_dj raid6_pq hid_generic usbhid amdgpu amd_iommu_v2 gpu_sched i2c_algo_bit ttm drm_kms_helper syscopyarea sysfillrect sysimgblt fb_sys_fops drm xhci_pci crc32c_intel xhci_hcd usbcore wmi video
[  560.862860]  pinctrl_amd sg dm_multipath dm_mod scsi_dh_rdac scsi_dh_emc scsi_dh_alua efivarfs
[  560.862863] CPU: 1 PID: 176 Comm: kworker/u64:8 Tainted: G        W         5.3.0-rc5-6.gdf791c5-default #1 openSUSE Tumbleweed (unreleased)
[  560.862864] Hardware name: System manufacturer System Product Name/PRIME B450M-A, BIOS 1804 07/29/2019
[  560.862868] Workqueue: events_unbound commit_work [drm_kms_helper]
[  560.862916] RIP: 0010:dcn10_verify_allow_pstate_change_high.cold+0xc/0x229 [amdgpu]
[  560.862917] Code: 83 c8 ff e9 58 3d f8 ff 48 c7 c7 58 6b 7c c0 e8 99 5a ff c5 0f 0b 83 c8 ff e9 42 3d f8 ff 48 c7 c7 58 6b 7c c0 e8 83 5a ff c5 <0f> 0b 80 bb 9f 01 00 00 00 75 05 e9 d6 63 f8 ff 48 8b 83 f8 02 00
[  560.862918] RSP: 0018:ffffa5698045fa38 EFLAGS: 00010282
[  560.862918] RAX: 0000000000000024 RBX: ffff88c961920000 RCX: 0000000000000006
[  560.862919] RDX: 0000000000000007 RSI: 0000000000000096 RDI: ffff88c96ea59a10
[  560.862919] RBP: ffff88c961920000 R08: 00000000000004f9 R09: 0000000000000001
[  560.862920] R10: 0000000000000000 R11: 0000000000000001 R12: ffff88c6e0890000
[  560.862920] R13: ffff88c947c4d000 R14: ffff88c6e08913f8 R15: 0000000000000004
[  560.862921] FS:  0000000000000000(0000) GS:ffff88c96ea40000(0000) knlGS:0000000000000000
[  560.862921] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[  560.862922] CR2: 00007fe7d200b000 CR3: 00000006c4ea8000 CR4: 00000000003406e0
[  560.862922] Call Trace:
[  560.862967]  commit_planes_for_stream+0x5a4/0x860 [amdgpu]
[  560.863011]  dc_commit_updates_for_stream+0x942/0xab0 [amdgpu]
[  560.863055]  amdgpu_dm_commit_planes.constprop.0+0x7d7/0x9a0 [amdgpu]
[  560.863098]  amdgpu_dm_atomic_commit_tail+0x94c/0xfb0 [amdgpu]
[  560.863112]  ? __btrfs_drop_extents+0xb11/0xdc0 [btrfs]
[  560.863114]  ? __switch_to_asm+0x40/0x70
[  560.863115]  ? __switch_to_asm+0x34/0x70
[  560.863115]  ? __switch_to_asm+0x40/0x70
[  560.863116]  ? __switch_to_asm+0x34/0x70
[  560.863117]  ? __switch_to_asm+0x40/0x70
[  560.863118]  ? __switch_to_asm+0x34/0x70
[  560.863119]  ? __switch_to_asm+0x40/0x70
[  560.863120]  ? __switch_to_asm+0x34/0x70
[  560.863121]  ? __switch_to_asm+0x40/0x70
[  560.863121]  ? __switch_to_asm+0x34/0x70
[  560.863122]  ? __switch_to_asm+0x40/0x70
[  560.863123]  ? __switch_to_asm+0x34/0x70
[  560.863124]  ? __switch_to_asm+0x40/0x70
[  560.863125]  ? __switch_to_asm+0x34/0x70
[  560.863126]  ? __switch_to_asm+0x40/0x70
[  560.863127]  ? trace_hardirqs_off_thunk+0x1a/0x30
[  560.863128]  ? wait_for_completion_timeout+0xf3/0x110
[  560.863129]  ? finish_task_switch+0x7e/0x280
[  560.863133]  ? commit_tail+0x3c/0x70 [drm_kms_helper]
[  560.863137]  commit_tail+0x3c/0x70 [drm_kms_helper]
[  560.863138]  process_one_work+0x1df/0x380
[  560.863140]  worker_thread+0x4d/0x400
[  560.863141]  kthread+0xf9/0x130
[  560.863142]  ? process_one_work+0x380/0x380
[  560.863142]  ? kthread_park+0x80/0x80
[  560.863143]  ret_from_fork+0x27/0x50
[  560.863145] ---[ end trace 1ec4a5fdfcd96671 ]---
[  560.863746] [drm] pstate TEST_DEBUG_DATA: 0x37F6F000
[  560.863746] ------------[ cut here ]------------
[  560.863804] WARNING: CPU: 1 PID: 176 at drivers/gpu/drm/amd/amdgpu/../display/dc/dcn10/dcn10_hw_sequencer.c:932 dcn10_verify_allow_pstate_change_high.cold+0xc/0x229 [amdgpu]
[  560.863804] Modules linked in: fuse vhost_net vhost tap tun ebtable_filter ebtables ip6table_filter ip6_tables iptable_filter ip_tables x_tables bpfilter scsi_transport_iscsi af_packet br_netfilter bridge stp llc iscsi_ibft iscsi_boot_sysfs msr nls_iso8859_1 nls_cp437 vfat fat edac_mce_amd kvm_amd ccp kvm irqbypass crct10dif_pclmul crc32_pclmul ghash_clmulni_intel snd_hda_codec_realtek snd_hda_codec_generic snd_hda_codec_hdmi ledtrig_audio snd_hda_intel snd_hda_codec aesni_intel aes_x86_64 crypto_simd cryptd snd_hda_core eeepc_wmi snd_hwdep glue_helper snd_pcm asus_wmi sparse_keymap pcspkr rfkill wmi_bmof sp5100_tco snd_timer r8169 snd k10temp realtek i2c_piix4 soundcore libphy joydev gpio_amdpt gpio_generic acpi_cpufreq button hid_logitech_hidpp btrfs libcrc32c xor uas usb_storage hid_logitech_dj raid6_pq hid_generic usbhid amdgpu amd_iommu_v2 gpu_sched i2c_algo_bit ttm drm_kms_helper syscopyarea sysfillrect sysimgblt fb_sys_fops drm xhci_pci crc32c_intel xhci_hcd usbcore wmi video
[  560.863817]  pinctrl_amd sg dm_multipath dm_mod scsi_dh_rdac scsi_dh_emc scsi_dh_alua efivarfs
[  560.863820] CPU: 1 PID: 176 Comm: kworker/u64:8 Tainted: G        W         5.3.0-rc5-6.gdf791c5-default #1 openSUSE Tumbleweed (unreleased)
[  560.863820] Hardware name: System manufacturer System Product Name/PRIME B450M-A, BIOS 1804 07/29/2019
[  560.863824] Workqueue: events_unbound commit_work [drm_kms_helper]
[  560.863871] RIP: 0010:dcn10_verify_allow_pstate_change_high.cold+0xc/0x229 [amdgpu]
[  560.863873] Code: 83 c8 ff e9 58 3d f8 ff 48 c7 c7 58 6b 7c c0 e8 99 5a ff c5 0f 0b 83 c8 ff e9 42 3d f8 ff 48 c7 c7 58 6b 7c c0 e8 83 5a ff c5 <0f> 0b 80 bb 9f 01 00 00 00 75 05 e9 d6 63 f8 ff 48 8b 83 f8 02 00
[  560.863873] RSP: 0018:ffffa5698045fa18 EFLAGS: 00010286
[  560.863874] RAX: 0000000000000024 RBX: ffff88c961920000 RCX: 0000000000000006
[  560.863874] RDX: 0000000000000007 RSI: 0000000000000092 RDI: ffff88c96ea59a10
[  560.863874] RBP: ffff88c961920000 R08: 000000000000052d R09: 0000000000000001
[  560.863875] R10: 0000000000000000 R11: 0000000000000001 R12: ffff88c6e08901b8
[  560.863875] R13: ffff88c947c4d000 R14: 0000000000000004 R15: ffff88c940c3f800
[  560.863876] FS:  0000000000000000(0000) GS:ffff88c96ea40000(0000) knlGS:0000000000000000
[  560.863876] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[  560.863877] CR2: 00007fe7d200b000 CR3: 00000006c4ea8000 CR4: 00000000003406e0
[  560.863877] Call Trace:
[  560.863923]  dcn10_pipe_control_lock.part.0+0x69/0x70 [amdgpu]
[  560.863966]  commit_planes_for_stream+0x76c/0x860 [amdgpu]
[  560.864010]  dc_commit_updates_for_stream+0x942/0xab0 [amdgpu]
[  560.864053]  amdgpu_dm_commit_planes.constprop.0+0x7d7/0x9a0 [amdgpu]
[  560.864096]  amdgpu_dm_atomic_commit_tail+0x94c/0xfb0 [amdgpu]
[  560.864110]  ? __btrfs_drop_extents+0xb11/0xdc0 [btrfs]
[  560.864111]  ? __switch_to_asm+0x40/0x70
[  560.864112]  ? __switch_to_asm+0x34/0x70
[  560.864113]  ? __switch_to_asm+0x40/0x70
[  560.864114]  ? __switch_to_asm+0x34/0x70
[  560.864115]  ? __switch_to_asm+0x40/0x70
[  560.864116]  ? __switch_to_asm+0x34/0x70
[  560.864116]  ? __switch_to_asm+0x40/0x70
[  560.864117]  ? __switch_to_asm+0x34/0x70
[  560.864118]  ? __switch_to_asm+0x40/0x70
[  560.864119]  ? __switch_to_asm+0x34/0x70
[  560.864120]  ? __switch_to_asm+0x40/0x70
[  560.864121]  ? __switch_to_asm+0x34/0x70
[  560.864122]  ? __switch_to_asm+0x40/0x70
[  560.864122]  ? __switch_to_asm+0x34/0x70
[  560.864123]  ? __switch_to_asm+0x40/0x70
[  560.864124]  ? trace_hardirqs_off_thunk+0x1a/0x30
[  560.864126]  ? wait_for_completion_timeout+0xf3/0x110
[  560.864127]  ? finish_task_switch+0x7e/0x280
[  560.864131]  ? commit_tail+0x3c/0x70 [drm_kms_helper]
[  560.864134]  commit_tail+0x3c/0x70 [drm_kms_helper]
[  560.864136]  process_one_work+0x1df/0x380
[  560.864137]  worker_thread+0x4d/0x400
[  560.864138]  kthread+0xf9/0x130
[  560.864139]  ? process_one_work+0x380/0x380
[  560.864140]  ? kthread_park+0x80/0x80
[  560.864141]  ret_from_fork+0x27/0x50
[  560.864142] ---[ end trace 1ec4a5fdfcd96672 ]---
[  560.864719] [drm] pstate TEST_DEBUG_DATA: 0x37F6F000
[  560.864719] ------------[ cut here ]------------
[  560.864774] WARNING: CPU: 1 PID: 176 at drivers/gpu/drm/amd/amdgpu/../display/dc/dcn10/dcn10_hw_sequencer.c:932 dcn10_verify_allow_pstate_change_high.cold+0xc/0x229 [amdgpu]
[  560.864775] Modules linked in: fuse vhost_net vhost tap tun ebtable_filter ebtables ip6table_filter ip6_tables iptable_filter ip_tables x_tables bpfilter scsi_transport_iscsi af_packet br_netfilter bridge stp llc iscsi_ibft iscsi_boot_sysfs msr nls_iso8859_1 nls_cp437 vfat fat edac_mce_amd kvm_amd ccp kvm irqbypass crct10dif_pclmul crc32_pclmul ghash_clmulni_intel snd_hda_codec_realtek snd_hda_codec_generic snd_hda_codec_hdmi ledtrig_audio snd_hda_intel snd_hda_codec aesni_intel aes_x86_64 crypto_simd cryptd snd_hda_core eeepc_wmi snd_hwdep glue_helper snd_pcm asus_wmi sparse_keymap pcspkr rfkill wmi_bmof sp5100_tco snd_timer r8169 snd k10temp realtek i2c_piix4 soundcore libphy joydev gpio_amdpt gpio_generic acpi_cpufreq button hid_logitech_hidpp btrfs libcrc32c xor uas usb_storage hid_logitech_dj raid6_pq hid_generic usbhid amdgpu amd_iommu_v2 gpu_sched i2c_algo_bit ttm drm_kms_helper syscopyarea sysfillrect sysimgblt fb_sys_fops drm xhci_pci crc32c_intel xhci_hcd usbcore wmi video
[  560.864786]  pinctrl_amd sg dm_multipath dm_mod scsi_dh_rdac scsi_dh_emc scsi_dh_alua efivarfs
[  560.864788] CPU: 1 PID: 176 Comm: kworker/u64:8 Tainted: G        W         5.3.0-rc5-6.gdf791c5-default #1 openSUSE Tumbleweed (unreleased)
[  560.864789] Hardware name: System manufacturer System Product Name/PRIME B450M-A, BIOS 1804 07/29/2019
[  560.864793] Workqueue: events_unbound commit_work [drm_kms_helper]
[  560.864840] RIP: 0010:dcn10_verify_allow_pstate_change_high.cold+0xc/0x229 [amdgpu]
[  560.864841] Code: 83 c8 ff e9 58 3d f8 ff 48 c7 c7 58 6b 7c c0 e8 99 5a ff c5 0f 0b 83 c8 ff e9 42 3d f8 ff 48 c7 c7 58 6b 7c c0 e8 83 5a ff c5 <0f> 0b 80 bb 9f 01 00 00 00 75 05 e9 d6 63 f8 ff 48 8b 83 f8 02 00
[  560.864841] RSP: 0018:ffffa5698045fa38 EFLAGS: 00010282
[  560.864842] RAX: 0000000000000024 RBX: ffff88c961920000 RCX: 0000000000000006
[  560.864842] RDX: 0000000000000007 RSI: 0000000000000096 RDI: ffff88c96ea59a10
[  560.864842] RBP: ffff88c961920000 R08: 0000000000000562 R09: 0000000000000001
[  560.864843] R10: 0000000000000000 R11: 0000000000000001 R12: ffff88c6e0890000
[  560.864843] R13: ffff88c947c4d000 R14: 0000000000000004 R15: ffff88c940c3f800
[  560.864844] FS:  0000000000000000(0000) GS:ffff88c96ea40000(0000) knlGS:0000000000000000
[  560.864844] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[  560.864845] CR2: 00007fe7d200b000 CR3: 00000006c4ea8000 CR4: 00000000003406e0
[  560.864845] Call Trace:
[  560.864889]  commit_planes_for_stream+0x76c/0x860 [amdgpu]
[  560.864932]  dc_commit_updates_for_stream+0x942/0xab0 [amdgpu]
[  560.864976]  amdgpu_dm_commit_planes.constprop.0+0x7d7/0x9a0 [amdgpu]
[  560.865019]  amdgpu_dm_atomic_commit_tail+0x94c/0xfb0 [amdgpu]
[  560.865032]  ? __btrfs_drop_extents+0xb11/0xdc0 [btrfs]
[  560.865033]  ? __switch_to_asm+0x40/0x70
[  560.865034]  ? __switch_to_asm+0x34/0x70
[  560.865035]  ? __switch_to_asm+0x40/0x70
[  560.865036]  ? __switch_to_asm+0x34/0x70
[  560.865037]  ? __switch_to_asm+0x40/0x70
[  560.865038]  ? __switch_to_asm+0x34/0x70
[  560.865039]  ? __switch_to_asm+0x40/0x70
[  560.865040]  ? __switch_to_asm+0x34/0x70
[  560.865040]  ? __switch_to_asm+0x40/0x70
[  560.865041]  ? __switch_to_asm+0x34/0x70
[  560.865042]  ? __switch_to_asm+0x40/0x70
[  560.865043]  ? __switch_to_asm+0x34/0x70
[  560.865044]  ? __switch_to_asm+0x40/0x70
[  560.865045]  ? __switch_to_asm+0x34/0x70
[  560.865046]  ? __switch_to_asm+0x40/0x70
[  560.865047]  ? trace_hardirqs_off_thunk+0x1a/0x30
[  560.865048]  ? wait_for_completion_timeout+0xf3/0x110
[  560.865049]  ? finish_task_switch+0x7e/0x280
[  560.865053]  ? commit_tail+0x3c/0x70 [drm_kms_helper]
[  560.865056]  commit_tail+0x3c/0x70 [drm_kms_helper]
[  560.865058]  process_one_work+0x1df/0x380
[  560.865059]  worker_thread+0x4d/0x400
[  560.865060]  kthread+0xf9/0x130
[  560.865061]  ? process_one_work+0x380/0x380
[  560.865062]  ? kthread_park+0x80/0x80
[  560.865063]  ret_from_fork+0x27/0x50
[  560.865064] ---[ end trace 1ec4a5fdfcd96673 ]---
[  561.361879] [drm] pstate TEST_DEBUG_DATA: 0x37F60000
[  561.361880] ------------[ cut here ]------------
[  561.361961] WARNING: CPU: 3 PID: 176 at drivers/gpu/drm/amd/amdgpu/../display/dc/dcn10/dcn10_hw_sequencer.c:932 dcn10_verify_allow_pstate_change_high.cold+0xc/0x229 [amdgpu]
[  561.361962] Modules linked in: fuse vhost_net vhost tap tun ebtable_filter ebtables ip6table_filter ip6_tables iptable_filter ip_tables x_tables bpfilter scsi_transport_iscsi af_packet br_netfilter bridge stp llc iscsi_ibft iscsi_boot_sysfs msr nls_iso8859_1 nls_cp437 vfat fat edac_mce_amd kvm_amd ccp kvm irqbypass crct10dif_pclmul crc32_pclmul ghash_clmulni_intel snd_hda_codec_realtek snd_hda_codec_generic snd_hda_codec_hdmi ledtrig_audio snd_hda_intel snd_hda_codec aesni_intel aes_x86_64 crypto_simd cryptd snd_hda_core eeepc_wmi snd_hwdep glue_helper snd_pcm asus_wmi sparse_keymap pcspkr rfkill wmi_bmof sp5100_tco snd_timer r8169 snd k10temp realtek i2c_piix4 soundcore libphy joydev gpio_amdpt gpio_generic acpi_cpufreq button hid_logitech_hidpp btrfs libcrc32c xor uas usb_storage hid_logitech_dj raid6_pq hid_generic usbhid amdgpu amd_iommu_v2 gpu_sched i2c_algo_bit ttm drm_kms_helper syscopyarea sysfillrect sysimgblt fb_sys_fops drm xhci_pci crc32c_intel xhci_hcd usbcore wmi video
[  561.361981]  pinctrl_amd sg dm_multipath dm_mod scsi_dh_rdac scsi_dh_emc scsi_dh_alua efivarfs
[  561.361986] CPU: 3 PID: 176 Comm: kworker/u64:8 Tainted: G        W         5.3.0-rc5-6.gdf791c5-default #1 openSUSE Tumbleweed (unreleased)
[  561.361986] Hardware name: System manufacturer System Product Name/PRIME B450M-A, BIOS 1804 07/29/2019
[  561.361992] Workqueue: events_unbound commit_work [drm_kms_helper]
[  561.362042] RIP: 0010:dcn10_verify_allow_pstate_change_high.cold+0xc/0x229 [amdgpu]
[  561.362043] Code: 83 c8 ff e9 58 3d f8 ff 48 c7 c7 58 6b 7c c0 e8 99 5a ff c5 0f 0b 83 c8 ff e9 42 3d f8 ff 48 c7 c7 58 6b 7c c0 e8 83 5a ff c5 <0f> 0b 80 bb 9f 01 00 00 00 75 05 e9 d6 63 f8 ff 48 8b 83 f8 02 00
[  561.362044] RSP: 0018:ffffa5698045fa18 EFLAGS: 00010286
[  561.362045] RAX: 0000000000000024 RBX: ffff88c961920000 RCX: 0000000000000006
[  561.362046] RDX: 0000000000000007 RSI: 0000000000000092 RDI: ffff88c96ead9a10
[  561.362046] RBP: ffff88c961920000 R08: 0000000000000596 R09: 0000000000000001
[  561.362046] R10: 0000000000000000 R11: 0000000000000001 R12: ffff88c6e08901b8
[  561.362047] R13: ffff88c947c4d000 R14: ffff88c6e08913f8 R15: 0000000000000004
[  561.362048] FS:  0000000000000000(0000) GS:ffff88c96eac0000(0000) knlGS:0000000000000000
[  561.362048] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[  561.362049] CR2: 00007face200d000 CR3: 000000063fe82000 CR4: 00000000003406e0
[  561.362049] Call Trace:
[  561.362100]  dcn10_pipe_control_lock.part.0+0x69/0x70 [amdgpu]
[  561.362146]  commit_planes_for_stream+0x5a4/0x860 [amdgpu]
[  561.362191]  dc_commit_updates_for_stream+0x942/0xab0 [amdgpu]
[  561.362237]  amdgpu_dm_commit_planes.constprop.0+0x7d7/0x9a0 [amdgpu]
[  561.362281]  amdgpu_dm_atomic_commit_tail+0x94c/0xfb0 [amdgpu]
[  561.362297]  ? __btrfs_drop_extents+0xb11/0xdc0 [btrfs]
[  561.362300]  ? __switch_to_asm+0x40/0x70
[  561.362301]  ? __switch_to_asm+0x34/0x70
[  561.362302]  ? __switch_to_asm+0x40/0x70
[  561.362303]  ? __switch_to_asm+0x34/0x70
[  561.362304]  ? __switch_to_asm+0x40/0x70
[  561.362305]  ? __switch_to_asm+0x34/0x70
[  561.362306]  ? __switch_to_asm+0x40/0x70
[  561.362306]  ? __switch_to_asm+0x34/0x70
[  561.362307]  ? __switch_to_asm+0x40/0x70
[  561.362308]  ? __switch_to_asm+0x34/0x70
[  561.362309]  ? __switch_to_asm+0x40/0x70
[  561.362310]  ? __switch_to_asm+0x34/0x70
[  561.362311]  ? __switch_to_asm+0x40/0x70
[  561.362311]  ? __switch_to_asm+0x34/0x70
[  561.362312]  ? __switch_to_asm+0x40/0x70
[  561.362315]  ? trace_hardirqs_off_thunk+0x1a/0x30
[  561.362316]  ? wait_for_completion_timeout+0xf3/0x110
[  561.362318]  ? finish_task_switch+0x7e/0x280
[  561.362322]  ? commit_tail+0x3c/0x70 [drm_kms_helper]
[  561.362326]  commit_tail+0x3c/0x70 [drm_kms_helper]
[  561.362328]  process_one_work+0x1df/0x380
[  561.362330]  worker_thread+0x4d/0x400
[  561.362331]  kthread+0xf9/0x130
[  561.362332]  ? process_one_work+0x380/0x380
[  561.362333]  ? kthread_park+0x80/0x80
[  561.362334]  ret_from_fork+0x27/0x50
[  561.362336] ---[ end trace 1ec4a5fdfcd96674 ]---
[  561.362916] [drm] pstate TEST_DEBUG_DATA: 0x37F60000
[  561.362916] ------------[ cut here ]------------
[  561.362984] WARNING: CPU: 3 PID: 176 at drivers/gpu/drm/amd/amdgpu/../display/dc/dcn10/dcn10_hw_sequencer.c:932 dcn10_verify_allow_pstate_change_high.cold+0xc/0x229 [amdgpu]
[  561.362984] Modules linked in: fuse vhost_net vhost tap tun ebtable_filter ebtables ip6table_filter ip6_tables iptable_filter ip_tables x_tables bpfilter scsi_transport_iscsi af_packet br_netfilter bridge stp llc iscsi_ibft iscsi_boot_sysfs msr nls_iso8859_1 nls_cp437 vfat fat edac_mce_amd kvm_amd ccp kvm irqbypass crct10dif_pclmul crc32_pclmul ghash_clmulni_intel snd_hda_codec_realtek snd_hda_codec_generic snd_hda_codec_hdmi ledtrig_audio snd_hda_intel snd_hda_codec aesni_intel aes_x86_64 crypto_simd cryptd snd_hda_core eeepc_wmi snd_hwdep glue_helper snd_pcm asus_wmi sparse_keymap pcspkr rfkill wmi_bmof sp5100_tco snd_timer r8169 snd k10temp realtek i2c_piix4 soundcore libphy joydev gpio_amdpt gpio_generic acpi_cpufreq button hid_logitech_hidpp btrfs libcrc32c xor uas usb_storage hid_logitech_dj raid6_pq hid_generic usbhid amdgpu amd_iommu_v2 gpu_sched i2c_algo_bit ttm drm_kms_helper syscopyarea sysfillrect sysimgblt fb_sys_fops drm xhci_pci crc32c_intel xhci_hcd usbcore wmi video
[  561.363002]  pinctrl_amd sg dm_multipath dm_mod scsi_dh_rdac scsi_dh_emc scsi_dh_alua efivarfs
[  561.363006] CPU: 3 PID: 176 Comm: kworker/u64:8 Tainted: G        W         5.3.0-rc5-6.gdf791c5-default #1 openSUSE Tumbleweed (unreleased)
[  561.363006] Hardware name: System manufacturer System Product Name/PRIME B450M-A, BIOS 1804 07/29/2019
[  561.363011] Workqueue: events_unbound commit_work [drm_kms_helper]
[  561.363059] RIP: 0010:dcn10_verify_allow_pstate_change_high.cold+0xc/0x229 [amdgpu]
[  561.363060] Code: 83 c8 ff e9 58 3d f8 ff 48 c7 c7 58 6b 7c c0 e8 99 5a ff c5 0f 0b 83 c8 ff e9 42 3d f8 ff 48 c7 c7 58 6b 7c c0 e8 83 5a ff c5 <0f> 0b 80 bb 9f 01 00 00 00 75 05 e9 d6 63 f8 ff 48 8b 83 f8 02 00
[  561.363061] RSP: 0018:ffffa5698045fa38 EFLAGS: 00010282
[  561.363062] RAX: 0000000000000024 RBX: ffff88c961920000 RCX: 0000000000000006
[  561.363062] RDX: 0000000000000007 RSI: 0000000000000096 RDI: ffff88c96ead9a10
[  561.363063] RBP: ffff88c961920000 R08: 00000000000005cb R09: 0000000000000001
[  561.363063] R10: 0000000000000000 R11: 0000000000000001 R12: ffff88c6e0890000
[  561.363063] R13: ffff88c947c4d000 R14: ffff88c6e08913f8 R15: 0000000000000004
[  561.363064] FS:  0000000000000000(0000) GS:ffff88c96eac0000(0000) knlGS:0000000000000000
[  561.363065] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[  561.363065] CR2: 00007face200d000 CR3: 000000063fe82000 CR4: 00000000003406e0
[  561.363065] Call Trace:
[  561.363110]  commit_planes_for_stream+0x5a4/0x860 [amdgpu]
[  561.363154]  dc_commit_updates_for_stream+0x942/0xab0 [amdgpu]
[  561.363198]  amdgpu_dm_commit_planes.constprop.0+0x7d7/0x9a0 [amdgpu]
[  561.363242]  amdgpu_dm_atomic_commit_tail+0x94c/0xfb0 [amdgpu]
[  561.363257]  ? __btrfs_drop_extents+0xb11/0xdc0 [btrfs]
[  561.363259]  ? __switch_to_asm+0x40/0x70
[  561.363260]  ? __switch_to_asm+0x34/0x70
[  561.363261]  ? __switch_to_asm+0x40/0x70
[  561.363262]  ? __switch_to_asm+0x34/0x70
[  561.363263]  ? __switch_to_asm+0x40/0x70
[  561.363263]  ? __switch_to_asm+0x34/0x70
[  561.363264]  ? __switch_to_asm+0x40/0x70
[  561.363265]  ? __switch_to_asm+0x34/0x70
[  561.363266]  ? __switch_to_asm+0x40/0x70
[  561.363267]  ? __switch_to_asm+0x34/0x70
[  561.363268]  ? __switch_to_asm+0x40/0x70
[  561.363268]  ? __switch_to_asm+0x34/0x70
[  561.363269]  ? __switch_to_asm+0x40/0x70
[  561.363270]  ? __switch_to_asm+0x34/0x70
[  561.363271]  ? __switch_to_asm+0x40/0x70
[  561.363273]  ? trace_hardirqs_off_thunk+0x1a/0x30
[  561.363274]  ? wait_for_completion_timeout+0xf3/0x110
[  561.363275]  ? finish_task_switch+0x7e/0x280
[  561.363280]  ? commit_tail+0x3c/0x70 [drm_kms_helper]
[  561.363283]  commit_tail+0x3c/0x70 [drm_kms_helper]
[  561.363285]  process_one_work+0x1df/0x380
[  561.363287]  worker_thread+0x4d/0x400
[  561.363288]  kthread+0xf9/0x130
[  561.363289]  ? process_one_work+0x380/0x380
[  561.363290]  ? kthread_park+0x80/0x80
[  561.363291]  ret_from_fork+0x27/0x50
[  561.363292] ---[ end trace 1ec4a5fdfcd96675 ]---
[  561.363887] [drm] pstate TEST_DEBUG_DATA: 0x37F60000
[  561.363887] ------------[ cut here ]------------
[  561.363954] WARNING: CPU: 3 PID: 176 at drivers/gpu/drm/amd/amdgpu/../display/dc/dcn10/dcn10_hw_sequencer.c:932 dcn10_verify_allow_pstate_change_high.cold+0xc/0x229 [amdgpu]
[  561.363954] Modules linked in: fuse vhost_net vhost tap tun ebtable_filter ebtables ip6table_filter ip6_tables iptable_filter ip_tables x_tables bpfilter scsi_transport_iscsi af_packet br_netfilter bridge stp llc iscsi_ibft iscsi_boot_sysfs msr nls_iso8859_1 nls_cp437 vfat fat edac_mce_amd kvm_amd ccp kvm irqbypass crct10dif_pclmul crc32_pclmul ghash_clmulni_intel snd_hda_codec_realtek snd_hda_codec_generic snd_hda_codec_hdmi ledtrig_audio snd_hda_intel snd_hda_codec aesni_intel aes_x86_64 crypto_simd cryptd snd_hda_core eeepc_wmi snd_hwdep glue_helper snd_pcm asus_wmi sparse_keymap pcspkr rfkill wmi_bmof sp5100_tco snd_timer r8169 snd k10temp realtek i2c_piix4 soundcore libphy joydev gpio_amdpt gpio_generic acpi_cpufreq button hid_logitech_hidpp btrfs libcrc32c xor uas usb_storage hid_logitech_dj raid6_pq hid_generic usbhid amdgpu amd_iommu_v2 gpu_sched i2c_algo_bit ttm drm_kms_helper syscopyarea sysfillrect sysimgblt fb_sys_fops drm xhci_pci crc32c_intel xhci_hcd usbcore wmi video
[  561.363972]  pinctrl_amd sg dm_multipath dm_mod scsi_dh_rdac scsi_dh_emc scsi_dh_alua efivarfs
[  561.363976] CPU: 3 PID: 176 Comm: kworker/u64:8 Tainted: G        W         5.3.0-rc5-6.gdf791c5-default #1 openSUSE Tumbleweed (unreleased)
[  561.363976] Hardware name: System manufacturer System Product Name/PRIME B450M-A, BIOS 1804 07/29/2019
[  561.363981] Workqueue: events_unbound commit_work [drm_kms_helper]
[  561.364029] RIP: 0010:dcn10_verify_allow_pstate_change_high.cold+0xc/0x229 [amdgpu]
[  561.364030] Code: 83 c8 ff e9 58 3d f8 ff 48 c7 c7 58 6b 7c c0 e8 99 5a ff c5 0f 0b 83 c8 ff e9 42 3d f8 ff 48 c7 c7 58 6b 7c c0 e8 83 5a ff c5 <0f> 0b 80 bb 9f 01 00 00 00 75 05 e9 d6 63 f8 ff 48 8b 83 f8 02 00
[  561.364030] RSP: 0018:ffffa5698045fa18 EFLAGS: 00010286
[  561.364031] RAX: 0000000000000024 RBX: ffff88c961920000 RCX: 0000000000000006
[  561.364031] RDX: 0000000000000007 RSI: 0000000000000092 RDI: ffff88c96ead9a10
[  561.364032] RBP: ffff88c961920000 R08: 00000000000005ff R09: 0000000000000001
[  561.364032] R10: 0000000000000000 R11: 0000000000000001 R12: ffff88c6e08901b8
[  561.364033] R13: ffff88c947c4d000 R14: 0000000000000004 R15: ffff88c940c3f800
[  561.364033] FS:  0000000000000000(0000) GS:ffff88c96eac0000(0000) knlGS:0000000000000000
[  561.364034] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[  561.364034] CR2: 00007face200d000 CR3: 000000063fe82000 CR4: 00000000003406e0
[  561.364035] Call Trace:
[  561.364081]  dcn10_pipe_control_lock.part.0+0x69/0x70 [amdgpu]
[  561.364124]  commit_planes_for_stream+0x76c/0x860 [amdgpu]
[  561.364168]  dc_commit_updates_for_stream+0x942/0xab0 [amdgpu]
[  561.364211]  amdgpu_dm_commit_planes.constprop.0+0x7d7/0x9a0 [amdgpu]
[  561.364254]  amdgpu_dm_atomic_commit_tail+0x94c/0xfb0 [amdgpu]
[  561.364268]  ? __btrfs_drop_extents+0xb11/0xdc0 [btrfs]
[  561.364270]  ? __switch_to_asm+0x40/0x70
[  561.364271]  ? __switch_to_asm+0x34/0x70
[  561.364272]  ? __switch_to_asm+0x40/0x70
[  561.364273]  ? __switch_to_asm+0x34/0x70
[  561.364274]  ? __switch_to_asm+0x40/0x70
[  561.364274]  ? __switch_to_asm+0x34/0x70
[  561.364275]  ? __switch_to_asm+0x40/0x70
[  561.364276]  ? __switch_to_asm+0x34/0x70
[  561.364277]  ? __switch_to_asm+0x40/0x70
[  561.364278]  ? __switch_to_asm+0x34/0x70
[  561.364279]  ? __switch_to_asm+0x40/0x70
[  561.364280]  ? __switch_to_asm+0x34/0x70
[  561.364280]  ? __switch_to_asm+0x40/0x70
[  561.364281]  ? __switch_to_asm+0x34/0x70
[  561.364282]  ? __switch_to_asm+0x40/0x70
[  561.364284]  ? trace_hardirqs_off_thunk+0x1a/0x30
[  561.364285]  ? wait_for_completion_timeout+0xf3/0x110
[  561.364286]  ? finish_task_switch+0x7e/0x280
[  561.364290]  ? commit_tail+0x3c/0x70 [drm_kms_helper]
[  561.364294]  commit_tail+0x3c/0x70 [drm_kms_helper]
[  561.364296]  process_one_work+0x1df/0x380
[  561.364297]  worker_thread+0x4d/0x400
[  561.364298]  kthread+0xf9/0x130
[  561.364299]  ? process_one_work+0x380/0x380
[  561.364299]  ? kthread_park+0x80/0x80
[  561.364300]  ret_from_fork+0x27/0x50
[  561.364301] ---[ end trace 1ec4a5fdfcd96676 ]---
[  561.364875] [drm] pstate TEST_DEBUG_DATA: 0x37F60000
[  561.364875] ------------[ cut here ]------------
[  561.364938] WARNING: CPU: 3 PID: 176 at drivers/gpu/drm/amd/amdgpu/../display/dc/dcn10/dcn10_hw_sequencer.c:932 dcn10_verify_allow_pstate_change_high.cold+0xc/0x229 [amdgpu]
[  561.364938] Modules linked in: fuse vhost_net vhost tap tun ebtable_filter ebtables ip6table_filter ip6_tables iptable_filter ip_tables x_tables bpfilter scsi_transport_iscsi af_packet br_netfilter bridge stp llc iscsi_ibft iscsi_boot_sysfs msr nls_iso8859_1 nls_cp437 vfat fat edac_mce_amd kvm_amd ccp kvm irqbypass crct10dif_pclmul crc32_pclmul ghash_clmulni_intel snd_hda_codec_realtek snd_hda_codec_generic snd_hda_codec_hdmi ledtrig_audio snd_hda_intel snd_hda_codec aesni_intel aes_x86_64 crypto_simd cryptd snd_hda_core eeepc_wmi snd_hwdep glue_helper snd_pcm asus_wmi sparse_keymap pcspkr rfkill wmi_bmof sp5100_tco snd_timer r8169 snd k10temp realtek i2c_piix4 soundcore libphy joydev gpio_amdpt gpio_generic acpi_cpufreq button hid_logitech_hidpp btrfs libcrc32c xor uas usb_storage hid_logitech_dj raid6_pq hid_generic usbhid amdgpu amd_iommu_v2 gpu_sched i2c_algo_bit ttm drm_kms_helper syscopyarea sysfillrect sysimgblt fb_sys_fops drm xhci_pci crc32c_intel xhci_hcd usbcore wmi video
[  561.364955]  pinctrl_amd sg dm_multipath dm_mod scsi_dh_rdac scsi_dh_emc scsi_dh_alua efivarfs
[  561.364958] CPU: 3 PID: 176 Comm: kworker/u64:8 Tainted: G        W         5.3.0-rc5-6.gdf791c5-default #1 openSUSE Tumbleweed (unreleased)
[  561.364959] Hardware name: System manufacturer System Product Name/PRIME B450M-A, BIOS 1804 07/29/2019
[  561.364963] Workqueue: events_unbound commit_work [drm_kms_helper]
[  561.365010] RIP: 0010:dcn10_verify_allow_pstate_change_high.cold+0xc/0x229 [amdgpu]
[  561.365011] Code: 83 c8 ff e9 58 3d f8 ff 48 c7 c7 58 6b 7c c0 e8 99 5a ff c5 0f 0b 83 c8 ff e9 42 3d f8 ff 48 c7 c7 58 6b 7c c0 e8 83 5a ff c5 <0f> 0b 80 bb 9f 01 00 00 00 75 05 e9 d6 63 f8 ff 48 8b 83 f8 02 00
[  561.365012] RSP: 0018:ffffa5698045fa38 EFLAGS: 00010282
[  561.365012] RAX: 0000000000000024 RBX: ffff88c961920000 RCX: 0000000000000006
[  561.365013] RDX: 0000000000000007 RSI: 0000000000000096 RDI: ffff88c96ead9a10
[  561.365013] RBP: ffff88c961920000 R08: 0000000000000634 R09: 0000000000000001
[  561.365014] R10: 0000000000000000 R11: 0000000000000001 R12: ffff88c6e0890000
[  561.365014] R13: ffff88c947c4d000 R14: 0000000000000004 R15: ffff88c940c3f800
[  561.365015] FS:  0000000000000000(0000) GS:ffff88c96eac0000(0000) knlGS:0000000000000000
[  561.365015] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[  561.365016] CR2: 00007face200d000 CR3: 000000063fe82000 CR4: 00000000003406e0
[  561.365016] Call Trace:
[  561.365060]  commit_planes_for_stream+0x76c/0x860 [amdgpu]
[  561.365103]  dc_commit_updates_for_stream+0x942/0xab0 [amdgpu]
[  561.365147]  amdgpu_dm_commit_planes.constprop.0+0x7d7/0x9a0 [amdgpu]
[  561.365190]  amdgpu_dm_atomic_commit_tail+0x94c/0xfb0 [amdgpu]
[  561.365204]  ? __btrfs_drop_extents+0xb11/0xdc0 [btrfs]
[  561.365206]  ? __switch_to_asm+0x40/0x70
[  561.365207]  ? __switch_to_asm+0x34/0x70
[  561.365208]  ? __switch_to_asm+0x40/0x70
[  561.365208]  ? __switch_to_asm+0x34/0x70
[  561.365209]  ? __switch_to_asm+0x40/0x70
[  561.365210]  ? __switch_to_asm+0x34/0x70
[  561.365211]  ? __switch_to_asm+0x40/0x70
[  561.365212]  ? __switch_to_asm+0x34/0x70
[  561.365213]  ? __switch_to_asm+0x40/0x70
[  561.365214]  ? __switch_to_asm+0x34/0x70
[  561.365214]  ? __switch_to_asm+0x40/0x70
[  561.365215]  ? __switch_to_asm+0x34/0x70
[  561.365216]  ? __switch_to_asm+0x40/0x70
[  561.365217]  ? __switch_to_asm+0x34/0x70
[  561.365218]  ? __switch_to_asm+0x40/0x70
[  561.365219]  ? trace_hardirqs_off_thunk+0x1a/0x30
[  561.365220]  ? wait_for_completion_timeout+0xf3/0x110
[  561.365222]  ? finish_task_switch+0x7e/0x280
[  561.365226]  ? commit_tail+0x3c/0x70 [drm_kms_helper]
[  561.365230]  commit_tail+0x3c/0x70 [drm_kms_helper]
[  561.365232]  process_one_work+0x1df/0x380
[  561.365233]  worker_thread+0x4d/0x400
[  561.365234]  kthread+0xf9/0x130
[  561.365235]  ? process_one_work+0x380/0x380
[  561.365236]  ? kthread_park+0x80/0x80
[  561.365237]  ret_from_fork+0x27/0x50
[  561.365238] ---[ end trace 1ec4a5fdfcd96677 ]---
Comment 7 bzz bee 2019-08-26 09:46:25 UTC
let me rephrase it here again:

on kernel: Linux suse 5.3.0-rc5-6.gdf791c5-default #1 SMP Fri Aug 23 07:47:04 UTC 2019 (df791c5) x86_64 x86_64 x86_64 GNU/Linux

graphics flickering is still there (always after fresh boot)

the dmesg warning appear after turing off and on the display.
Comment 8 Takashi Iwai 2019-08-26 09:50:56 UTC
Thanks for quick testing!

So it's worth for reporting this to upstream.
Care to open an upstream bugzilla entry, bugs.freedesktop.org?  Use category DRI/AMDGPU.  Feel free to put me (tiwai@suse.de) in Cc there.
Comment 10 Takashi Iwai 2019-08-26 13:32:40 UTC
And, I'm still a bit confused: is flickering gone if you boot with an older 5.2.x kernel while keeping the rest updated (including the recent xfce updates)?
If you can figure out that it's a really kernel regression, narrowing the regression range would help a lot.
Comment 11 bzz bee 2019-08-26 18:03:03 UTC
@ Takashi Iwai: unfortunately i have no idea how to test that. 
I didn't had so many rollback setup before, so i lost even option to rollback to the older working state, freeze kernel and upgrade the rest. 

Anyway. Seems that there are 2 issues.
On is flickering of graphic elements and 2nd is, when i connect external display using HDMI and turn it off and then back on

1) if the connected external display is HDMI -> HDMI then i got always "green solid screen"
2) if the connected external display was for example HDMI -> DVI-D, then no issues appear (even in dmesg)
Comment 12 bzz bee 2019-08-26 20:37:59 UTC
ok, i have some update.
Even with older monitor, when there is some "blank" or "power-safe mode" involved, the display/xorg/anything graphical just blows up and never go back working until full reboot. 

when i put to grub boot cmd "nomodeset" then i boot to only 1024x768, but there is not graphics flickering and no issue when i turn off/on display (any of displays).
Comment 13 Jiri Slaby 2019-11-04 12:25:47 UTC
(In reply to bzz bee from comment #9)
> https://bugs.freedesktop.org/show_bug.cgi?id=111487

Closing as upstream is to blame here. Another report is here:
https://bugs.freedesktop.org/show_bug.cgi?id=109628

Discussion happens there. If there any patches and you feel we should take them earlier than they get upstream, feel free to reopen.