Bug 1147032 - kernel trace: WARNING: CPU: 7 PID: 0 at net/sched/sch_generic.c:442 dev_watchdog+0x248/0x250
kernel trace: WARNING: CPU: 7 PID: 0 at net/sched/sch_generic.c:442 dev_watch...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
x86-64 Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-08-23 09:28 UTC by Dan Čermák
Modified: 2019-09-02 13:59 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
kernel trace from journald (6.33 KB, text/x-log)
2019-08-23 09:28 UTC, Dan Čermák
Details
kernel log from journalctl (13.67 KB, text/x-log)
2019-08-26 11:26 UTC, Dan Čermák
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dan Čermák 2019-08-23 09:28:36 UTC
Created attachment 815409 [details]
kernel trace from journald

I've found the attached kernel trace after rebooting today with the newest Tumbleweed snapshot.

$ uname -a
Linux Boreas 5.2.8-1-default #1 SMP Fri Aug 9 17:51:51 UTC 2019 (bf37e83) x86_64 x86_64 x86_64 GNU/Linux

$ lpci
00:00.0 Host bridge: Intel Corporation 8th Gen Core Processor Host Bridge/DRAM Registers (rev 07)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor PCIe Controller (x16) (rev 07)
00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 630 (Mobile)
00:04.0 Signal processing controller: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem (rev 07)
00:08.0 System peripheral: Intel Corporation Xeon E3-1200 v5/v6 / E3-1500 v5 / 6th/7th Gen Core Processor Gaussian Mixture Model
00:12.0 Signal processing controller: Intel Corporation Cannon Lake PCH Thermal Controller (rev 10)
00:14.0 USB controller: Intel Corporation Cannon Lake PCH USB 3.1 xHCI Host Controller (rev 10)
00:14.2 RAM memory: Intel Corporation Cannon Lake PCH Shared SRAM (rev 10)
00:15.0 Serial bus controller [0c80]: Intel Corporation Cannon Lake PCH Serial IO I2C Controller #0 (rev 10)
00:15.1 Serial bus controller [0c80]: Intel Corporation Cannon Lake PCH Serial IO I2C Controller #1 (rev 10)
00:16.0 Communication controller: Intel Corporation Cannon Lake PCH HECI Controller (rev 10)
00:17.0 SATA controller: Intel Corporation Cannon Lake Mobile PCH SATA AHCI Controller (rev 10)
00:1b.0 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port #17 (rev f0)
00:1c.0 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port #1 (rev f0)
00:1c.4 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port #5 (rev f0)
00:1d.0 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port #9 (rev f0)
00:1f.0 ISA bridge: Intel Corporation Device a30e (rev 10)
00:1f.3 Audio device: Intel Corporation Cannon Lake PCH cAVS (rev 10)
00:1f.4 SMBus: Intel Corporation Cannon Lake PCH SMBus Controller (rev 10)
00:1f.5 Serial bus controller [0c80]: Intel Corporation Cannon Lake PCH SPI Controller (rev 10)
01:00.0 3D controller: NVIDIA Corporation GP107GLM [Quadro P1000 Mobile] (rev ff)
02:00.0 PCI bridge: Intel Corporation JHL6340 Thunderbolt 3 Bridge (C step) [Alpine Ridge 2C 2016] (rev 02)
03:00.0 PCI bridge: Intel Corporation JHL6340 Thunderbolt 3 Bridge (C step) [Alpine Ridge 2C 2016] (rev 02)
03:01.0 PCI bridge: Intel Corporation JHL6340 Thunderbolt 3 Bridge (C step) [Alpine Ridge 2C 2016] (rev 02)
03:02.0 PCI bridge: Intel Corporation JHL6340 Thunderbolt 3 Bridge (C step) [Alpine Ridge 2C 2016] (rev 02)
3a:00.0 USB controller: Intel Corporation JHL6340 Thunderbolt 3 USB 3.1 Controller (C step) [Alpine Ridge 2C 2016] (rev 02)
3b:00.0 Network controller: Intel Corporation Wireless-AC 9260 (rev 29)
3c:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS525A PCI Express Card Reader (rev 01)
3d:00.0 Non-Volatile memory controller: SK hynix Device 1527


Hardware: Dell Precision 5530
Comment 1 Takashi Iwai 2019-08-26 08:47:51 UTC
Is this a regression?  i.e. if you reboot with the old kernel, doesn't it happen?
Also it's reproducible?
Comment 2 Dan Čermák 2019-08-26 11:25:30 UTC
Unfortunately yesterday's update already remove the older kernel, so I can no longer test that one. The new kernel (5.2.9) on the other hand completely killed wifi on my laptop (see the attached log file).
Comment 3 Dan Čermák 2019-08-26 11:26:22 UTC
Created attachment 815707 [details]
kernel log from journalctl
Comment 4 Takashi Iwai 2019-08-26 12:08:03 UTC
Please try to install kernel-firmware.rpm from OBS Kernel:HEAD repo.
Comment 5 Dan Čermák 2019-08-27 07:56:17 UTC
I've installed 5.3.0-rc6-1.g2831011-default and kernel-firmware-20190815-277.1.noarch from Kernel:Head and WiFi works now.
Comment 6 Takashi Iwai 2019-08-27 08:31:49 UTC
OK, then try the kernel in OBS Kernel:stable (5.2.10), too.  This should work as well with the latest kernel-firmware package.  The current TW kernel (5.2.9) seems problematic with the latest kernel-firmware, though.
Comment 7 Denis Kirjanov 2019-08-29 12:16:13 UTC
Hm, could you please check the driver from the Realtek website?
https://www.realtek.com/en/component/zoo/category/network-interface-controllers-10-100-1000m-gigabit-ethernet-usb-3-0-software
Comment 8 Denis Kirjanov 2019-08-29 12:17:00 UTC
In my understanding you're using a Dell docking station, right?
Comment 9 Dan Čermák 2019-09-02 07:26:17 UTC
(In reply to Takashi Iwai from comment #6)
> OK, then try the kernel in OBS Kernel:stable (5.2.10), too.  This should
> work as well with the latest kernel-firmware package.  The current TW kernel
> (5.2.9) seems problematic with the latest kernel-firmware, though.

kernel-firmware-20190827-279.1.noarch and kernel 5.2.10 work too.
Comment 10 Dan Čermák 2019-09-02 07:26:48 UTC
(In reply to Denis Kirjanov from comment #8)
> In my understanding you're using a Dell docking station, right?

That is correct, but the issue appeared also without it.
Comment 11 Takashi Iwai 2019-09-02 13:11:24 UTC
And since the update to 5.2.10 + the latest kernel-firmware, is the original issue (the kernel warning from the watchdog) gone?  I understand that WiFi issue was resolved, but not sure whether that is the cause.
Comment 12 Dan Čermák 2019-09-02 13:57:40 UTC
(In reply to Takashi Iwai from comment #11)
> And since the update to 5.2.10 + the latest kernel-firmware, is the original
> issue (the kernel warning from the watchdog) gone?  I understand that WiFi
> issue was resolved, but not sure whether that is the cause.

Haven't seen it so far, but I have rebooted only once since the kernel change.
Comment 13 Takashi Iwai 2019-09-02 13:59:11 UTC
OK, then let's assume that it's been already addressed.
Feel free to reopen if you still see the very same problem.  Thanks.