Bug 1146862 - Wacom multitouch screens should not use the xf86-input-wacom driver for touch support
Wacom multitouch screens should not use the xf86-input-wacom driver for touch...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: X.Org
Current
All openSUSE Factory
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-08-22 12:40 UTC by Leinir Turthra
Modified: 2020-01-09 15:31 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Leinir Turthra 2019-08-22 12:40:35 UTC
As explored in some depth in this ubuntu bug[1], the linuxwacom driver for touch does not work amazingly well for devices which have a (true) multi-touch touch screen. In short, for such devices, X should fall back to using the libinput/evdev driver, which functions as expected.

The upstream bug tracking the issue is https://github.com/linuxwacom/xf86-input-wacom/issues/44

[1] https://bugs.launchpad.net/ubuntu/+source/xf86-input-wacom/+bug/1774242
Comment 1 Stefan Dirsch 2019-08-22 15:03:11 UTC
This should already be fixed in xf86-input-wacom 0.37, which I've updated to this tuesday ...
Comment 2 Leinir Turthra 2020-01-09 15:31:23 UTC
More work has been done on this elsewhere, and it seems as though what wants doing to make things work right is not quite to turn off the touch section entirely, but rather to turn off Wacom's gesture support (this can also be done at runtime through for example `xsetwacom --set "Wacom Pen and multitouch sensor Finger touch" Gesture Off`). The ubuntu bug entry has this suggested as the solution, and given how non-invasive it is, that seems like a fairly reasonable option to add (if it's truly desired by some user, it can then be turned on at runtime, without affecting the general touch friendliness of the system). I'm not changing the state, but only wish to mention that the issue is still occurring with current tumbleweed.