Bug 1146802 - kubic image does not call cloud-init
kubic image does not call cloud-init
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kubic
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Kubic Bugs
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-08-22 09:48 UTC by Alin M Elena
Modified: 2020-01-19 08:21 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
fvogt: needinfo? (alinm.elena)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alin M Elena 2019-08-22 09:48:21 UTC
I have created an instance on a private openstack using the Kubic image, 
openSUSE-MicroOS.x86_64-16.0.0-Kubic-kubeadm-OpenStack-Cloud-Snapshot20190810.qcow2
However I have found that cloud-init.service is not executed when it runs.

this was strange since jeos leap15.1 worked just fine following the same procedure.

looking into the logs with the help of @fvogl in #kuibic
turned out the issue is missing configdrive from data sources.

log on kubic: /run/cloud-init/ds-identify.log
[up 8.92s] ds-identify 
policy loaded: mode=search report=false found=all maybe=all notfound=disabled
/etc/cloud/cloud.cfg set datasource_list: [ LocalDisk, NoCloud, OpenStack, None ]
DMI_PRODUCT_NAME=OpenStack Compute
DMI_SYS_VENDOR=RDO
DMI_PRODUCT_SERIAL=
DMI_PRODUCT_UUID=
PID_1_PRODUCT_NAME=unavailable
DMI_CHASSIS_ASSET_TAG=
FS_LABELS=EFI,ROOT,config-2
ISO9660_DEVS=/dev/sr0=config-2
KERNEL_CMDLINE=BOOT_IMAGE=(hd0,gpt3)/boot/vmlinuz-5.2.7-1-default plymouth.enable=0 console=ttyS0,115200 console=tty0 net.ifnames=0 swapaccount=1 root=UUID=8d179643-1ce8-4c8c-be48-86957b41df7b rw
VIRT=kvm
UNAME_KERNEL_NAME=Linux
UNAME_KERNEL_RELEASE=5.2.7-1-default
UNAME_KERNEL_VERSION=#1 SMP Wed Aug 7 05:13:31 UTC 2019 (a3e04b1)
UNAME_MACHINE=x86_64
UNAME_NODENAME=localhost
UNAME_OPERATING_SYSTEM=GNU/Linux
DSNAME=
DSLIST=LocalDisk NoCloud OpenStack None
MODE=search
ON_FOUND=all
ON_MAYBE=all
ON_NOTFOUND=disabled
pid=646 ppid=625
is_container=false
WARN: No check method 'dscheck_LocalDisk' for datasource 'LocalDisk'
is_ds_enabled(IBMCloud) = false.
No ds found [mode=search, notfound=disabled]. Disabled cloud-init [1]
[up 9.31s] returning 1

on working leap:
[up 15.38s] ds-identify 
policy loaded: mode=search report=false found=all maybe=all notfound=disabled
no datasource_list found, using default: MAAS ConfigDrive NoCloud AltCloud Azure Bigstep CloudSigma CloudStack DigitalOcean AliYun Ec2 GCE OpenNebula OpenStack OVF SmartOS Scaleway Hetzner IBMCloud Oracle
DMI_PRODUCT_NAME=OpenStack Compute
DMI_SYS_VENDOR=RDO
DMI_PRODUCT_SERIAL=
DMI_PRODUCT_UUID=
PID_1_PRODUCT_NAME=unavailable
DMI_CHASSIS_ASSET_TAG=
FS_LABELS=EFI,ROOT,config-2
ISO9660_DEVS=/dev/sr0=config-2
KERNEL_CMDLINE=BOOT_IMAGE=(hd0,gpt3)/boot/vmlinuz-4.12.14-lp151.28.10-default plymouth.enable=0 console=ttyS0,115200 console=tty0 net.ifnames=0 quiet root=UUID=16adb09b-ef97-49d4-ab39-ad734992541c rw
VIRT=kvm
UNAME_KERNEL_NAME=Linux
UNAME_KERNEL_RELEASE=4.12.14-lp151.28.10-default
UNAME_KERNEL_VERSION=#1 SMP Sat Jul 13 17:59:31 UTC 2019 (0ab03b7)
UNAME_MACHINE=x86_64
UNAME_NODENAME=localhost
UNAME_OPERATING_SYSTEM=GNU/Linux
DSNAME=
DSLIST=MAAS ConfigDrive NoCloud AltCloud Azure Bigstep CloudSigma CloudStack DigitalOcean AliYun Ec2 GCE OpenNebula OpenStack OVF SmartOS Scaleway Hetzner IBMCloud Oracle
MODE=search
ON_FOUND=all
ON_MAYBE=all
ON_NOTFOUND=disabled
pid=328 ppid=313
is_container=false
is_ds_enabled(IBMCloud) = true.
check for 'ConfigDrive' returned found
ec2 platform is 'Unknown'.
is_ds_enabled(IBMCloud) = true.
got label=config-2
Found single datasource: ConfigDrive
[up 15.81s] returning 0

==============

on kubic, commenting in /etc/cloud/cloud.cfg the datasources line solves the issue
Comment 1 Fabian Vogt 2019-08-22 09:58:36 UTC
Most likely caused by datasource_list in cloud-init-config-{caasp,MicroOS}, reassigning.

Would it hurt to remove that line in the packages?
If yes, I'd need to drop it in the images only.
Comment 2 Thorsten Kukuk 2019-08-22 10:03:56 UTC
(In reply to Fabian Vogt from comment #1)
> Most likely caused by datasource_list in cloud-init-config-{caasp,MicroOS},
> reassigning.
> 
> Would it hurt to remove that line in the packages?
> If yes, I'd need to drop it in the images only.

I added that line because it was necesssary at that point in time.
No idea how this is today. I don't care much, as we don't want to use cloud-init anymore for bare metal and KVM/XEN.
Comment 3 Fabian Vogt 2019-08-22 11:56:07 UTC
(In reply to Thorsten Kukuk from comment #2)
> (In reply to Fabian Vogt from comment #1)
> > Most likely caused by datasource_list in cloud-init-config-{caasp,MicroOS},
> > reassigning.
> > 
> > Would it hurt to remove that line in the packages?
> > If yes, I'd need to drop it in the images only.
> 
> I added that line because it was necesssary at that point in time.
> No idea how this is today. I don't care much, as we don't want to use
> cloud-init anymore for bare metal and KVM/XEN.

Ok, I made https://build.opensuse.org/request/show/725277.

Once accepted, images in devel:kubic:images (devel_kubic repo) should build with the changes. Once they're built, please give them a try.
Comment 4 Thorsten Kukuk 2020-01-19 08:21:43 UTC
No answer, assumes it works.