Bug 1146207 - Compile of proprietary NVIDIA driver failed after tumbleweed update
Compile of proprietary NVIDIA driver failed after tumbleweed update
Status: RESOLVED FIXED
: 1146039 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: X11 3rd Party Driver
Current
x86-64 Other
: P5 - None : Minor (vote)
: ---
Assigned To: E-mail List
Stefan Dirsch
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-08-19 14:51 UTC by Philipp Albert
Modified: 2019-08-19 15:15 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp Albert 2019-08-19 14:51:03 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Build Identifier: 

After tumbleweed update to snapshot 20190814, the NVIDIA driver will not compile anymore, when installing it (x11-video-nvidiaG04).

Get the following error message:

nvidia-gfxG04-kmp-default-390.116_k5.1.16_1-10.2.x86_64:

   CC [M]
/usr/src/kernel-modules/nvidia-390.116-default/nvidia-uvm/uvm8_tools.o
 
 

/usr/src/kernel-modules/nvidia-390.116-default/nvidia-uvm/uvm8_tools.c:207:13:
error: conflicting types for ‘put_user_pages’
 

   207 | static void put_user_pages(struct page **pages, NvU64
page_count)
 

       |             ^~~~~~~~~~~~~~
 
 

In file included from
/usr/src/kernel-modules/nvidia-390.116-default/common/inc/nv-pgprot.h:17,
 
 

                  from
/usr/src/kernel-modules/nvidia-390.116-default/common/inc/nv-linux.h:20,
 
 

                  from
/usr/src/kernel-modules/nvidia-390.116-default/nvidia-uvm/uvm_linux.h:41,
 
 

                  from
/usr/src/kernel-modules/nvidia-390.116-default/nvidia-uvm/uvm_common.h:48,
 
 

                  from
/usr/src/kernel-modules/nvidia-390.116-default/nvidia-uvm/uvm8_tools.c:23:
 
 

/usr/src/linux-5.2.8-1/include/linux/mm.h:1080:6: note: previous
declaration of ‘put_user_pages’ was here
 

  1080 | void put_user_pages(struct page **pages, unsigned long npages);
 
 

       |      ^~~~~~~~~~~~~~
 
 

make[3]: *** [/usr/src/linux-5.2.8-1/scripts/Makefile.build:280:
/usr/src/kernel-modules/nvidia-390.116-default/nvidia-uvm/uvm8_tools.o]
Error 1

make[2]: *** [/usr/src/linux-5.2.8-1/Makefile:1611:
_module_/usr/src/kernel-modules/nvidia-390.116-default] Error 2
 

make[2]: Leaving directory '/usr/src/linux-5.2.8-1-obj/x86_64/default'
 
 

make[1]: *** [Makefile:179: sub-make] Error 2
 
 

make[1]: Leaving directory '/usr/src/linux-5.2.8-1'
 
 

make: *** [Makefile:79: modules] Error 2

Reproducible: Always

Steps to Reproduce:
1. Update tumbleweed to snapshot 20190814.
2. Install x11-video-nvidiaG04 using zypper.
Actual Results:  
No nvidia modules loaded in current kernel (5.2.8-1-default).

Expected Results:  
No compile error. Nvidia modules loaded into kernel.
Comment 1 Stefan Dirsch 2019-08-19 15:13:56 UTC
This is fixed with 390.129. Packages are already on their way to our repos ...
Comment 2 Stefan Dirsch 2019-08-19 15:15:23 UTC
*** Bug 1146039 has been marked as a duplicate of this bug. ***