Bug 1146022 - hplip, infinite loop setting up some printers
hplip, infinite loop setting up some printers
Status: RESOLVED UPSTREAM
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Printing
Current
64bit openSUSE Factory
: P5 - None : Normal (vote)
: ---
Assigned To: Johannes Meixner
Johannes Meixner
https://www.linuxquestions.org/questi...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-08-18 17:33 UTC by Geoffrey Fagan
Modified: 2020-03-26 16:26 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Geoffrey Fagan 2019-08-18 17:33:22 UTC
Similar to 1139794, infinite loop when installing the proprietary blob (but happens no matter how hplip is invoked). Only some printers need the blob, like the Laserjet P1102w in my case. This happens with hplip 3.19.3 - whatever version Leap has seems ok. 

Adding some symlinks makes the process runs smoothly; can they be installed by the rpm? 
/usr/lib/i386-linux-gnu/sane -> /usr/lib/sane
/usr/lib/x86_64-linux-gnu -> /usr/lib64/x86_64-linux-gnu
/usr/lib64/x86_64-linux-gnu/sane -> /usr/lib64/sane

Hat tip to zaskar_84 who posted the fix here: https://www.linuxquestions.org/questions/linux-software-2/hplip-keeps-looping-at-plug-in-installation-4175647505/

GEF
Comment 1 Johannes Meixner 2020-03-26 16:26:54 UTC
First and foremost:
In general issues with HPLIP's proprietary plugins
do not belong to us (i.e. to openSUSE) because the whole
HPLIP proprietary plugins stuff belongs to non-free software
where only those who made the non-free software can provide
real help and support, cf. the sections
"Printers with non-free driver software" in
https://en.opensuse.org/SDB:Printer_buying_guide
and "Third-Party Scanner Drivers"
https://en.opensuse.org/SDB:Configuring_Scanners
so the responsibility for the bug lies at HPLIP upstream, cf.
https://developers.hp.com/hp-linux-imaging-and-printing/about
where you could report this issue.

Nevertheless some blind guess what the root cause could be
(I do not have a HP device that needs any kind of
proprietary driver/plugin/whatever so I cannot reproduce
anything with HPLIP's proprietary plugins):

https://www.linuxquestions.org/questions/linux-software-2/hplip-keeps-looping-at-plug-in-installation-4175647505/#post5958568
reads (excerpt, long lines shown wrapped here):
-------------------------------------------------------------------------
hp-setup[31158]: debug: Either
 /usr/lib/i386-linux-gnu/sane/libsane-hp2000S1.so file is not present
 or symbolic link is missing
hp-setup[31158]: debug: /usr/lib/i386-linux-gnu/sane/libsane-hp2000S1.so
 library status: 0
-------------------------------------------------------------------------

As far as I can imagine
/usr/lib/i386-linux-gnu/sane/libsane-hp2000S1.so
is a library from HPLIP's proprietary plugin
(likely a proprietary library for scanning)
which uses a directory that is wrong for openSUSE
and other distributions (but that is right for Ubuntu)
so it seems this needs to be fixed in HPLIP's proprietary plugin.