Bug 1146011 - Audio very low on Lenovo Ideapad S940
Audio very low on Lenovo Ideapad S940
Status: RESOLVED WONTFIX
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Sound
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Takashi Iwai
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-08-18 01:40 UTC by James Oakley
Modified: 2019-09-07 18:57 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
alsa-info (42.95 KB, text/plain)
2019-08-18 01:40 UTC, James Oakley
Details
alsa-info after /lib/firmware update (42.76 KB, text/plain)
2019-08-22 03:06 UTC, James Oakley
Details
alsa-info 3 (43.70 KB, text/plain)
2019-08-24 00:41 UTC, James Oakley
Details

Note You need to log in before you can comment on or make changes to this bug.
Description James Oakley 2019-08-18 01:40:46 UTC
Created attachment 814363 [details]
alsa-info

I have a Lenovo Ideapad S940, which has very low audio in Tumbleweed. From what I can gather, this device has a subwoofer that is not getting enabled. I tried setting various parameters using hdajackretask and hda-analyzer, as described in various forums for other Lenovo devices, but I have not been successful.

I undid the settings, rebooted, and generated an alsa-info, which I am attaching.
Comment 1 Takashi Iwai 2019-08-18 07:50:29 UTC
Did you try to change the pin config for NID 0x17 to something like 0x99130112, which corresponds to the subwoofer?
Comment 2 James Oakley 2019-08-18 22:42:37 UTC
I attempted that. I stopped pulseaudio, then:

echo "0x17 0x99130112" /sys/class/sound/hwC0D0/user_pin_configs
echo 1 > /sys/class/sound/hwC0D0/reconfig 

Then started pulesaudio again. This resulted in no sound at all, and aplay printed a series of underrun notices:


aplay /usr/share/sounds/alsa/test.wav
Invalid MIT-MAGIC-COOKIE-1 keyPlaying WAVE '/usr/share/sounds/alsa/test.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
underrun!!! (at least 892.694 ms long)
underrun!!! (at least 1039.358 ms long)
underrun!!! (at least 1023.307 ms long)
underrun!!! (at least 1009.486 ms long)
underrun!!! (at least 1004.156 ms long)
underrun!!! (at least 1010.759 ms long)
underrun!!! (at least 1010.537 ms long)
underrun!!! (at least 1001.043 ms long)
underrun!!! (at least 1002.312 ms long)
underrun!!! (at least 1003.264 ms long)
underrun!!! (at least 1003.425 ms long)
underrun!!! (at least 1003.717 ms long)
underrun!!! (at least 1005.444 ms long)
underrun!!! (at least 1000.490 ms long)
underrun!!! (at least 1003.493 ms long)


I also tried various things like:

https://superuser.com/questions/975219/how-to-disable-power-saving-on-my-lenovo-y50s-subwoofer-audio-pins

I had no luck with hda analyzer.

I also attempted to use hdajackretask to remap 0x17 to be the LFE out, since it seems to get detected as a headphone output. That also fails.
Comment 3 Takashi Iwai 2019-08-19 06:58:00 UTC
I don't know what went wrong, but a more safer way would be to create a file /lib/firmware/alsa/hda containing the lines:

[codec]
0x10ec0298 0x17aa3816 0

[pincfg]
0x17 0x99130112

.... then pass this to model option for snd-hda-intel module, e.g. create /etc/modprobe.d/60-hda.conf containing the line

options snd-hda-intel model=alsa/hda

.... and reboot / retest.
Comment 4 James Oakley 2019-08-22 03:05:31 UTC
OK, with that, sound plays like before, but the subwoofer still does not appear to be enabled.

Attaching a new alsa-info after that change.
Comment 5 James Oakley 2019-08-22 03:06:16 UTC
Created attachment 815109 [details]
alsa-info after /lib/firmware update
Comment 6 Takashi Iwai 2019-08-22 13:28:34 UTC
Oops, sorry it was a wrong option name.  Pass patch option instead of model.
  options snd-hda-intel patch=alsa/hda
Comment 7 James Oakley 2019-08-24 00:40:49 UTC
Sadly this has the same result. No subwoofer output. Will attach another alsa-info.
Comment 8 James Oakley 2019-08-24 00:41:37 UTC
Created attachment 815577 [details]
alsa-info 3
Comment 9 James Oakley 2019-09-07 18:57:06 UTC
I sent the laptop back, so I am unable to debug this further.