Bug 1145921 - dracut: `rd.neednet=1 ip=dhcp` boot parameters end in emergency shell
dracut: `rd.neednet=1 ip=dhcp` boot parameters end in emergency shell
Status: RESOLVED DUPLICATE of bug 1146661
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Thomas Blume
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-08-16 14:20 UTC by Ignaz Forster
Modified: 2019-09-23 09:37 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ignaz Forster 2019-08-16 14:20:25 UTC
When appending `rd.neednet=1 ip=dhcp` as boot parameters in GRUB to get a network connection during dracut, then the system will end up in an emergency shell.

Example:
* Boot openSUSE-Tumbleweed-GNOME-Live-x86_64-Snapshot20190814.iso
* In GRUB press 'e' on the main entry and append "rd.neednet=1 ip=dhcp" to the "$linux ..." line and press F10 to boot the modified entry
* The system will now wait after it got an IP address with wicked
* Wait for about two and a half minutes until dracut-initqueue will run into a timeout and print dozens of "Warning: dracut-initqueue timeout - starting timeout scripts"
* Wait for another minute until thrown into an emergency shell

From a first look it seems the timeout is caused because /lib/dracut/hooks/initqueue/finished/wait-network.sh will never return success.
Comment 1 Ignaz Forster 2019-09-23 09:37:52 UTC
Alberto discovered the same bug and already submitted a (working) bugfix on GitHub.

*** This bug has been marked as a duplicate of bug 1146661 ***