Bug 1145913 - apcupsd was compiled without: configure --enable-usb
apcupsd was compiled without: configure --enable-usb
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
All SUSE Other
: P5 - None : Normal (vote)
: ---
Assigned To: Stanislav Brabec
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-08-16 09:59 UTC by Axel Schwarzer
Modified: 2019-08-26 21:51 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
Output from "systemctl status apcupsd" with apcupsd-3.14.14-9.1-x86_64 installed (1.67 KB, text/plain)
2019-08-17 17:28 UTC, Axel Schwarzer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Axel Schwarzer 2019-08-16 09:59:03 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/76.0.3809.100 Safari/537.36
Build Identifier: 

The last update in openSUSE Tumbleweed by my customer:

2019-08-15 20:03:29|install|apcupsd|3.14.14-9.1|x86_64|root@birke|tw.Ioss|517a7ae6d6ff11a4fef976eba9bbd603eff2f3b5ac0d4895be7a9919cbb7702d|

introduced apcupds packages which are not able to communicate via USB to the UPS. Installing the previous version:

2019-08-16 11:28:28|command|root@birke|'zypper' 'in' '--force' 'apcupsd-3.14.14-8.1.x86_64.rpm' 'apcupsd-gui-3.14.14-8.1.x86_64.rpm'|

restores full functionality:
APC      : 001,018,0446
DATE     : 2019-08-16 11:31:34 +0200  
HOSTNAME : birke
VERSION  : 3.14.14 (31 May 2016) suse
UPSNAME  : Back-UPS Pro 900
CABLE    : USB Cable
DRIVER   : USB UPS Driver
UPSMODE  : Stand Alone
STARTTIME: 2019-08-16 11:30:22 +0200  
STATUS   : COMMLOST 
MBATTCHG : 5 Percent
MINTIMEL : 3 Minutes
MAXTIME  : 0 Seconds
NUMXFERS : 0
TONBATT  : 0 Seconds
CUMONBATT: 0 Seconds
XOFFBATT : N/A
STATFLAG : 0x05000100
END APC  : 2019-08-16 11:46:58 +0200  

As a workaround I've locked the packages now.



Reproducible: Always

Steps to Reproduce:
1. have an UPS like "Back-UPS Pro 900" attached with USB cable; have it configured

2. install apcupsd-3.14.14-9.1-x86_64 and see error msgs from "systemctl start apcupsd"

3. install apcupsd-3.14.14-8.1.x86_64 and it will work again
Actual Results:  
Was able to restore functionality.

Expected Results:  
It should be recompiled with an added option for configure: --enable-usb

I'm afraid most of the business men using openSUSE and an UPS won't be able to fix it that fast. Normally updates run in background so I would deem it to have severe consequences.
Comment 1 Axel Schwarzer 2019-08-17 17:28:40 UTC
Created attachment 814361 [details]
Output from "systemctl status apcupsd" with apcupsd-3.14.14-9.1-x86_64 installed

Because the connection to bugzilla.opensuse.org was cancelled while I originally entered this bug report I was not able to attach it then.
Comment 2 patrick shanahan 2019-08-17 19:06:02 UTC
I have the same

an interim solution:
  https://build.opensuse.org/package/show/home:lemmy04/apcupsd

works for me
Comment 3 Stanislav Brabec 2019-08-26 21:51:59 UTC
Broken by:
Fri Aug  9 18:52:07 UTC 2019 - Bjørn Lie <bjorn.lie@gmail.com>

- Stop passing enable-all to configure, pass enable-gapcmon and
  enable-cgi instead, reflecting what we actually build.
- Following this, drop unused pkgconfig(gnome-vfs-2.0)
  BuildRequires and add pkgconfig(glib-2.0) and
  pkgconfig(gthread-2.0), align with what configure actually checks
  for.

Fixed by:
Tue Aug 20 02:06:15 UTC 2019 - Bjørn Lie <bjorn.lie@gmail.com>

- Pass --enable-usb, --enable-modbus-usb and --enable-test to
  configure aswell, build all the drivers we used to build with
  --enable-all (boo#1145913).

(Already in Factory.)


Comparing build log before and after these two changes, I see a big difference in the package list in the build environment, but no change in the configure and make log, and a good looking change in apcconfig.h

--- apcupsd.old/apcupsd-3.14.14/include/apcconfig.h<--->2019-08-26 22:19:18.787364026 +0200
+++ apcupsd/apcupsd-3.14.14/include/apcconfig.h>2019-08-26 23:47:53.413096211 +0200
@@ -133,7 +133,7 @@
 #define HAVE_NETINET_IN_H 1
.
 /* Define if building net driver */
-#define HAVE_NET_DRIVER /**/
+#define HAVE_NET_DRIVER 1
.
 /* Define if apcupsd NIS library is being built */
 #define HAVE_NISLIB /**/
@@ -148,7 +148,7 @@
 /* #undef HAVE_OSF1_OS */
.
 /* Define if building PCNET driver */
-#define HAVE_PCNET_DRIVER /**/
+#define HAVE_PCNET_DRIVER 1
.
 /* Define if you have pthreads */
 #define HAVE_PTHREADS 1
@@ -175,7 +175,7 @@
 #define HAVE_SIGNAL_H 1
.
 /* Define if building snmplite driver */
-#define HAVE_SNMPLITE_DRIVER /**/
+#define HAVE_SNMPLITE_DRIVER 1
.
 /* Define to 1 if you have the `snprintf' function. */
 #define HAVE_SNPRINTF 1

=> Now the package adds more drivers.