Bug 1145116 - haveged.service: Main process exited, code=exited, status=1/FAILURE
haveged.service: Main process exited, code=exited, status=1/FAILURE
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
i586 Other
: P5 - None : Normal (vote)
: ---
Assigned To: Otto Hollmann
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-08-09 18:33 UTC by Suse User
Modified: 2022-04-21 08:29 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
journalctl -b -o short-monotonic --no-hostname | grep -i haveged -B 5 -A 5 (5.97 KB, text/plain)
2019-08-09 18:33 UTC, Suse User
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Suse User 2019-08-09 18:33:08 UTC
Created attachment 813544 [details]
journalctl -b -o short-monotonic --no-hostname | grep -i haveged -B 5 -A 5

I noticed several failures related to this service on a freshly installed Tumblweed system.

Attaching journal excerpt.
Comment 1 Peter Simons 2019-08-12 07:20:34 UTC
The only clue I see in the logs is the error

> haveged: Couldn't get poolsize
> haveged.service: Main process exited, code=exited, status=1/FAILURE

which occurs when haveged can't read /proc/sys/kernel/random/poolsize. (/proc not mounted?)

However, a moment later the restarted process seemingly crashes once more without saying anything about this issue, so I suppose it's unlikely that this is the cause of the crash.
Comment 2 Michael Pujos 2019-10-21 14:14:01 UTC
I am also seeing this in logs, although it starts normally some time after that failure.
Comment 3 André Werlang 2020-07-31 18:43:27 UTC
From https://github.com/jirka-h/haveged/blob/7ae444b7a0aa64a96729d78dd724b4398b9b0eaa/src/haveged.c#L542

    error_exit("Couldn't get poolsize");

So this message points to the reason the service fails. Since the process restarts and doesn't seem to repeat the failure, I believe it's a timing thing. It needs to start after /proc is mounted, or something.
Comment 5 Otto Hollmann 2022-03-11 09:45:58 UTC
It sounds like bug bsc#1160723 which was already resolved with update to newer version of haveged. Can you try it with latest version and let me know if issue persists?
Comment 6 Suse User 2022-04-20 07:49:02 UTC
I don't see the message in the log any more.
Comment 7 Otto Hollmann 2022-04-21 08:29:25 UTC
Thank you for feedback, closing this bug as resolved.