Bug 1144952 - YaST no longer appears in GNOME search results
YaST no longer appears in GNOME search results
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
Current
x86-64 openSUSE Factory
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-08-08 22:17 UTC by ravas mi
Modified: 2019-08-21 07:00 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ravas mi 2019-08-08 22:17:43 UTC
Since updating from 20190730 to 20190806, YaST was removed from my favorites bar, and when I press the SuperKey and type in YaST I get various YaST sub-components but not YaST itself. It can however be found manually via "Show Applications".
Comment 1 xiaoguang wang 2019-08-19 01:49:12 UTC
The .desktop files in new latest yast package are changed. All the .desktop files in folder /usr/share/applications/YaST2 are added 'YaST' word in 'Name' field.
When you type 'yast' after you press the SuperKey, all the .desktop files in /usr/share/applications/YaST2 folder match the search, but search result can only show 5 application icons, so you can't see the yast icon.

Just a test or a workaround:
1. change file /usr/share/applications/org.openSUSE.YaST.desktop
   from: Name=YaST
   to:   Name=YaST2
2. press SuperKey, type in yast2, you can see the yast icon now.
Comment 2 ravas mi 2019-08-20 06:23:50 UTC
Hi xiaoguang wang +

It works like you said.
Comment 3 Yifan Jiang 2019-08-20 07:13:30 UTC
So desktop file change actually seems working as designed (intended), I am changing the component to YaST for a confirmation. Thank you ravas, Xiaoguang!
Comment 4 Stefan Hundhammer 2019-08-20 09:48:34 UTC
I don't know what exactly we are expected to do here...

Yes, the .desktop files were changed; they all got a consistent naming scheme now. This was requested and done by desktop experts from the community.

But that specific .desktop file has been unchanged (other than the rename and the icon name) since a long time:

% cat /usr/share/applications/org.openSUSE.YaST.desktop
[Desktop Entry]
Type=Application
Categories=Settings;System;X-SuSE-Core-System;X-SuSE-ControlCenter-System;X-GNOME-SystemSettings;
Name=YaST
Icon=yast-control-center
GenericName=Administrator Settings
Exec=/usr/bin/xdg-su -c /sbin/yast2
Encoding=UTF-8
Comment=Manage system-wide settings

% git blame org.openSUSE.YaST.desktop

^8c6e3f6 src/YaST.desktop (Katarína Machálková 2009-06-25 16:07:54 +0000 4) Name=YaST
Comment 5 Stefan Hundhammer 2019-08-20 09:49:05 UTC
IMHO there is no bug. Closing.
Comment 6 xiaoguang wang 2019-08-21 01:29:44 UTC
For a .desktop file it's better to have a specific name, it will be easy to be searched. If many desktop files include a same name, it will make no sense for that name.
Now when we type in yast we will no see this '/usr/share/applications/org.openSUSE.YaST.desktop' icon in gnome overview search result, that is not a good user experience.
Comment 7 David Diaz 2019-08-21 07:00:23 UTC
I tested it yesterday (using TW VERSION_ID="20190809") and me neither can't see the access to YaST in the Gnome search because the limitation in the results. Even more, a guy from OBS also ask me about that yesterday in the morning.

So, I agree with 

(xiaoguang wang in comment #6)
> that is not a good user experience.

but at the same time, I think that this consistent naming scheme is better now since it's easier to distinguish the YaST modules from other tools.

I took a look to the Desktop Entry Specification[1] and I didn't see anything that could help with that (precedence, weight or something similar). So, I wouldn't know to say how to solve it.

Of course, suggestions are welcome.

[1] https://specifications.freedesktop.org/desktop-entry-spec/desktop-entry-spec-1.1.html