Bug 1144894 - [Build 20190806] autoyast profile doesn't validate
[Build 20190806] autoyast profile doesn't validate
Status: VERIFIED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: AutoYaST
Current
Other Other
: P2 - High : Normal (vote)
: ---
Assigned To: Stefan Schubert
E-mail List
https://openqa.opensuse.org/tests/100...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-08-08 13:58 UTC by Rodion Iafarov
Modified: 2022-02-04 11:55 UTC (History)
6 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
xml schema (8.01 KB, application/xml)
2019-08-08 13:58 UTC, Rodion Iafarov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rodion Iafarov 2019-08-08 13:58:51 UTC
Created attachment 813357 [details]
xml schema

## Observation

Might be related to the issue mentioned in https://bugzilla.opensuse.org/show_bug.cgi?id=1144007 

jing reports:

/usr/share/YaST2/schema/autoyast/rng/profile.rng:47:45: error: reference to undefined pattern "org.opensuse.yast.Mail"
/usr/share/YaST2/schema/autoyast/rng/profile.rng:29:49: error: reference to undefined pattern "org.opensuse.yast.Firewall"
/usr/share/YaST2/schema/autoyast/rng/profile.rng:110:50: error: reference to undefined pattern "org.opensuse.yast.Firstboot"
/usr/share/YaST2/schema/autoyast/rng/profile.rng:101:46: error: reference to undefined pattern "org.opensuse.yast.Users"
/usr/share/YaST2/schema/autoyast/rng/profile.rng:59:50: error: reference to undefined pattern "org.opensuse.yast.NISServer"
/usr/share/YaST2/schema/autoyast/rng/profile.rng:129:46: error: reference to undefined pattern "org.opensuse.yast.Kdump"
/usr/share/YaST2/schema/autoyast/rng/profile.rng:126:51: error: reference to undefined pattern "org.opensuse.yast.Bootloader"
/usr/share/YaST2/schema/autoyast/rng/profile.rng:56:44: error: reference to undefined pattern "org.opensuse.yast.NIS"
/usr/share/YaST2/schema/autoyast/rng/profile.rng:92:50: error: reference to undefined pattern "org.opensuse.yast.Sysconfig"
/usr/share/YaST2/schema/autoyast/rng/profile.rng:53:50: error: reference to undefined pattern "org.opensuse.yast.NFSServer"
/usr/share/YaST2/schema/autoyast/rng/profile.rng:65:66: error: reference to undefined pattern "org.opensuse.yast.OnlineUpdateConfiguration"
/usr/share/YaST2/schema/autoyast/rng/profile.rng:123:46: error: reference to undefined pattern "org.opensuse.yast.AddOn"
/usr/share/YaST2/schema/autoyast/rng/profile.rng:50:44: error: reference to undefined pattern "org.opensuse.yast.NFS"
/usr/share/YaST2/schema/autoyast/rng/profile.rng:83:56: error: reference to undefined pattern "org.opensuse.yast.ServicesManager"
/usr/share/YaST2/schema/autoyast/rng/profile.rng:86:46: error: reference to undefined pattern "org.opensuse.yast.Sound"

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-clone_system@64bit fails in
[yast2_clone_system](https://openqa.opensuse.org/tests/1000130/modules/yast2_clone_system/steps/32)

## Test suite description
Maintainer: okurz@suse.de
Clone the system into an autoyast profile to be used by downstream jobs, e.g. to test reinstall from that profile.


## Reproducible

Fails since (at least) Build [20190731](https://openqa.opensuse.org/tests/997194)


## Expected result

Last good: [20190730](https://openqa.opensuse.org/tests/996249) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?arch=x86_64&distri=opensuse&flavor=DVD&machine=64bit&test=clone_system&version=Tumbleweed)
Comment 1 Dominique Leuenberger 2019-08-08 14:17:38 UTC
Dup of https://bugzilla.opensuse.org/show_bug.cgi?id=1144007

*** This bug has been marked as a duplicate of bug 1144007 ***
Comment 2 Rodion Iafarov 2019-08-08 14:20:18 UTC
(In reply to Dominique Leuenberger from comment #1)
> Dup of https://bugzilla.opensuse.org/show_bug.cgi?id=1144007
> 
> *** This bug has been marked as a duplicate of bug 1144007 ***

I'm not sure how is it duplicate if these are two different issues. I leave it to the YaST team to decide how to proceed.
Issue described in 1144007 is resolved and this is another one.
Comment 3 Rodion Iafarov 2019-08-21 07:07:57 UTC
https://bugzilla.opensuse.org/show_bug.cgi?id=1144007 is resolved, it's next issue. We see this issue in SLE 15 SP2 now too:
https://openqa.suse.de/tests/3246056
Comment 4 David Diaz 2019-08-21 08:53:15 UTC
Thank you Rodion.

It seems that @Imobach realized that it could happen in https://bugzilla.opensuse.org/show_bug.cgi?id=1144007#c1 And now we have the confirmation.

Adding it to our Trello scrum board to look for a solution.
Comment 6 Yiannis Bonatakis 2019-08-26 15:24:45 UTC
still happening in the latest Build 20.3
Comment 7 Stefan Schubert 2019-08-27 16:04:58 UTC
I will take over....
Comment 10 Ludwig Nussel 2019-09-06 08:25:01 UTC
Leap has autoyast2 4.2.8 but the openqa job still fails:
https://openqa.opensuse.org/tests/1025781
Comment 11 Ludwig Nussel 2019-09-11 09:07:29 UTC
ping?
Comment 12 Stefan Schubert 2019-09-11 11:53:45 UTC
I see that the test still uses:
xmllint --noout --relaxng /usr/share/YaST2/schema/autoyast/rng/profile.rng /root/autoinst.xml ; echo qJBbl-$?-

Could we change this to jing in order to see what is going wrong? Otherwise I have to download each time the current ISO and have to try it out by my own in order to see what is going wrong.
Comment 13 Stefan Schubert 2019-09-11 12:06:51 UTC
In order to try it out by my own. Where can I get
openSUSE-Leap-15.2-DVD-x86_64-Build492.3-Media.iso ?
Comment 14 Rodion Iafarov 2019-09-11 12:15:31 UTC
(In reply to Stefan Schubert from comment #13)
> In order to try it out by my own. Where can I get
> openSUSE-Leap-15.2-DVD-x86_64-Build492.3-Media.iso ?

Hi Shubi! 
So first things first, on TW we have patch already: https://openqa.opensuse.org/tests/1029518

So seems we might miss submission for Leap 15.2

As for jing, we run both tools in the test, and for Leap 15.2 current error is shown here:
https://openqa.opensuse.org/tests/1029803#step/yast2_clone_system/32
namely "/usr/share/YaST2/schema/autoyast/rng/profile.rng:83:31: error: reference to undefined pattern "runlevel""

As for the iso, you can find it on the Assets tab in openQA:
https://openqa.opensuse.org/tests/1029803#downloads

https://openqa.opensuse.org/tests/1029803/asset/iso/openSUSE-Leap-15.2-DVD-x86_64-Build493.4-Media.iso this is the link to the latest image we have used.

Let me know if you need anything else ;)
Comment 15 Stefan Schubert 2019-09-11 12:45:20 UTC
Thanks Radion. Hm, I have not found this information in:
(In reply to Ludwig Nussel from comment #10)
> Leap has autoyast2 4.2.8 but the openqa job still fails:
> https://openqa.opensuse.org/tests/1025781

So I am a little bit confused when the information is there or not :-)
Comment 16 Stefan Schubert 2019-09-12 08:30:27 UTC
OK, next round :-)
https://github.com/yast/yast-schema/pull/62
Comment 17 Rodion Iafarov 2019-10-01 11:25:10 UTC
Fixed in 20190923