Bug 1144670 - Wireless interface doesn't start on boot
Wireless interface doesn't start on boot
Status: RESOLVED DUPLICATE of bug 1156920
: 1145159 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Network
Current
x86-64 All
: P5 - None : Major (vote)
: ---
Assigned To: Karol Babioch
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-08-07 11:51 UTC by Luca Billi
Modified: 2020-11-23 10:55 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
config-ifcfg.tgz (22.69 KB, application/x-compressed-tar)
2019-12-11 13:15 UTC, Freek de Kruijf
Details
config-dump.log (2.71 KB, text/x-log)
2019-12-11 13:17 UTC, Freek de Kruijf
Details
status.log (1.99 KB, text/x-log)
2019-12-11 13:18 UTC, Freek de Kruijf
Details
journal.log (142.42 KB, text/x-log)
2019-12-11 13:19 UTC, Freek de Kruijf
Details
ip_addr.log (1.15 KB, text/x-log)
2019-12-11 13:22 UTC, Freek de Kruijf
Details
routes.log (1.44 KB, text/x-log)
2019-12-11 13:23 UTC, Freek de Kruijf
Details
wicked-version.log (58 bytes, text/x-log)
2019-12-11 13:24 UTC, Freek de Kruijf
Details
iptables.txt (36.04 KB, text/plain)
2019-12-11 13:25 UTC, Freek de Kruijf
Details
ip6tables.txt (26.55 KB, text/plain)
2019-12-11 13:26 UTC, Freek de Kruijf
Details
hwinfo-netcard.log (2.45 KB, text/x-log)
2019-12-11 13:27 UTC, Freek de Kruijf
Details
wpa_supplicant.log (488 bytes, text/x-log)
2019-12-11 13:27 UTC, Freek de Kruijf
Details
bridge-nf.txt (68 bytes, text/plain)
2019-12-11 13:33 UTC, Freek de Kruijf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luca Billi 2019-08-07 11:51:33 UTC
After updating to Tumbleweed 20190805, the wireless interface is not started during boot anymore and the following errors show up in the log:

wickedd[766]: ni_wpa_interface_bind(wlan0): Operation not permitted
wickedd[766]: wpa_supplicant doesn't know interface wlan0
wickedd-nanny[768]: device wlan0: call to org.opensuse.Network.Wireless.changeDevice() failed: General failure
wickedd-nanny[768]: wlan0: failed to bring up device, still continuing
wicked[769]: lo              setup-in-progress
wicked[769]: wlan0           device-not-running


Since I noticed that the latest update changed the starting order of wpa_supplicant.service, I tried to revert it.
By simply adding back

Before=network.target

in /usr/lib/systemd/system/wpa_supplicant.service
the booting process is back to normal with a working wifi.
Comment 1 Freek de Kruijf 2019-08-19 07:57:18 UTC
I have the same problem on a 32bit Tumbleweed system. Same type of error message.
Comment 2 Freek de Kruijf 2019-12-09 12:23:01 UTC
Please correct this. I experienced it once again on a 32bit Tumbleweed system.
Comment 3 Freek de Kruijf 2019-12-11 13:14:49 UTC
On my 64bits Tumbleweed machine I have the same problem to activate a wireless USB dongle.
So I use the Wiki article "Reporting Wicked/Networking related bugs" to report the problem.

It looks like sequencing processes is not right.
dec 11 12:54:49.466295 eiktum wickedd[1268]: ni_wpa_interface_bind(wlp0s22f2u2): Interrupted system call
dec 11 12:54:49.466299 eiktum wickedd[1268]: wpa_supplicant doesn't know interface wlp0s22f2u2

The suggested solution by Luca Billi about changing the starting order does not work, which did work in August on the 32bit machine, but now not anymore.

So the following attachments will be added:
config-ifcfg.tgz
config-dump.log
status.log
journal.log, however using grep wicked
ip_addr.log
routes.log
wicked-version.log
iptables.txt
ip6tables.txt
hwinfo-netcard.log
wpa_supplicant.log
Comment 4 Freek de Kruijf 2019-12-11 13:15:58 UTC
Created attachment 825976 [details]
config-ifcfg.tgz
Comment 5 Freek de Kruijf 2019-12-11 13:17:23 UTC
Created attachment 825977 [details]
config-dump.log
Comment 6 Freek de Kruijf 2019-12-11 13:18:38 UTC
Created attachment 825978 [details]
status.log
Comment 7 Freek de Kruijf 2019-12-11 13:19:25 UTC
Created attachment 825979 [details]
journal.log
Comment 8 Freek de Kruijf 2019-12-11 13:22:14 UTC
Created attachment 825980 [details]
ip_addr.log
Comment 9 Freek de Kruijf 2019-12-11 13:23:43 UTC
Created attachment 825982 [details]
routes.log
Comment 10 Freek de Kruijf 2019-12-11 13:24:17 UTC
Created attachment 825983 [details]
wicked-version.log
Comment 11 Freek de Kruijf 2019-12-11 13:25:49 UTC
Created attachment 825984 [details]
iptables.txt
Comment 12 Freek de Kruijf 2019-12-11 13:26:18 UTC
Created attachment 825985 [details]
ip6tables.txt
Comment 13 Freek de Kruijf 2019-12-11 13:27:04 UTC
Created attachment 825986 [details]
hwinfo-netcard.log
Comment 14 Freek de Kruijf 2019-12-11 13:27:40 UTC
Created attachment 825987 [details]
wpa_supplicant.log
Comment 15 Freek de Kruijf 2019-12-11 13:31:45 UTC
Changed priority to major, because running a cable over the floor is harmful.
Comment 16 Freek de Kruijf 2019-12-11 13:33:39 UTC
Created attachment 825988 [details]
bridge-nf.txt
Comment 17 Freek de Kruijf 2019-12-14 17:16:35 UTC
Seems related to bug#1156920
Comment 18 Rubén Torrero Marijnissen 2020-03-25 15:57:14 UTC
*** Bug 1145159 has been marked as a duplicate of this bug. ***
Comment 19 Luca Billi 2020-04-28 13:06:52 UTC
Looks fixed in Tumbleweed 20200425 and wpa_supplicant-2.9-3.1