Bug 1144560 - [Build 20190805] openQA test fails in updates_packagekit_gpk
[Build 20190805] openQA test fails in updates_packagekit_gpk
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: GNOME
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: xiaoguang wang
E-mail List
https://openqa.opensuse.org/tests/999...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-08-06 19:35 UTC by Dominique Leuenberger
Modified: 2019-09-11 09:24 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Leuenberger 2019-08-06 19:35:37 UTC
## Observation

openQA test in scenario opensuse-Tumbleweed-NET-x86_64-zdup-Leap-42.2-gnome@64bit_cirrus fails in
[updates_packagekit_gpk](https://openqa.opensuse.org/tests/999880/modules/updates_packagekit_gpk/steps/31)

## Test suite description
20180309 -- lnussel -- switched to last available 42.2 image 20180206;  20180319 - dimstar - use same disk image as for update_Leap_42.2_gnome, resolve poo#33061


## Reproducible

Fails since (at least) Build [20190731](https://openqa.opensuse.org/tests/997128)


## Expected result

Last good: [20190730](https://openqa.opensuse.org/tests/996183) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?arch=x86_64&distri=opensuse&flavor=NET&machine=64bit_cirrus&test=zdup-Leap-42.2-gnome&version=Tumbleweed)
Comment 2 Jia Zhaocong 2019-08-07 07:37:32 UTC
I can confirm this is not a product bug -- GDM is not freeze.  This is probably a testing issue, I'll dig deeper to report back.
Comment 3 Jia Zhaocong 2019-08-07 09:04:09 UTC
The needle in this step is wrong: https://openqa.opensuse.org/tests/999870#step/updates_packagekit_gpk/7

That screen should match tag "screenlock-password" instead of "displaymanager".

It mismatched because the needle "displaymanager-gdm-nomouseover-20190729" is wrong: it should not have tag "displaymanager".

That needle is introduced by https://github.com/os-autoinst/os-autoinst-needles-opensuse/commit/6f099b3ae1ef4a7f4cd255376e38e7d73d17afde

So Dominique can you check why this needle is introduced and remove it from the repo?
Comment 4 Dominique Leuenberger 2019-08-07 09:10:11 UTC
Thanks for debugging Jia - I removed the needle from the repo. Let's see what else breaks, as obviously this needle was generated in a staging to get some issue fixed (possibly wrong copied tags though)
Comment 5 Dominique Leuenberger 2019-08-07 09:14:16 UTC
The needle was created for the tumbleweed logo at the bottom that became a bit larger

Looking at the image stored as reference with
https://github.com/os-autoinst/os-autoinst-needles-opensuse/commit/6f099b3ae1ef4a7f4cd255376e38e7d73d17afde?short_path=e7a6c70#diff-e7a6c70c8f4161465e6d869499fecfa7 it actually IS a displaymanager screenshot - just the screenlock-needle happens to match as well (yaiks)
Comment 6 Jia Zhaocong 2019-08-07 10:25:32 UTC
OK, now I understand: the needle is needle, just the matching area is too small.

I have created new needle, let's see if it works.
Comment 7 Jia Zhaocong 2019-08-08 01:48:41 UTC
Fixed, closing: https://openqa.opensuse.org/tests/1000633#step/updates_packagekit_gpk/8