Bug 1144439 - [Build 20190805] AutoYAST based installation fails
[Build 20190805] AutoYAST based installation fails
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: AutoYaST
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Dominique Leuenberger
E-mail List
https://openqa.opensuse.org/tests/999...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-08-06 08:10 UTC by Dominique Leuenberger
Modified: 2019-10-26 05:22 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Leuenberger 2019-08-06 08:10:51 UTC
## Observation

openQA test in scenario opensuse-Tumbleweed-NET-x86_64-autoyast_gnome@64bit fails in
[installation](https://openqa.opensuse.org/tests/999309/modules/installation/steps/43)

## Test suite description



## Reproducible

Fails since (at least) Build [20190731](https://openqa.opensuse.org/tests/997102)


## Expected result

Last good: [20190730](https://openqa.opensuse.org/tests/996493) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?arch=x86_64&distri=opensuse&flavor=NET&machine=64bit&test=autoyast_gnome&version=Tumbleweed)


This is a follow-up after changes in YaST for having two products co-exist in the FTP tree.

Likely we have to adjust the autoyast profile now - to also pick the right product?
Comment 1 José Iván López González 2019-08-06 14:56:22 UTC
Could you please attach the AutoYaST profile you are using for the test?
Comment 2 Dominique Leuenberger 2019-08-06 15:12:20 UTC
(In reply to José Iván López González from comment #1)
> Could you please attach the AutoYaST profile you are using for the test?

https://github.com/os-autoinst/os-autoinst-distri-opensuse/blob/master/data/autoyast_opensuse/opensuse_gnome.xml
Comment 3 David Diaz 2019-08-07 12:24:08 UTC
Hi Dominique!

Taking a look to the AutoYaST profile, it seems to me that the problem is in the <software> section[1] since there is not a <product> selected[2] and the installer found more than one product, as is shown in the error message.

So, the solution is to update the control file and "select" the desired product adding the <product> option in the <software> section. Something like 

>  <software>
>    <install_recommended config:type="boolean">true</install_recommended>
>    <products config:type="list">
>      <product>openSUSE</product>
>    </products>
>    <patterns config:type="list">
>      <pattern>apparmor</pattern>
>      <pattern>base</pattern>
>     <pattern>gnome</pattern>
>    </patterns>
>  </software>

Could you try it?

Thanks!

[1] https://github.com/os-autoinst/os-autoinst-distri-opensuse/blob/87909e1f1ac8b2048b2f44ef520529ede79d271d/data/autoyast_opensuse/opensuse_gnome.xml#L23-L30

[2] https://www.suse.com/documentation/sles-15/book_autoyast/data/createprofile_software.html#software_selections_base_product
Comment 4 Dominique Leuenberger 2019-08-07 12:52:18 UTC
Thanks for confirming - so my suspicion was right (and it happens only on the NET based installer, as the DVD based one only has one product on the DVD, the FTP tree has both)

So, I created a PR
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/8141

And a openQA test run:
https://openqa.opensuse.org/tests/1000671
Comment 5 José Iván López González 2019-08-07 15:00:45 UTC
Dominique, I see you are using this bug as reference in your PR. But due to there is nothing to fix from YaST size, I will reassign the bug directly to you. Please, send it back to YaST if you consider it.

Thanks for the report.