Bug 1144301 - [Build 20190801] no category is shown in yast2 control center when do search of the module
[Build 20190801] no category is shown in yast2 control center when do search ...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
Current
Other Other
: P5 - None : Minor (vote)
: ---
Assigned To: YaST Team
Jiri Srain
https://openqa.opensuse.org/tests/998...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-08-05 11:36 UTC by Rodion Iafarov
Modified: 2021-08-25 23:10 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
dgonzalez: needinfo? (riafarov)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rodion Iafarov 2019-08-05 11:36:55 UTC
## Observation

Previously, when do the search, on the left we had a list of categories which match results. Now this list is empty.
https://openqa.opensuse.org/tests/998606#step/yast2_control_center/12
 vs
https://openqa.opensuse.org/tests/996412#step/yast2_control_center/12

Change was in the last 5 days in comparison.

No obvious errors can be found in the logs.

Seems to be related to https://github.com/yast/yast-control-center/pull/42 as https://build.opensuse.org/request/show/707233 got accepted 5 days ago.

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-yast2_gui@64bit fails in
[yast2_control_center](https://openqa.opensuse.org/tests/998990/modules/yast2_control_center/steps/52)

## Test suite description
Maintainer: zluo, riafarov

Test for yast2 UI, GUI only. Running on created gnome images which provides both text console for ncurses UI tests as well as the gnome environment for the GUI tests.

Temporarily added YAST2_GUI_TERMINATE_PREVIOUS_INSTANCES to see if helps. This variable triggers code which terminates all yast2 processes before starting new one. (see poo#26104).


## Reproducible

Fails since (at least) Build [20190315](https://openqa.opensuse.org/tests/881432)


## Expected result

Last good: [20190313](https://openqa.opensuse.org/tests/879965) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?arch=x86_64&distri=opensuse&flavor=DVD&machine=64bit&test=yast2_gui&version=Tumbleweed)
Comment 1 David Diaz 2019-08-05 15:04:41 UTC
Thank you for the bug report Rodion.

As discussed in IRC, it seems to be related to change in desktop files done ~2 months ago[1], which were accepted 5 exactly 5 days ago[2].

Tracking it in our Trello board.

[1] https://github.com/yast/yast-control-center/pull/42
[2] https://build.opensuse.org/request/show/707233
Comment 3 David Diaz 2021-07-29 13:45:12 UTC
If I'm not wrong, looks like it is not reproducible anymore, is it?

https://openqa.opensuse.org/tests/1859727#step/yast2_control_center/32
Comment 4 David Diaz 2021-08-25 23:10:27 UTC
Closing as fixed.