Bug 1144062 - Please add "pam_keyinit.so" to the /etc/pam.d/vsftpd configuration file
Please add "pam_keyinit.so" to the /etc/pam.d/vsftpd configuration file
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
All All
: P5 - None : Normal (vote)
: Current
Assigned To: Cristian Rodríguez
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-08-02 15:20 UTC by Josef Möllers
Modified: 2022-03-14 10:55 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Josef Möllers 2019-08-02 15:20:12 UTC
In the near future, the use of kernel keyrings will be enabled by systemd.
To fully support this feature, the vsftpd package must include the pam_keyinit.so
module in its /etc/pam.d/vsftpd configuration file.
Please add this module to the /etc/pam.d/vsftpd configuration file with the
appropriate parameters:
session optional pam_keyinit.so revoke [force]
Thanks.
Comment 1 Josef Möllers 2019-08-15 07:51:37 UTC
Changed codestream to TW where it belongs.
Comment 2 Josef Möllers 2019-10-08 06:32:53 UTC
ping!
Any progress?
Comment 3 Josef Möllers 2020-01-08 12:48:26 UTC
Can you please take care of this?
Comment 4 Josef Möllers 2020-04-07 13:57:41 UTC
Fixed with https://build.opensuse.org/request/show/754432
Comment 6 Swamp Workflow Management 2021-04-14 13:17:15 UTC
SUSE-RU-2021:1186-1: An update that has 5 recommended fixes and contains one feature can now be installed.

Category: recommended (moderate)
Bug References: 1125951,1144062,1179553,1180314,1181512
CVE References: 
JIRA References: SLE-4182
Sources used:
SUSE Linux Enterprise Server for SAP 15 (src):    vsftpd-3.0.3-7.16.1
SUSE Linux Enterprise Server 15-LTSS (src):    vsftpd-3.0.3-7.16.1
SUSE Linux Enterprise Module for Server Applications 15-SP2 (src):    vsftpd-3.0.3-7.16.1
SUSE Linux Enterprise High Performance Computing 15-LTSS (src):    vsftpd-3.0.3-7.16.1
SUSE Linux Enterprise High Performance Computing 15-ESPOS (src):    vsftpd-3.0.3-7.16.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 7 Swamp Workflow Management 2021-04-17 19:15:16 UTC
openSUSE-RU-2021:0568-1: An update that has 5 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1125951,1144062,1179553,1180314,1181512
CVE References: 
JIRA References: 
Sources used:
openSUSE Leap 15.2 (src):    vsftpd-3.0.3-lp152.8.3.1
Comment 14 Swamp Workflow Management 2022-03-02 14:23:27 UTC
SUSE-RU-2022:0655-1: An update that has 11 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1042673,1070653,1083705,1089088,1125951,1144062,1179553,1180314,1181400,1187188,786024
CVE References: 
JIRA References: 
Sources used:
SUSE Linux Enterprise Server 12-SP5 (src):    vsftpd-3.0.5-48.3.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.