Bug 1144007 - [Build 20190801] yast2_clone_system fails
[Build 20190801] yast2_clone_system fails
Status: VERIFIED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: AutoYaST
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: YaST Team
E-mail List
https://openqa.opensuse.org/tests/997...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-08-02 11:41 UTC by Dominique Leuenberger
Modified: 2022-07-12 08:36 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Leuenberger 2019-08-02 11:41:31 UTC
## Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-clone_system@64bit fails in
[yast2_clone_system](https://openqa.opensuse.org/tests/997929/modules/yast2_clone_system/steps/30)

## Test suite description
Maintainer: okurz@suse.de
Clone the system into an autoyast profile to be used by downstream jobs, e.g. to test reinstall from that profile.


## Reproducible

Fails since (at least) Build [20190731](https://openqa.opensuse.org/tests/997194)


## Expected result

Last good: [20190730](https://openqa.opensuse.org/tests/996249) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?arch=x86_64&distri=opensuse&flavor=DVD&machine=64bit&test=clone_system&version=Tumbleweed)


jing reports:

/root/autoinst.xml:5:39: error: element "add_on_others" not allowed here; expected the element end-tag or element "add_on_products"
/root/autoinst.xml:737:17: error: element "uuid" not allowed here; expected the element end-tag or element "bcache_backing_for", "bcache_caching_for", "create", "create_subvolumes", "crypt", "crypt_fs", "crypt_key", "device_order", "filesystem", "filesystem_id", "format", "fs_options", "fstopt", "label", "loop_fs", "lv_name", "lvm_group", "mount", "mountby", "partition_id", "partition_nr", "partition_type", "pool", "raid_name", "raid_options", "raid_type", "region", "resize", "size", "stripes", "stripesize", "subvolumes", "subvolumes_prefix" or "used_pool"
/root/autoinst.xml:749:17: error: element "uuid" not allowed here; expected the element end-tag or element "bcache_backing_for", "bcache_caching_for", "create", "create_subvolumes", "crypt", "crypt_fs", "crypt_key", "device_order", "filesystem", "filesystem_id", "format", "fs_options", "fstopt", "label", "loop_fs", "lv_name", "lvm_group", "mount", "mountby", "partition_id", "partition_nr", "partition_type", "pool", "raid_name", "raid_options", "raid_type", "region", "resize", "size", "stripes", "stripesize", "subvolumes", "subvolumes_prefix" or "used_pool"
Comment 1 Imobach Gonzalez Sosa 2019-08-02 16:09:25 UTC
Initially, I thought this one would be easy to fix. We only needed to update the yast2-schema dependency on yast2-add-on and fix a problem in the autoyast2 partitioning rnc file.

* https://github.com/yast/yast-schema/pull/60
* https://github.com/yast/yast-autoinstallation/pull/518

However, it turns out that we will have a different problem in the near future because of this changes: https://github.com/yast/yast-yast2/issues/934. Renaming the files causes problems when building yast2-schema that we should address.
Comment 4 Dominique Leuenberger 2019-08-08 14:17:38 UTC
*** Bug 1144894 has been marked as a duplicate of this bug. ***
Comment 5 Rodion Iafarov 2019-08-21 07:06:45 UTC
(In reply to Dominique Leuenberger from comment #4)
> *** Bug 1144894 has been marked as a duplicate of this bug. ***

As I see no actions, I will resolve this one as problem reported here is fixed and reopen https://bugzilla.opensuse.org/show_bug.cgi?id=1144894

We see this issue in SLE 15 SP2 now, which is expected.