Bug 1143943 - [Build 20190801] Undefined method 'installation_package'
[Build 20190801] Undefined method 'installation_package'
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Installation
Current
Other Other
: P1 - Urgent : Normal (vote)
: ---
Assigned To: David Diaz
Jiri Srain
https://openqa.opensuse.org/tests/997...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-08-02 07:40 UTC by Dominique Leuenberger
Modified: 2022-09-12 10:32 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: Yes
Marketing QA Status: ---
IT Deployment: ---
dleuenberger: SHIP_STOPPER+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Leuenberger 2019-08-02 07:40:03 UTC
## Observation

openQA test in scenario opensuse-Tumbleweed-NET-x86_64-gnome@64bit fails in
[online_repos](https://openqa.opensuse.org/tests/997803/modules/online_repos/steps/2)

## Test suite description



## Reproducible

Fails since (at least) Build [20190731](https://openqa.opensuse.org/tests/997089)


## Expected result

Last good: [20190730](https://openqa.opensuse.org/tests/996477) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?arch=x86_64&distri=opensuse&flavor=NET&machine=64bit&test=gnome&version=Tumbleweed)
Comment 2 David Diaz 2019-08-02 11:39:34 UTC
I could reproduce it and find why is failing. 

Basically, the control file is forcing to use a specific base product among the available ones (through the `select_product` option added in https://github.com/yast/yast-installation/pull/790), avoiding to show the product selector. However, the product is not being marked as selected, which is translated in a `nil` result when the installer tries to find it.
Comment 3 David Diaz 2019-08-05 14:56:35 UTC
It has been fixed and it will be working as expected from with yast2-intallation >= 4.2.8

As I tried to explain in the previous comment, the base product given through the `select_product` option in the control.xml actually was not being selected. Anyway, more details are stated in the PRs description.


Useful links, 

- yast2 (4.2.17)
  * PR: https://github.com/yast/yast-yast2/pull/954
  * SR: https://build.opensuse.org/request/show/721080

- yast2-packager (4.2.23)
  * PR: https://github.com/yast/yast-packager/pull/466
  * SR: https://build.opensuse.org/request/show/721082

- yast2-installation (4.2.8)
  * PR: https://github.com/yast/yast-installation/pull/807
  * SR: https://build.opensuse.org/request/show/721084