Bug 1143405 - [Build 20190729] openQA test fails in salt: File conflict when running "zypper in"
[Build 20190729] openQA test fails in salt: File conflict when running "zyppe...
Status: VERIFIED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Salt
Current
Other Other
: P5 - None : Major (vote)
: ---
Assigned To: Todd R
E-mail List
https://openqa.opensuse.org/tests/995...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-07-30 09:42 UTC by Dominik Heidler
Modified: 2019-07-31 15:19 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominik Heidler 2019-07-30 09:42:07 UTC
## Observation

openQA test in scenario opensuse-Tumbleweed-NET-x86_64-update_13.2@64bit fails in
[salt](https://openqa.opensuse.org/tests/995536/modules/salt/steps/8)

## Test suite description



## Reproducible

Fails since (at least) Build [20190729](https://openqa.opensuse.org/tests/995536) (current job)


## Expected result

Last good: [20190728](https://openqa.opensuse.org/tests/994090) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?arch=x86_64&distri=opensuse&flavor=NET&machine=64bit&test=update_13.2&version=Tumbleweed)


Looks like a file conflict between python-numpy and python3-numpy:
/usr/bin/f2py seems to exist in both packages.
And both packages seem to get installed when calling
zypper -n in salt-master salt-minion
Comment 1 Tomáš Chvátal 2019-07-30 10:28:02 UTC
This is not an issue of salt but the python-numpy and python2-numpy split.
Comment 2 Dominik Heidler 2019-07-30 11:02:15 UTC
Inkscape test fail as well due to this bug:

https://openqa.opensuse.org/tests/995616#

Setting serverity to Major as we have >40 failing openQA jobs due to this bug.
Comment 3 Stefan Brüns 2019-07-30 17:27:15 UTC
Inkscape python3 port: https://build.opensuse.org/request/show/719866
Comment 4 Todd R 2019-07-30 21:11:13 UTC
This should be fixed now that python2-numpy is no longer in openSUSE:Factory.
Comment 5 Dominik Heidler 2019-07-31 14:32:17 UTC
Verified in 20190730
Comment 6 Todd R 2019-07-31 14:59:17 UTC
Does the following QA results mean the problem is fixed?  https://openqa.opensuse.org/tests/996461
Comment 7 Dominik Heidler 2019-07-31 15:19:42 UTC
The salt and inkscape tests do not fail anymore.
There doesn't seem to be a pkg with the name python-numpy anymore.

And the python2-numpy and python3-numpy pkgs don't seem to have conflicting files anymore.

 [root@athene ~]# rpm -ql python2-numpy | grep bin
/usr/bin/f2py2
/usr/bin/f2py2.7
[root@athene ~]# rpm -ql python3-numpy | grep bin
/usr/bin/f2py
/usr/bin/f2py3
/usr/bin/f2py3.7
Comment 8 Dominik Heidler 2019-07-31 15:19:57 UTC
.