Bug 1143313 - [Build 20190728] openQA test fails in docker
[Build 20190728] openQA test fails in docker
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Containers
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Fabian Vogt
E-mail List
https://openqa.opensuse.org/tests/994...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-07-29 19:23 UTC by Dominique Leuenberger
Modified: 2019-07-31 15:04 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Leuenberger 2019-07-29 19:23:44 UTC
## Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-extra_tests_in_textmode@64bit fails in
[docker](https://openqa.opensuse.org/tests/994789/modules/docker/steps/57)

## Test suite description
Maintainer: okurz@suse.de

Mainly console extratest.


## Reproducible

Fails since (at least) Build [20190716](https://openqa.opensuse.org/tests/984307)


## Expected result

Last good: [20190713](https://openqa.opensuse.org/tests/983791) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?arch=x86_64&distri=opensuse&flavor=DVD&machine=64bit&test=extra_tests_in_textmode&version=Tumbleweed)
Comment 1 Dominique Leuenberger 2019-07-29 19:25:07 UTC
This snapshot contained a docker update :
https://lists.opensuse.org/opensuse-commit/2019-07/msg01556.html
Comment 2 Flavio Castelli 2019-07-30 06:54:04 UTC
Everything looks fine on the linked openQA tests, however I can find failures in more recent ones: https://openqa.opensuse.org/tests/994788


Adding all the containers folks on CC.
Comment 3 Marco Vedovati 2019-07-31 12:46:30 UTC
The failing test:

docker run --init --rm opensuse/tumbleweed ps --no-headers -xo "pid args" | grep "1 /dev/init"

is because, starting from Docker 19.03, the init process is mount binded to /sbin/docker-init instead of /dev/init, to support the use case of users mounting `/dev` inside a container.

You may update the test to check for the new init path.
Comment 4 Flavio Castelli 2019-07-31 13:51:35 UTC
@fabian: I think you're the maintainer of this test (at least openQA says so). Could you change the test to reflect what Marco wrote in the previous comment?
Comment 5 Fabian Vogt 2019-07-31 14:32:54 UTC
(In reply to Flavio Castelli from comment #4)
> @fabian: I think you're the maintainer of this test (at least openQA says
> so)

Where? The docker test module says:

# Maintainer: Flavio Castelli <fcastelli@suse.com>, Panagiotis Georgiadis <pgeorgiadis@suse.com>, Sergio Lindo Mansilla <slindomansilla@suse.com>

> Could you change the test to reflect what Marco wrote in the previous comment?

Sure, should be a small change.
Comment 6 Fabian Vogt 2019-07-31 14:50:34 UTC
(In reply to Fabian Vogt from comment #5)
> (In reply to Flavio Castelli from comment #4)
> > Could you change the test to reflect what Marco wrote in the previous comment?
> 
> Sure, should be a small change.

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/8084
Comment 7 Flavio Castelli 2019-07-31 15:04:57 UTC
@fabian: thanks a lot for stepping in.

I was "mislead" by the following text:

Maintainer: fvogt@suse.com This test's main job is to configure a docker host and install the docker image built within the current product and test it. 

I found it over there: https://openqa.opensuse.org/tests/994788